summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-03-08 23:05:08 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-03-08 23:05:08 +0000
commit4b63a2a741ab7ee588b1a1e1860480c226ad33b0 (patch)
treec4ef37f91ae2900c55d2f56863d3ec98cc4cfcdd /app-emulation
parentMarking gromacs-4.5.5-r1 ppc64 for bug 391147 (diff)
downloadgentoo-2-4b63a2a741ab7ee588b1a1e1860480c226ad33b0.tar.gz
gentoo-2-4b63a2a741ab7ee588b1a1e1860480c226ad33b0.tar.bz2
gentoo-2-4b63a2a741ab7ee588b1a1e1860480c226ad33b0.zip
Only warn about the lack of kvm-amd or kvm-intel on amd64 and x86.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog5
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild8
2 files changed, 10 insertions, 3 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index 02a77b53e289..f8335cb67bc2 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.109 2012/03/08 18:26:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.110 2012/03/08 23:05:08 cardoe Exp $
+
+ 08 Mar 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.0-r3.ebuild:
+ Only warn about the lack of kvm-amd or kvm-intel on amd64 and x86.
08 Mar 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.0-r3.ebuild:
Prefix with spaces rather than suffix for wrapped lines cause #gentoo-dev
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
index 8f97bce20079..c7dc68ea7a1b 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild,v 1.10 2012/03/08 18:26:38 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild,v 1.11 2012/03/08 23:05:08 cardoe Exp $
#BACKPORTS=1
@@ -144,7 +144,7 @@ pkg_pretend() {
if ! linux_config_exists; then
eerror "Unable to check your kernel for KVM support"
else
- CONFIG_CHECK="~KVM ~KVM_AMD ~KVM_INTEL ~TUN ~BRIDGE"
+ CONFIG_CHECK="~KVM ~TUN ~BRIDGE"
ERROR_KVM="You must enable KVM in your kernel to continue"
ERROR_KVM_AMD="If you have an AMD CPU, you must enable KVM_AMD in"
ERROR_KVM_AMD+=" your kernel configuration."
@@ -159,6 +159,10 @@ pkg_pretend() {
ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net"
ERROR_VHOST_NET+=" support"
+ if use amd64 || use x86 || use amd64-linux || use x86-linux; then
+ CONFIG_CHECK+=" ~KVM_AMD ~KVM_INTEL"
+ fi
+
# Now do the actual checks setup above
check_extra_config
fi