summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-24 05:53:07 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-24 05:53:07 +0000
commit507d4d68b99725a18e91de7f0d8af01dff39086a (patch)
tree7bc8e345291426182d8fe30c68cc4c6bfa993be8 /app-emulation
parentupdated for new tiff and bug 66794 (Manifest recommit) (diff)
downloadgentoo-2-507d4d68b99725a18e91de7f0d8af01dff39086a.tar.gz
gentoo-2-507d4d68b99725a18e91de7f0d8af01dff39086a.tar.bz2
gentoo-2-507d4d68b99725a18e91de7f0d8af01dff39086a.zip
ver bump #64065 and patch fix #61721
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/point2play/ChangeLog8
-rw-r--r--app-emulation/point2play/files/1.3.2-fix-sound-test.patch20
-rw-r--r--app-emulation/point2play/files/digest-point2play-1.3.21
-rw-r--r--app-emulation/point2play/point2play-1.3.2.ebuild40
4 files changed, 68 insertions, 1 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 1ac1042f02d2..508089488726 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.14 2004/08/14 06:35:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.15 2004/10/24 05:53:07 vapier Exp $
+
+*point2play-1.3.2 (24 Oct 2004)
+
+ 24 Oct 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.3.2-fix-sound-test.patch, +point2play-1.3.2.ebuild:
+ Version bump #64065 by Alex Rostovtsev and patch fix #61721 by fury.
*point2play-1.3.1 (14 Aug 2004)
diff --git a/app-emulation/point2play/files/1.3.2-fix-sound-test.patch b/app-emulation/point2play/files/1.3.2-fix-sound-test.patch
new file mode 100644
index 000000000000..b7e90ce680c5
--- /dev/null
+++ b/app-emulation/point2play/files/1.3.2-fix-sound-test.patch
@@ -0,0 +1,20 @@
+--- usr/lib/transgaming_point2play/tests/test_sound.py.orig 2004-09-14 19:10:30.409212936 -0400
++++ usr/lib/transgaming_point2play/tests/test_sound.py 2004-09-14 19:15:05.541386488 -0400
+@@ -40,15 +40,13 @@
+ # OSS Portion of the test
+ #
+ try:
+- audio_out = ossaudiodev.open('/dev/dsp', 'w')
++ audio_out = ossaudiodev.open('w')
+ except IOError, e:
+ OSSResult = ((_('OSS Sound Support'), _('Unable to open /dev/dsp'), 'red'))
+
+ if audio_out:
+ try:
+- audio_out.setparameters(TestSound1.getframerate(), 16,
+- TestSound1.getnchannels(), ossaudiodev.AFMT_S16_LE, False)
+- #FIXME: use getsampwidth for 16 and AFMT_S16_LE
++ audio_out.setparameters(ossaudiodev.AFMT_S16_LE, TestSound1.getnchannels(), TestSound1.getframerate())
+ except:
+ audio_out.close()
+ OSSResult = ((_('OSS Sound Support'), _('Unable to play sound, your\nSound card may not be configured correctly'), 'red'))
diff --git a/app-emulation/point2play/files/digest-point2play-1.3.2 b/app-emulation/point2play/files/digest-point2play-1.3.2
new file mode 100644
index 000000000000..dddef0b2244c
--- /dev/null
+++ b/app-emulation/point2play/files/digest-point2play-1.3.2
@@ -0,0 +1 @@
+MD5 a9e7c130588201e8973147d58427470c point2play-small-1.3.2.tgz 824970
diff --git a/app-emulation/point2play/point2play-1.3.2.ebuild b/app-emulation/point2play/point2play-1.3.2.ebuild
new file mode 100644
index 000000000000..ad4c1fea0bf9
--- /dev/null
+++ b/app-emulation/point2play/point2play-1.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.2.ebuild,v 1.1 2004/10/24 05:53:07 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-1.99.16
+ >=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr ${D}/
+ mv etc/X11/applnk ${D}/usr/share
+}