summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-08-18 21:44:47 +0000
committerTravis Tilley <lv@gentoo.org>2004-08-18 21:44:47 +0000
commit52abcfad3850dd88ad9bb37d0abd6fa3d2323277 (patch)
tree8978e9086e05971974536cc57d3d9a3a7e6783da /app-emulation
parentversion bump, added more integrated logic, most parts should work now (Manife... (diff)
downloadgentoo-2-52abcfad3850dd88ad9bb37d0abd6fa3d2323277.tar.gz
gentoo-2-52abcfad3850dd88ad9bb37d0abd6fa3d2323277.tar.bz2
gentoo-2-52abcfad3850dd88ad9bb37d0abd6fa3d2323277.zip
fix linker script fix thingie thing thing
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild b/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
index 1cde27e0b59d..064be3846a84 100644
--- a/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
+++ b/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild,v 1.1 2004/08/16 20:40:54 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/emul-linux-x86-glibc/emul-linux-x86-glibc-1.1.ebuild,v 1.2 2004/08/18 21:44:47 lv Exp $
DESCRIPTION="GNU C Library for emulation of 32bit x86 on amd64"
HOMEPAGE="http://www.gentoo.org/"
@@ -27,12 +27,13 @@ src_install() {
mkdir -p ${D}/usr
ln -sf /emul/linux/x86/usr/lib ${D}/usr/lib32
- cp -aRpvf ${WORKDIR}/* ${D}/
-
+ cd ${WORKDIR}/emul/linux/x86/usr/lib32 || die
# fix linker scripts to point to lib32
sed -i -e "s/\/lib\//\/lib32\//g" libc.so
sed -i -e "s/\/lib\//\/lib32\//g" libpthread.so
+ cp -aRpvf ${WORKDIR}/* ${D}/
+
# create env.d entry
mkdir -p ${D}/etc/env.d
cat > ${D}/etc/env.d/40emul-linux-x86-glibc <<ENDOFENV