summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-02-29 12:01:42 +0000
committerHanno Böck <hanno@gentoo.org>2008-02-29 12:01:42 +0000
commit636247810f5915dc2fc045495907e3f16b3c2c6a (patch)
treeb063a9651879803979660abe6ce06691f67e1c3b /app-emulation
parentFixed security issue (CVE-2008-0411), bug #208999, thank Robert Buchholz for ... (diff)
downloadgentoo-2-636247810f5915dc2fc045495907e3f16b3c2c6a.tar.gz
gentoo-2-636247810f5915dc2fc045495907e3f16b3c2c6a.tar.bz2
gentoo-2-636247810f5915dc2fc045495907e3f16b3c2c6a.zip
big cleanup of old dosemu stuff
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/dosemu/dosemu-1.2.2-r1.ebuild68
-rw-r--r--app-emulation/dosemu/dosemu-1.3.2.ebuild70
-rw-r--r--app-emulation/dosemu/dosemu-1.3.3.ebuild71
-rw-r--r--app-emulation/dosemu/dosemu-1.3.4.ebuild69
-rw-r--r--app-emulation/dosemu/dosemu-1.3.5.ebuild68
-rw-r--r--app-emulation/dosemu/files/dosemu-1.2.2-cflags.patch83
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch87
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff27
-rw-r--r--app-emulation/dosemu/files/dosemu-1.3.5-slang2.diff32
-rw-r--r--app-emulation/dosemu/files/dosemu-broken-links.diff11
-rw-r--r--app-emulation/dosemu/files/dosemu-compile-asm.diff11
11 files changed, 0 insertions, 597 deletions
diff --git a/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild b/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild
deleted file mode 100644
index 14bd2d774dbd..000000000000
--- a/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.2.2-r1.ebuild,v 1.11 2007/07/22 09:15:42 omp Exp $
-
-inherit flag-o-matic eutils
-
-P_FD=dosemu-freedos-b9r5-bin
-DESCRIPTION="DOS Emulator"
-HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- mirror://sourceforge/dosemu/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE="X svga gpm debug"
-
-RDEPEND="X? ( x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-proto/xf86dgaproto )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
- =sys-libs/slang-1.4*"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
- epatch ${FILESDIR}/${PN}-broken-links.diff
- epatch ${FILESDIR}/${P}-cflags.patch
-
- WANT_AUTOCONF=2.5
- autoconf || die "autoconf failed"
-}
-
-src_compile() {
- local myflags="--sysconfdir=/etc/dosemu/ \
- --with-mandir=/usr/share/man/"
-
- unset KERNEL
- use X || myflags="${myflags} --with-x=no"
- use svga && myflags="${myflags} --enable-use-svgalib"
- use gpm || myflags="${myflags} --without-gpm"
- use debug && myflags="${myflags} --enable-debug"
-
- # Has problems with -O3 on some systems
- replace-flags -O[3-9] -O2
-
- # Fix compilation on hardened
- append-flags -fno-pic
-
- econf ${myflags} || die "DOSemu Base Configuration Failed"
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- dodoc doc/*
- rm -rf ${D}/usr/share/doc/dosemu
-
- # freedos tarball is needed in /usr/share/dosemu
- cp ${DISTDIR}/${P_FD}.tgz ${D}/usr/share/dosemu/dosemu-freedos-bin.tgz
-}
diff --git a/app-emulation/dosemu/dosemu-1.3.2.ebuild b/app-emulation/dosemu/dosemu-1.3.2.ebuild
deleted file mode 100644
index f4a2d41bafff..000000000000
--- a/app-emulation/dosemu/dosemu-1.3.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.2.ebuild,v 1.5 2007/07/22 09:15:42 omp Exp $
-
-inherit flag-o-matic eutils
-
-P_FD=dosemu-freedos-b9r5-bin
-DESCRIPTION="DOS Emulator"
-HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- mirror://sourceforge/dosemu/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~x86"
-IUSE="X svga gpm debug"
-
-RDEPEND="X? ( x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-proto/xf86dgaproto
- x11-apps/xset
- x11-apps/xlsfonts )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
- =sys-libs/slang-1.4*"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
- epatch ${FILESDIR}/${PN}-broken-links.diff
- epatch ${FILESDIR}/dosemu-1.2.2-cflags.patch
-
- WANT_AUTOCONF=2.5
- autoconf || die "autoconf failed"
-}
-
-src_compile() {
- local myflags="--sysconfdir=/etc/dosemu/ \
- --with-mandir=/usr/share/man/"
-
- unset KERNEL
- use X || myflags="${myflags} --with-x=no"
- use svga && myflags="${myflags} --enable-use-svgalib"
- use gpm || myflags="${myflags} --without-gpm"
- use debug && myflags="${myflags} --enable-debug"
-
- # Has problems with -O3 on some systems
- replace-flags -O[3-9] -O2
-
- # Fix compilation on hardened
- append-flags -fno-pic
-
- econf ${myflags} || die "DOSemu Base Configuration Failed"
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
-
- dodoc doc/*
- rm -rf ${D}/usr/share/doc/dosemu
-
- # freedos tarball is needed in /usr/share/dosemu
- cp ${DISTDIR}/${P_FD}.tgz ${D}/usr/share/dosemu/dosemu-freedos-bin.tgz
-}
diff --git a/app-emulation/dosemu/dosemu-1.3.3.ebuild b/app-emulation/dosemu/dosemu-1.3.3.ebuild
deleted file mode 100644
index 6bda11c9b34c..000000000000
--- a/app-emulation/dosemu/dosemu-1.3.3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.3.ebuild,v 1.5 2007/02/25 15:27:55 drac Exp $
-
-inherit flag-o-matic eutils autotools
-
-P_FD=dosemu-freedos-b9r5a-bin
-DESCRIPTION="DOS Emulator"
-HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- mirror://sourceforge/dosemu/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* x86"
-IUSE="X svga gpm debug"
-
-RDEPEND="gpm? ( sys-libs/gpm )
- X? ( x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-proto/xf86dgaproto
- x11-apps/xset
- x11-apps/xlsfonts
- x11-apps/bdftopcf
- x11-apps/mkfontdir )
- svga? ( media-libs/svgalib )
- =sys-libs/slang-1.4*"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
-
- epatch ${FILESDIR}/${P}-configure.ac.patch
-
- eautoreconf || die "autoconf failed"
-}
-
-src_compile() {
- # Has problems with -O3 on some systems
- replace-flags -O[3-9] -O2
-
- # Fix compilation on hardened
- append-flags -fno-pic
-
- unset KERNEL
-
- use X || myflags="--with-x=no"
-
- ./default-configure ${myflags} \
- `use_enable svga svgalib` \
- `use_enable debug` \
- `use_with gpm` \
- --with-fdtarball=${DISTDIR}/${P_FD}.tgz \
- --sysconfdir=/etc/dosemu/ \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-docdir=/usr/share/doc/${PF} || die
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- # Don't remove COPYING, see bug #137286
- dodoc Bugs ChangeLog COPYING NEWS THANKS
-}
diff --git a/app-emulation/dosemu/dosemu-1.3.4.ebuild b/app-emulation/dosemu/dosemu-1.3.4.ebuild
deleted file mode 100644
index 3a52c388cc96..000000000000
--- a/app-emulation/dosemu/dosemu-1.3.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.4.ebuild,v 1.2 2007/07/22 09:15:42 omp Exp $
-
-inherit flag-o-matic eutils autotools
-
-P_FD=dosemu-freedos-b9r5a-bin
-DESCRIPTION="DOS Emulator"
-HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- mirror://sourceforge/dosemu/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~x86"
-IUSE="X svga gpm debug"
-
-RDEPEND="X? ( x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-proto/xf86dgaproto
- x11-apps/xset
- x11-apps/xlsfonts
- x11-apps/bdftopcf
- x11-apps/mkfontdir )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
- >=sys-libs/slang-1.4"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
-
- epatch ${FILESDIR}/dosemu-1.3.3-configure.ac.patch
- epatch ${FILESDIR}/dosemu-1.3.4-shm.diff
- epatch ${FILESDIR}/dosemu-1.3.4-slang2.diff
- epatch ${FILESDIR}/dosemu-compile-asm.diff
-
- eautoreconf || die "autoconf failed"
-}
-
-src_compile() {
- # Has problems with -O3 on some systems
- replace-flags -O[3-9] -O2
-
- # Fix compilation on hardened
- append-flags -fno-pic
-
- unset KERNEL
-
- econf `use_with X x` \
- `use_enable svga svgalib` \
- `use_enable debug` \
- `use_with gpm` \
- --with-fdtarball=${DISTDIR}/${P_FD}.tgz \
- --sysconfdir=/etc/dosemu/ \
- --with-docdir=/usr/share/doc/${PF} || die
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- # Don't remove COPYING, see bug #137286
- dodoc Bugs ChangeLog COPYING NEWS THANKS
-}
diff --git a/app-emulation/dosemu/dosemu-1.3.5.ebuild b/app-emulation/dosemu/dosemu-1.3.5.ebuild
deleted file mode 100644
index c062aeb2e3fd..000000000000
--- a/app-emulation/dosemu/dosemu-1.3.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/dosemu/dosemu-1.3.5.ebuild,v 1.2 2007/07/22 09:15:42 omp Exp $
-
-inherit flag-o-matic eutils autotools
-
-P_FD=dosemu-freedos-1.0-bin
-DESCRIPTION="DOS Emulator"
-HOMEPAGE="http://www.dosemu.org/"
-SRC_URI="mirror://sourceforge/dosemu/${P_FD}.tgz
- mirror://sourceforge/dosemu/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* ~x86"
-IUSE="X svga gpm debug"
-
-RDEPEND="X? ( x11-libs/libXxf86vm
- x11-libs/libXau
- x11-libs/libXdmcp
- x11-proto/xf86dgaproto
- x11-apps/xset
- x11-apps/xlsfonts
- x11-apps/bdftopcf
- x11-apps/mkfontdir )
- svga? ( media-libs/svgalib )
- gpm? ( sys-libs/gpm )
- >=sys-libs/slang-1.4"
-
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.57"
-
-src_unpack() {
- unpack ${P}.tgz
- cd ${S}
-
- epatch ${FILESDIR}/dosemu-1.3.3-configure.ac.patch
- epatch ${FILESDIR}/dosemu-1.3.4-shm.diff
- epatch ${FILESDIR}/dosemu-1.3.5-slang2.diff
-
- eautoreconf || die "autoconf failed"
-}
-
-src_compile() {
- # Has problems with -O3 on some systems
- replace-flags -O[3-9] -O2
-
- # Fix compilation on hardened
- append-flags -fno-pic
-
- unset KERNEL
-
- econf `use_with X x` \
- `use_enable svga svgalib` \
- `use_enable debug` \
- `use_with gpm` \
- --with-fdtarball=${DISTDIR}/${P_FD}.tgz \
- --sysconfdir=/etc/dosemu/ \
- --with-docdir=/usr/share/doc/${PF} || die
-
- emake || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- # Don't remove COPYING, see bug #137286
- dodoc Bugs ChangeLog COPYING NEWS THANKS
-}
diff --git a/app-emulation/dosemu/files/dosemu-1.2.2-cflags.patch b/app-emulation/dosemu/files/dosemu-1.2.2-cflags.patch
deleted file mode 100644
index c779b3077d6a..000000000000
--- a/app-emulation/dosemu/files/dosemu-1.2.2-cflags.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- dosemu-1.2.2/configure.ac.orig 2005-04-04 21:58:49.635588970 -0700
-+++ dosemu-1.2.2/configure.ac 2005-04-04 21:56:35.277976095 -0700
-@@ -15,7 +15,6 @@ AC_CONFIG_HEADER(src/include/config.h)
- AC_CANONICAL_TARGET([])
-
- dnl Checks for programs.
--OPT=$CFLAGS
- AC_PROG_CC
- AC_PROG_GCC_TRADITIONAL
- AC_PROG_AWK
-@@ -447,19 +446,6 @@ dnl Now CFLAGS and INCLUDES
- INCDIR="-I\${top_builddir}/src/include -I\${top_builddir}/src/plugin/include ${SLANGINC}"
- AC_SUBST(INCDIR)
-
--CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs"
--if test -z "$OPT"; then
-- if test "$enable_debug" = "yes"; then
-- CFLAGS="$CFLAGS -g"
-- AC_DEFINE(_DEBUG)
-- OPT="-O"
-- else
-- OPT="-O2" # BIG NOTE: do _not_ use -O3,
-- # because in forces _inline_ at places where we don't want it !
-- # If we want _inline_, well then we 'code' it.
-- OPT="$OPT -fomit-frame-pointer" # never omit the frame pointer when debugging!
-- fi
--fi
- if test "$enable_debug" = "yes"; then
- AC_DEFINE(_DEBUG)
- fi
-@@ -509,7 +495,6 @@ if test "$CONFIG_HOST" = "linux"; then
- AC_MSG_NOTICE(Compiling with network support...);
- AC_DEFINE(USING_NET)
- fi
-- PIPE=-pipe
- fi
-
-
-@@ -545,36 +530,6 @@ if test "$GCC" = "yes" ; then
- fi
-
-
-- # -m486 is usually in the specs for the compiler
-- # but gcc-3.0 wants -mcpu=i486 instead
-- # and gcc-3.4 wants -mtune=i486 instead
-- # let the compiler options be dependent of the _target_
-- # where dosemu is compiled for, not the host
-- if test "$target_cpu" = "athlon" -a $GCC_VERSION_CODE -le 2095 ; then
-- target_cpu="i686"
-- fi
-- if test "$GCC_VERSION_CODE" -ge 3004 ; then
-- OPT="$OPT -mtune=$target_cpu"
-- elif test "$GCC_VERSION_CODE" -ge 2095 ; then
-- OPT="$OPT -mcpu=$target_cpu"
-- else
-- case "$target_cpu" in
-- i486)
-- OPT="$OPT -m486"
-- ;;
-- i386)
-- OPT="$OPT -m386"
-- ;;
-- *)
-- ;;
-- esac
-- fi
-- if test "$target_cpu" = "athlon"; then
-- OPT="$OPT -malign-functions=4 -fexpensive-optimizations"
-- elif test "$target_cpu" = "i486"; then
-- OPT="$OPT -malign-loops=2 -malign-jumps=2 -malign-functions=2"
-- fi
--
- AC_MSG_CHECKING(for glibc...)
- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|gcc -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
- major=$1; minor=$2
-@@ -595,7 +550,6 @@ AC_DEFINE_UNQUOTED(GCC_VERSION_CODE,$GCC
- AC_SUBST(ASM_PEDANTIC)
- AC_DEFINE(_GNU_SOURCE)
-
--CFLAGS="${CFLAGS} ${OPT} ${PIPE}"
- CPPFLAGS="${CPPFLAGS} -MMD \${INCDIR}"
- AC_SUBST(LDFLAGS)
- AC_SUBST(LIBS)
diff --git a/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch b/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch
deleted file mode 100644
index 51dfe03202af..000000000000
--- a/app-emulation/dosemu/files/dosemu-1.3.3-configure.ac.patch
+++ /dev/null
@@ -1,87 +0,0 @@
---- dosemu-old/configure.ac 2005-12-21 20:47:43.000000000 -0500
-+++ dosemu-1.3.3/configure.ac 2006-02-23 15:07:06.000000000 -0500
-@@ -15,7 +15,6 @@
- AC_CANONICAL_TARGET([])
-
- dnl Checks for programs.
--OPT=$CFLAGS
- AC_PROG_CC
- if test "$host_cpu" = "x86_64" -a -z "$CPPFLAGS"; then
- # 64bit long mode dosemu is not yet
-@@ -478,19 +477,6 @@
- INCDIR="-I\${top_builddir}/src/include -I\${top_builddir}/src/plugin/include"
- AC_SUBST(INCDIR)
-
--CFLAGS="-Wall -Wstrict-prototypes -Wmissing-declarations -Wnested-externs"
--if test -z "$OPT"; then
-- if test "$enable_debug" = "yes"; then
-- CFLAGS="$CFLAGS -g"
-- AC_DEFINE(_DEBUG)
-- OPT="-O"
-- else
-- OPT="-O2" # BIG NOTE: do _not_ use -O3,
-- # because in forces _inline_ at places where we don't want it !
-- # If we want _inline_, well then we 'code' it.
-- OPT="$OPT -fomit-frame-pointer" # never omit the frame pointer when debugging!
-- fi
--fi
- if test "$enable_debug" = "yes"; then
- AC_DEFINE(_DEBUG)
- fi
-@@ -540,7 +526,6 @@
- AC_MSG_NOTICE(Compiling with network support...);
- AC_DEFINE(USING_NET)
- fi
-- PIPE=-pipe
- fi
-
-
-@@ -590,39 +575,6 @@
- fi
-
-
-- # -m486 is usually in the specs for the compiler
-- # but gcc-3.0 wants -mcpu=i486 instead
-- # and gcc-3.4 wants -mtune=i486 instead
-- # let the compiler options be dependent of the _target_
-- # where dosemu is compiled for, not the host
-- if test "$target_cpu" = "athlon" -a $GCC_VERSION_CODE -le 2095 ; then
-- target_cpu="i686"
-- fi
-- if test "$target_cpu" = "x86_64"; then
-- target_cpu="k8"
-- fi
-- if test "$GCC_VERSION_CODE" -ge 3004 ; then
-- OPT="$OPT -mtune=$target_cpu"
-- elif test "$GCC_VERSION_CODE" -ge 2095 ; then
-- OPT="$OPT -mcpu=$target_cpu"
-- else
-- case "$target_cpu" in
-- i486)
-- OPT="$OPT -m486"
-- ;;
-- i386)
-- OPT="$OPT -m386"
-- ;;
-- *)
-- ;;
-- esac
-- fi
-- if test "$target_cpu" = "athlon"; then
-- OPT="$OPT -malign-functions=4 -fexpensive-optimizations"
-- elif test "$target_cpu" = "i486"; then
-- OPT="$OPT -malign-loops=2 -malign-jumps=2 -malign-functions=2"
-- fi
--
- AC_MSG_CHECKING(for glibc...)
- set `printf '%b\n' '#include <features.h>\nXXAaZZ __GLIBC__ XXBbZZ __GLIBC_MINOR__'|${CC-cc} -E -|awk '/XXAaZZ/ {print $2 " " $4}'`
- major=$1; minor=$2
-@@ -643,7 +595,7 @@
- AC_SUBST(ASM_PEDANTIC)
- AC_DEFINE(_GNU_SOURCE)
-
--CFLAGS="${CFLAGS} ${OPT} ${PIPE}"
-+CFLAGS=${OPT}
- CPPFLAGS="${CPPFLAGS} -MMD"
- AC_SUBST(LDFLAGS)
- AC_SUBST(LIBS)
diff --git a/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff b/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff
deleted file mode 100644
index dbf4a2ac6893..000000000000
--- a/app-emulation/dosemu/files/dosemu-1.3.4-slang2.diff
+++ /dev/null
@@ -1,27 +0,0 @@
---- dosemu-1.1.5-old/configure.ac
-+++ dosemu-1.1.5/configure.ac
-@@ -262,8 +262,8 @@
- else
- if test -d $prefix/include/slang; then
- SLANGINC="-I${prefix}/include/slang"
-- elif test -d /usr/include/slang; then
-- SLANGINC="-I/usr/include/slang"
-+ elif test -d /usr/include/slang-2; then
-+ SLANGINC="-I/usr/include/slang-2"
- fi
- fi
- else
-@@ -286,11 +286,11 @@
- AC_MSG_RESULT($SLANGINC $SLANGLIB)
- have_slang="no"
- AC_CHECK_HEADER(slang.h,
-- AC_CHECK_LIB(slang, SLtt_get_terminfo,
-+ AC_CHECK_LIB(slang-2, SLtt_get_terminfo,
- AC_MSG_NOTICE(Compiling with S-Lang support...)
- have_slang="yes"
- AC_DEFINE(USE_SLANG)
-- SLANGLIB="$SLANGLIB -lslang -lm",
-+ SLANGLIB="$SLANGLIB -lslang-2 -lm",
- [AC_MSG_WARN([No S-Lang library found.])]
- $srcdir/mkpluginhooks enable term no
- ),
diff --git a/app-emulation/dosemu/files/dosemu-1.3.5-slang2.diff b/app-emulation/dosemu/files/dosemu-1.3.5-slang2.diff
deleted file mode 100644
index 464ed9a7e75d..000000000000
--- a/app-emulation/dosemu/files/dosemu-1.3.5-slang2.diff
+++ /dev/null
@@ -1,32 +0,0 @@
---- dosemu-1.3.5/configure.ac 2006-12-10 15:03:24.000000000 +0100
-+++ dosemu-1.3.5-fix/configure.ac 2007-05-02 04:46:00.000000000 +0200
-@@ -291,6 +291,8 @@
- SLANGINC="-I${prefix}/include/slang"
- elif test -d /usr/include/slang; then
- SLANGINC="-I/usr/include/slang"
-+ elif test -d /usr/include/slang-2; then
-+ SLANGINC="-I/usr/include/slang-2"
- fi
- fi
- else
-@@ -313,13 +315,19 @@
- AC_MSG_RESULT($SLANGINC $SLANGLIB)
- have_slang="no"
- AC_CHECK_HEADER(slang.h,
-+ AC_CHECK_LIB(slang-2, SLtt_get_terminfo,
-+ AC_MSG_NOTICE(Compiling with S-Lang support...)
-+ have_slang="yes"
-+ AC_DEFINE(USE_SLANG)
-+ SLANGLIB="$SLANGLIB -lslang-2 -lm",
-+ [AC_MSG_WARN([No S-Lang library found.])]
-+ ),
- AC_CHECK_LIB(slang, SLtt_get_terminfo,
- AC_MSG_NOTICE(Compiling with S-Lang support...)
- have_slang="yes"
- AC_DEFINE(USE_SLANG)
- SLANGLIB="$SLANGLIB -lslang -lm",
- [AC_MSG_WARN([No S-Lang library found.])]
-- $srcdir/mkpluginhooks enable term no
- ),
- [AC_MSG_WARN([No S-Lang header file found.])]
- $srcdir/mkpluginhooks enable term no
diff --git a/app-emulation/dosemu/files/dosemu-broken-links.diff b/app-emulation/dosemu/files/dosemu-broken-links.diff
deleted file mode 100644
index 2c1db5848cd3..000000000000
--- a/app-emulation/dosemu/files/dosemu-broken-links.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- dosemu-1.1.5/src/arch/linux/Makefile.main~ 2003-06-06 23:32:21.000000000 +0100
-+++ dosemu-1.1.5/src/arch/linux/Makefile.main 2003-06-20 15:22:19.000000000 +0100
-@@ -158,7 +158,7 @@
- cd $(SYS); for i in `find * -type l`; do \
- ln -sf generic.com $(TMP)/dosemu/freedos/dosemu/$$i; \
- done
-- cp -a $(TMP)/dosemu/freedos $(DESTDIR)$(dosemudir)
-+ cp -aL $(TMP)/dosemu/freedos $(DESTDIR)$(dosemudir)
- rm -f $(DESTDIR)$(dosemudir)/commands
- ln -sf freedos/dosemu $(DESTDIR)$(dosemudir)/commands
- cd $(TMP)/dosemu; \
diff --git a/app-emulation/dosemu/files/dosemu-compile-asm.diff b/app-emulation/dosemu/files/dosemu-compile-asm.diff
deleted file mode 100644
index a404d57cf4ab..000000000000
--- a/app-emulation/dosemu/files/dosemu-compile-asm.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- dosemu-1.3.4/src/env/video/instremu.c 2006-11-11 23:22:27.000000000 +0100
-+++ dosemu-1.3.4-p/src/env/video/instremu.c 2007-01-30 13:36:08.000000000 +0100
-@@ -112,7 +112,7 @@
- shr $1, %0\n\
- "#insn" %4, %1\n\
- pushf; pop %0\n \
-- " : "=g" (eflags), #istype (op1) : "0" (eflags), "1" (op1), #type (op2));
-+ " : "=r" (eflags), #istype (op1) : "0" (eflags), "1" (op1), #type (op2));
-
-
- #if !defined True