summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-06-27 00:34:36 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-06-27 00:34:36 +0000
commit693b32e78d5288095538fe4a5b4c43d90ddaec47 (patch)
tree15b85ed56ce996ba59269978620d9020eeb5a3c2 /app-emulation
parentkeyword amd64-linux x86-linux (diff)
downloadgentoo-2-693b32e78d5288095538fe4a5b4c43d90ddaec47.tar.gz
gentoo-2-693b32e78d5288095538fe4a5b4c43d90ddaec47.tar.bz2
gentoo-2-693b32e78d5288095538fe4a5b4c43d90ddaec47.zip
Clean up some USE flags.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/libvirt/ChangeLog6
-rw-r--r--app-emulation/libvirt/libvirt-0.9.12-r1.ebuild8
-rw-r--r--app-emulation/libvirt/libvirt-9999.ebuild8
-rw-r--r--app-emulation/libvirt/metadata.xml2
4 files changed, 10 insertions, 14 deletions
diff --git a/app-emulation/libvirt/ChangeLog b/app-emulation/libvirt/ChangeLog
index 46001e34d2d6..1604c49452e7 100644
--- a/app-emulation/libvirt/ChangeLog
+++ b/app-emulation/libvirt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/libvirt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.189 2012/06/26 02:38:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/ChangeLog,v 1.190 2012/06/27 00:34:36 cardoe Exp $
+
+ 26 Jun 2012; Doug Goldstein <cardoe@gentoo.org> libvirt-0.9.12-r1.ebuild,
+ libvirt-9999.ebuild, metadata.xml:
+ Clean up some USE flags.
*libvirt-0.9.12-r1 (25 Jun 2012)
diff --git a/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild b/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild
index efdff589fed6..d749a85e9491 100644
--- a/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild
+++ b/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild,v 1.1 2012/06/26 02:38:34 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-0.9.12-r1.ebuild,v 1.2 2012/06/27 00:34:36 cardoe Exp $
EAPI=4
@@ -37,7 +37,6 @@ SLOT="0"
IUSE="audit avahi +caps debug iscsi +libvirtd lvm +lxc +macvtap nfs \
nls numa openvz parted pcap phyp policykit python qemu sasl selinux +udev \
uml +vepa virtualbox virt-network xen elibc_glibc"
-# IUSE=one : bug #293416 & bug #299011
REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
lxc? ( caps libvirtd )
openvz? ( libvirtd )
@@ -191,6 +190,7 @@ src_configure() {
myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
# leave it automagic as it depends on the version of xen used.
use xen || myconf+=" --without-libxl"
+ use xen || myconf+=" --without-xenapi"
myconf="${myconf} $(use_with openvz)"
myconf="${myconf} $(use_with lxc)"
@@ -202,10 +202,6 @@ src_configure() {
myconf="${myconf} $(use_with uml)"
myconf="${myconf} $(use_with qemu)"
myconf="${myconf} $(use_with qemu yajl)" # Use QMP over HMP
- # doesn't belong with hypervisors but links to libvirtd for some reason
- #myconf="${myconf} $(use_with one)"
-
- ## hypervisor protocols
myconf="${myconf} $(use_with phyp)"
myconf="${myconf} --with-esx"
diff --git a/app-emulation/libvirt/libvirt-9999.ebuild b/app-emulation/libvirt/libvirt-9999.ebuild
index ae22d278b53c..1219518a3617 100644
--- a/app-emulation/libvirt/libvirt-9999.ebuild
+++ b/app-emulation/libvirt/libvirt-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.36 2012/06/26 02:38:33 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libvirt/libvirt-9999.ebuild,v 1.37 2012/06/27 00:34:36 cardoe Exp $
EAPI=4
@@ -37,7 +37,6 @@ SLOT="0"
IUSE="audit avahi +caps debug iscsi +libvirtd lvm +lxc +macvtap nfs \
nls numa openvz parted pcap phyp policykit python qemu sasl selinux +udev \
uml +vepa virtualbox virt-network xen elibc_glibc"
-# IUSE=one : bug #293416 & bug #299011
REQUIRED_USE="libvirtd? ( || ( lxc openvz qemu uml virtualbox xen ) )
lxc? ( caps libvirtd )
openvz? ( libvirtd )
@@ -191,6 +190,7 @@ src_configure() {
myconf="${myconf} $(use_with xen) $(use_with xen xen-inotify)"
# leave it automagic as it depends on the version of xen used.
use xen || myconf+=" --without-libxl"
+ use xen || myconf+=" --without-xenapi"
myconf="${myconf} $(use_with openvz)"
myconf="${myconf} $(use_with lxc)"
@@ -202,10 +202,6 @@ src_configure() {
myconf="${myconf} $(use_with uml)"
myconf="${myconf} $(use_with qemu)"
myconf="${myconf} $(use_with qemu yajl)" # Use QMP over HMP
- # doesn't belong with hypervisors but links to libvirtd for some reason
- #myconf="${myconf} $(use_with one)"
-
- ## hypervisor protocols
myconf="${myconf} $(use_with phyp)"
myconf="${myconf} --with-esx"
diff --git a/app-emulation/libvirt/metadata.xml b/app-emulation/libvirt/metadata.xml
index e75138cfabed..fc1390e909c8 100644
--- a/app-emulation/libvirt/metadata.xml
+++ b/app-emulation/libvirt/metadata.xml
@@ -45,7 +45,7 @@
<pkg>app-emulation/virtualbox-ose</pkg>)
</flag>
<flag name='phyp'>
- Support management of virtualisation through the PHYP hypervisor protocol.
+ Support IBM HMC / IVM hypervisor via PHYP protocol
</flag>
<!-- Miscellaneous flags -->