summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:30:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-13 19:30:37 +0000
commit770fcb5b53de6835e20485ec764bdbccefc96dcc (patch)
tree8b6ac38d3c51e81592b1d18bc4e29b991c22a88d /app-emulation
parentVersion bump. Add LINGUAS support. (diff)
downloadgentoo-2-770fcb5b53de6835e20485ec764bdbccefc96dcc.tar.gz
gentoo-2-770fcb5b53de6835e20485ec764bdbccefc96dcc.tar.bz2
gentoo-2-770fcb5b53de6835e20485ec764bdbccefc96dcc.zip
[app-emulation/xen-tools] Sabayon Tinderbox build failuire, fixes bug #377557. patch by Tobias Heinlein aka keytoaster, full diff prepared by Ian Delaney. Use toolchain function instead of calling LD directly, copy fix from bug #384359, fix to invoke correct compiler, copy from bug #383973, patches by Ian Delaney aka idella4
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/ChangeLog9
-rwxr-xr-xapp-emulation/xen-tools/files/xendomains.initd-r16
-rw-r--r--app-emulation/xen-tools/xen-tools-3.4.2.ebuild238
-rw-r--r--app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild12
4 files changed, 19 insertions, 246 deletions
diff --git a/app-emulation/xen-tools/ChangeLog b/app-emulation/xen-tools/ChangeLog
index 75206bfa217d..f430dae41fbb 100644
--- a/app-emulation/xen-tools/ChangeLog
+++ b/app-emulation/xen-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/xen-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.98 2011/10/05 18:59:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/ChangeLog,v 1.99 2011/10/13 19:30:37 alexxy Exp $
+
+ 13 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> -xen-tools-3.4.2.ebuild,
+ xen-tools-4.1.1-r5.ebuild, files/xendomains.initd-r1:
+ Sabayon Tinderbox build failuire, fixes bug #377557. patch by Tobias Heinlein
+ aka keytoaster, full diff prepared by Ian Delaney. Use toolchain function
+ instead of calling LD directly, copy fix from bug #384359, fix to invoke
+ correct compiler, copy from bug #383973, patches by Ian Delaney aka idella4
05 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> xen-tools-3.4.2-r5.ebuild,
xen-tools-4.1.1-r5.ebuild, metadata.xml:
diff --git a/app-emulation/xen-tools/files/xendomains.initd-r1 b/app-emulation/xen-tools/files/xendomains.initd-r1
index 79ceac5a94b1..c7f6f88ee27d 100755
--- a/app-emulation/xen-tools/files/xendomains.initd-r1
+++ b/app-emulation/xen-tools/files/xendomains.initd-r1
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/files/xendomains.initd-r1,v 1.1 2009/09/01 09:56:36 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/files/xendomains.initd-r1,v 1.2 2011/10/13 19:30:37 alexxy Exp $
opts="start stop status restart"
@@ -38,7 +38,7 @@ start() {
einfo "Starting Xen domains from ${AUTODIR:=/etc/xen/auto}"
if using_screen ; then
ebegin "Creating screen session to hold domain consoles"
- ( screen -c ${SCREENRC:-/dev/null} -d -m -S ${SCREEN_NAME} -t dom0 \
+ ( screen -c ${SCREENRC:-/dev/null} -d -m -S ${SCREEN_NAME} -t dom0 && sleep 3 \
&& ${screen_cmd} zombie dr \
&& logrotate -f /etc/xen/xen-consoles.logrotate \
&& ${screen_cmd} logfile /var/log/xen-consoles/%t.log \
diff --git a/app-emulation/xen-tools/xen-tools-3.4.2.ebuild b/app-emulation/xen-tools/xen-tools-3.4.2.ebuild
deleted file mode 100644
index 7917bcdfba4f..000000000000
--- a/app-emulation/xen-tools/xen-tools-3.4.2.ebuild
+++ /dev/null
@@ -1,238 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-3.4.2.ebuild,v 1.6 2011/03/26 00:26:15 alexxy Exp $
-
-EAPI="3"
-
-inherit flag-o-matic eutils multilib python
-
-# TPMEMUFILE=tpm_emulator-0.4.tar.gz
-
-DESCRIPTION="Xend daemon and tools"
-HOMEPAGE="http://xen.org/"
-SRC_URI="http://bits.xensource.com/oss-xen/release/${PV}/xen-${PV}.tar.gz"
-# vtpm? ( mirror://berlios/tpm-emulator/${TPMEMUFILE} )"
-S="${WORKDIR}/xen-${PV}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc debug screen custom-cflags pygrub hvm api acm flask"
-
-CDEPEND="dev-lang/python[ncurses,threads]
- sys-libs/zlib
- hvm? ( media-libs/libsdl )
- acm? ( dev-libs/libxml2 )
- api? ( dev-libs/libxml2 net-misc/curl )"
-# vtpm? ( dev-libs/gmp dev-libs/openssl )
-
-DEPEND="${CDEPEND}
- sys-devel/gettext
- sys-devel/gcc
- dev-lang/perl
- dev-lang/python[ssl]
- app-misc/pax-utils
- doc? (
- app-doc/doxygen
- dev-tex/latex2html[png,gif]
- dev-texlive/texlive-latexextra
- media-gfx/transfig
- media-gfx/graphviz
- )
- hvm? (
- x11-proto/xproto
- sys-devel/dev86
- )"
-
-RDEPEND="${CDEPEND}
- sys-apps/iproute2
- net-misc/bridge-utils
- dev-python/pyxml
- screen? (
- app-misc/screen
- app-admin/logrotate
- )
- || ( sys-fs/udev sys-apps/hotplug )"
-
-# hvmloader is used to bootstrap a fully virtualized kernel
-# Approved by QA team in bug #144032
-QA_WX_LOAD="usr/lib/xen/boot/hvmloader"
-QA_EXECSTACK="usr/share/xen/qemu/openbios-sparc32
- usr/share/xen/qemu/openbios-sparc64"
-
-pkg_setup() {
- export "CONFIG_LOMOUNT=y"
-
- if ! use x86 && ! has x86 $(get_all_abis) && use hvm; then
- eerror "HVM (VT-x and AMD-v) cannot be built on this system. An x86 or"
- eerror "an amd64 multilib profile is required. Remove the hvm use flag"
- eerror "to build xen-tools on your current profile."
- die "USE=hvm is unsupported on this system."
- fi
-
- if [[ -z ${XEN_TARGET_ARCH} ]] ; then
- if use x86 && use amd64; then
- die "Confusion! Both x86 and amd64 are set in your use flags!"
- elif use x86; then
- export XEN_TARGET_ARCH="x86_32"
- elif use amd64 ; then
- export XEN_TARGET_ARCH="x86_64"
- else
- die "Unsupported architecture!"
- fi
- fi
-
-# use vtpm && export "VTPM_TOOLS=y"
- use api && export "LIBXENAPI_BINDINGS=y"
- use acm && export "ACM_SECURITY=y"
- use flask && export "FLASK_ENABLE=y"
-}
-
-src_prepare() {
-# use vtpm && cp "${DISTDIR}"/${TPMEMUFILE} tools/vtpm
-
- # if the user *really* wants to use their own custom-cflags, let them
- if use custom-cflags; then
- einfo "User wants their own CFLAGS - removing defaults"
- # try and remove all the default custom-cflags
- find "${S}" -name Makefile -o -name Rules.mk -o -name Config.mk -exec sed \
- -e 's/CFLAGS\(.*\)=\(.*\)-O3\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-march=i686\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-fomit-frame-pointer\(.*\)/CFLAGS\1=\2\3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-g3*\s\(.*\)/CFLAGS\1=\2 \3/' \
- -e 's/CFLAGS\(.*\)=\(.*\)-O2\(.*\)/CFLAGS\1=\2\3/' \
- -i {} \;
- fi
-
- # Disable hvm support on systems that don't support x86_32 binaries.
- if ! use hvm; then
- chmod 644 tools/check/check_x11_devel
- sed -i -e '/^CONFIG_IOEMU := y$/d' "${S}"/config/*.mk
- sed -i -e '/SUBDIRS-$(CONFIG_X86) += firmware/d' "${S}"/tools/Makefile
- fi
-
- if ! use pygrub; then
- sed -i -e '/^SUBDIRS-$(PYTHON_TOOLS) += pygrub$/d' "${S}"/tools/Makefile
- fi
-
- # Fix network broadcast on bridged networks
- epatch "${FILESDIR}/${PN}-3.4.0-network-bridge-broadcast.patch"
-
- # Do not strip binaries
- epatch "${FILESDIR}/${PN}-3.3.0-nostrip.patch"
-
- # fix variable declaration to avoid sandbox issue, #253134
- epatch "${FILESDIR}/${PN}-3.3.1-sandbox-fix.patch"
-
- # Fix --as-needed issues, bug 296631
- epatch "${FILESDIR}/${P}-as-needed.patch"
-}
-
-src_compile() {
- export VARTEXFONTS="${T}/fonts"
- local myopt
- use debug && myopt="${myopt} debug=y"
-
- use custom-cflags || unset CFLAGS
- if test-flag-CC -fno-strict-overflow; then
- append-flags -fno-strict-overflow
- fi
-
- emake -C tools ${myopt} || die "compile failed"
-
- if use doc; then
- sh ./docs/check_pkgs || die "package check failed"
- emake docs || die "compiling docs failed"
- emake dev-docs || die "make dev-docs failed"
- fi
-
- emake -C docs man-pages || die "make man-pages failed"
-}
-
-src_install() {
- make DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" XEN_PYTHON_NATIVE_INSTALL=y install-tools \
- || die "install failed"
-
- # Remove RedHat-specific stuff
- rm -rf "${D}"/etc/sysconfig
-
- dodoc README docs/README.xen-bugtool docs/ChangeLog
- if use doc; then
- emake DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" install-docs \
- || die "install docs failed"
-
- dohtml -r docs/api/
- docinto pdf
- dodoc docs/api/tools/python/latex/refman.pdf
-
- [ -d "${D}"/usr/share/doc/xen ] && mv "${D}"/usr/share/doc/xen/* "${D}"/usr/share/doc/${PF}/html
- fi
- rm -rf "${D}"/usr/share/doc/xen/
-
- doman docs/man?/*
-
- newinitd "${FILESDIR}"/xend.initd-r1 xend \
- || die "Couldn't install xen.initd"
- newconfd "${FILESDIR}"/xendomains.confd xendomains \
- || die "Couldn't install xendomains.confd"
- newinitd "${FILESDIR}"/xendomains.initd-r1 xendomains \
- || die "Couldn't install xendomains.initd"
-
- if use screen; then
- cat "${FILESDIR}"/xendomains-screen.confd >> "${D}"/etc/conf.d/xendomains
- cp "${FILESDIR}"/xen-consoles.logrotate "${D}"/etc/xen/
- keepdir /var/log/xen-consoles
- fi
-
- # xend expects these to exist
- keepdir /var/run/xenstored /var/lib/xenstored /var/xen/dump /var/lib/xen /var/log/xen
-
- # for xendomains
- keepdir /etc/xen/auto
-}
-
-pkg_postinst() {
- elog "Official Xen Guide and the unoffical wiki page:"
- elog " http://www.gentoo.org/doc/en/xen-guide.xml"
- elog " http://en.gentoo-wiki.com/wiki/Xen/"
-
- if [[ "$(scanelf -s __guard -q $(type -P python))" ]] ; then
- echo
- ewarn "xend may not work when python is built with stack smashing protection (ssp)."
- ewarn "If 'xm create' fails with '<ProtocolError for /RPC2: -1 >', see bug #141866"
- ewarn "This probablem may be resolved as of Xen 3.0.4, if not post in the bug."
- fi
-
- if ! has_version "dev-lang/python[ncurses]"; then
- echo
- ewarn "NB: Your dev-lang/python is built without USE=ncurses."
- ewarn "Please rebuild python with USE=ncurses to make use of xenmon.py."
- fi
-
- if has_version "sys-apps/iproute2[minimal]"; then
- echo
- ewarn "Your sys-apps/iproute2 is built with USE=minimal. Networking"
- ewarn "will not work until you rebuild iproute2 without USE=minimal."
- fi
-
- if ! use hvm; then
- echo
- elog "HVM (VT-x and AMD-V) support has been disabled. If you need hvm"
- elog "support enable the hvm use flag."
- elog "An x86 or amd64 multilib system is required to build HVM support."
- echo
- elog "The ioemu use flag has been removed and replaced with hvm."
- fi
-
- if grep -qsF XENSV= "${ROOT}/etc/conf.d/xend"; then
- echo
- elog "xensv is broken upstream (Gentoo bug #142011)."
- elog "Please remove '${ROOT%/}/etc/conf.d/xend', as it is no longer needed."
- fi
-
- python_mod_optimize $(use pygrub && echo grub) xen
-}
-
-pkg_postrm() {
- python_mod_cleanup $(use pygrub && echo grub) xen
-}
diff --git a/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild b/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild
index 9cb12442c55a..7fe45567b7e9 100644
--- a/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild,v 1.4 2011/10/05 18:59:29 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen-tools/xen-tools-4.1.1-r5.ebuild,v 1.5 2011/10/13 19:30:37 alexxy Exp $
EAPI="3"
@@ -18,7 +18,7 @@ else
S="${WORKDIR}/xen-${PV}"
fi
-inherit flag-o-matic eutils multilib python ${live_eclass}
+inherit flag-o-matic eutils multilib python toolchain-funcs ${live_eclass}
DESCRIPTION="Xend daemon and tools"
HOMEPAGE="http://xen.org/"
@@ -205,7 +205,7 @@ src_compile() {
fi
unset LDFLAGS
- emake -C tools ${myopt} || die "compile failed"
+ emake CC=$(tc-getCC) LD=$(tc-getLD) -C tools ${myopt} || die "compile failed"
if use doc; then
sh ./docs/check_pkgs || die "package check failed"
@@ -217,11 +217,15 @@ src_compile() {
}
src_install() {
+ # Override auto-detection in the build system, bug #382573
+ export INITD_DIR=/etc/init.d
+ export CONFIG_LEAF_DIR=default
+
make DESTDIR="${D}" DOCDIR="/usr/share/doc/${PF}" XEN_PYTHON_NATIVE_INSTALL=y install-tools \
|| die "install failed"
# Remove RedHat-specific stuff
- rm -r "${D}"/etc/init.d/xen* || die
+ rm -r "${D}"/etc/init.d/xen* "${D}"/etc/default || die
# uncomment lines in xl.conf
sed -e 's:^#autoballoon=1:autoballoon=1:' \