summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-08-05 09:29:12 +0000
committerMike Frysinger <vapier@gentoo.org>2014-08-05 09:29:12 +0000
commita61cebf7cf23b95d014e227eabb726f4a6b9018d (patch)
treed37550080326a5830a81738c427f448f39923ea3 /app-emulation
parentRemove obsolete ebuilds (diff)
downloadgentoo-2-a61cebf7cf23b95d014e227eabb726f4a6b9018d.tar.gz
gentoo-2-a61cebf7cf23b95d014e227eabb726f4a6b9018d.tar.bz2
gentoo-2-a61cebf7cf23b95d014e227eabb726f4a6b9018d.zip
Add USE=pin-upstream-blobs so people can opt to use any version of seabios/etc... on their local systems.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog7
-rw-r--r--app-emulation/qemu/metadata.xml3
-rw-r--r--app-emulation/qemu/qemu-2.1.0.ebuild27
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild27
4 files changed, 39 insertions, 25 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 982e98c1a6a8..4d52bbb23ab2 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.280 2014/08/05 08:54:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.281 2014/08/05 09:29:12 vapier Exp $
+
+ 05 Aug 2014; Mike Frysinger <vapier@gentoo.org> metadata.xml,
+ qemu-2.1.0.ebuild, qemu-9999.ebuild:
+ Add USE=pin-upstream-blobs so people can opt to use any version of
+ seabios/etc... on their local systems.
05 Aug 2014; Mike Frysinger <vapier@gentoo.org> qemu-2.1.0.ebuild,
qemu-9999.ebuild:
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
index 7276a657c2ae..4d1fd1c7e1a2 100644
--- a/app-emulation/qemu/metadata.xml
+++ b/app-emulation/qemu/metadata.xml
@@ -21,6 +21,9 @@
<flag name='ncurses'>Enable the ncurses-based console</flag>
<flag name='nfs'>Enable NFS support</flag>
<flag name='numa'>Enable NUMA support</flag>
+ <flag name='pin-upstream-blobs'>Pin the versions of BIOS firmware to the version included in the upstream release.
+ This is needed to sanely support migration/suspend/resume/snapshotting/etc... of instances.
+ When the blobs are different, random corruption/bugs/crashes/etc... may be observed.</flag>
<flag name='pulseaudio'>Enable pulseaudio output for sound emulation</flag>
<flag name='rbd'>Enable rados block device backend support, see http://ceph.newdream.net/wiki/QEMU-RBD</flag>
<flag name='sdl'>Enable the SDL-based console</flag>
diff --git a/app-emulation/qemu/qemu-2.1.0.ebuild b/app-emulation/qemu/qemu-2.1.0.ebuild
index ad356abba56a..5b3bf817dc40 100644
--- a/app-emulation/qemu/qemu-2.1.0.ebuild
+++ b/app-emulation/qemu/qemu-2.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.7 2014/08/05 08:54:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.8 2014/08/05 09:29:12 vapier Exp $
EAPI=5
@@ -31,7 +31,8 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
gtk infiniband iscsi +jpeg \
-kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
+kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs
++png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
virtfs +vnc xattr xen xfs"
@@ -91,20 +92,22 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
xattr? ( sys-apps/attr[static-libs(+)] )
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
USER_LIB_DEPEND="${COMMON_LIB_DEPEND}"
-RDEPEND="!static-softmmu? ( ${SOFTMMU_LIB_DEPEND//\[static-libs(+)]} )
- !static-user? ( ${USER_LIB_DEPEND//\[static-libs(+)]} )
- qemu_softmmu_targets_i386? (
- >=sys-firmware/ipxe-1.0.0_p20130624
- ~sys-firmware/seabios-1.7.5
- ~sys-firmware/sgabios-0.1_pre8
- ~sys-firmware/vgabios-0.7a
- )
- qemu_softmmu_targets_x86_64? (
- >=sys-firmware/ipxe-1.0.0_p20130624
+X86_FIRMWARE_DEPEND="
+ >=sys-firmware/ipxe-1.0.0_p20130624
+ pin-upstream-blobs? (
~sys-firmware/seabios-1.7.5
~sys-firmware/sgabios-0.1_pre8
~sys-firmware/vgabios-0.7a
)
+ !pin-upstream-blobs? (
+ sys-firmware/seabios
+ sys-firmware/sgabios
+ sys-firmware/vgabios
+ )"
+RDEPEND="!static-softmmu? ( ${SOFTMMU_LIB_DEPEND//\[static-libs(+)]} )
+ !static-user? ( ${USER_LIB_DEPEND//\[static-libs(+)]} )
+ qemu_softmmu_targets_i386? ( ${X86_FIRMWARE_DEPEND} )
+ qemu_softmmu_targets_x86_64? ( ${X86_FIRMWARE_DEPEND} )
accessibility? ( app-accessibility/brltty )
alsa? ( >=media-libs/alsa-lib-1.0.13 )
bluetooth? ( net-wireless/bluez )
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index ae7a498a7cf8..73fcce507c62 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.85 2014/08/05 08:54:59 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.86 2014/08/05 09:29:12 vapier Exp $
EAPI=5
@@ -31,7 +31,8 @@ LICENSE="GPL-2 LGPL-2 BSD-2"
SLOT="0"
IUSE="accessibility +aio alsa bluetooth +caps +curl debug +fdt glusterfs \
gtk infiniband iscsi +jpeg \
-kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +png pulseaudio python \
+kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs
++png pulseaudio python \
rbd sasl +seccomp sdl selinux smartcard snappy spice ssh static static-softmmu \
static-user systemtap tci test +threads tls usb usbredir +uuid vde +vhost-net \
virtfs +vnc xattr xen xfs"
@@ -91,20 +92,22 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
xattr? ( sys-apps/attr[static-libs(+)] )
xfs? ( sys-fs/xfsprogs[static-libs(+)] )"
USER_LIB_DEPEND="${COMMON_LIB_DEPEND}"
-RDEPEND="!static-softmmu? ( ${SOFTMMU_LIB_DEPEND//\[static-libs(+)]} )
- !static-user? ( ${USER_LIB_DEPEND//\[static-libs(+)]} )
- qemu_softmmu_targets_i386? (
- >=sys-firmware/ipxe-1.0.0_p20130624
- sys-firmware/seabios
- sys-firmware/sgabios
- sys-firmware/vgabios
+X86_FIRMWARE_DEPEND="
+ >=sys-firmware/ipxe-1.0.0_p20130624
+ pin-upstream-blobs? (
+ ~sys-firmware/seabios-1.7.5
+ ~sys-firmware/sgabios-0.1_pre8
+ ~sys-firmware/vgabios-0.7a
)
- qemu_softmmu_targets_x86_64? (
- >=sys-firmware/ipxe-1.0.0_p20130624
+ !pin-upstream-blobs? (
sys-firmware/seabios
sys-firmware/sgabios
sys-firmware/vgabios
- )
+ )"
+RDEPEND="!static-softmmu? ( ${SOFTMMU_LIB_DEPEND//\[static-libs(+)]} )
+ !static-user? ( ${USER_LIB_DEPEND//\[static-libs(+)]} )
+ qemu_softmmu_targets_i386? ( ${X86_FIRMWARE_DEPEND} )
+ qemu_softmmu_targets_x86_64? ( ${X86_FIRMWARE_DEPEND} )
accessibility? ( app-accessibility/brltty )
alsa? ( >=media-libs/alsa-lib-1.0.13 )
bluetooth? ( net-wireless/bluez )