summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-02-02 01:51:58 +0000
committerMike Frysinger <vapier@gentoo.org>2014-02-02 01:51:58 +0000
commitb3a853a04fcc13836d10f5fa973ffe0e6adb95f8 (patch)
treed0e19c607b69628544561d042fde19149d8da075 /app-emulation
parentAdded Andreas Schlick (ninox+pmg) to metadata.xml, whom will proxy maintain t... (diff)
downloadgentoo-2-b3a853a04fcc13836d10f5fa973ffe0e6adb95f8.tar.gz
gentoo-2-b3a853a04fcc13836d10f5fa973ffe0e6adb95f8.tar.bz2
gentoo-2-b3a853a04fcc13836d10f5fa973ffe0e6adb95f8.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/hercules/ChangeLog9
-rw-r--r--app-emulation/hercules/hercules-3.10.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index b6afcaf68b25..8766e82ce67e 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.37 2013/09/06 20:35:59 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.38 2014/02/02 01:51:58 vapier Exp $
+
+*hercules-3.10 (02 Feb 2014)
+
+ 02 Feb 2014; Mike Frysinger <vapier@gentoo.org> +hercules-3.10.ebuild:
+ Version bump.
06 Sep 2013; Mike Frysinger <vapier@gentoo.org>
files/hercules-3.09-aliasing.patch:
diff --git a/app-emulation/hercules/hercules-3.10.ebuild b/app-emulation/hercules/hercules-3.10.ebuild
new file mode 100644
index 000000000000..f47e34f0d437
--- /dev/null
+++ b/app-emulation/hercules/hercules-3.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-3.10.ebuild,v 1.1 2014/02/02 01:51:58 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+HOMEPAGE="http://www.hercules-390.eu/"
+SRC_URI="http://downloads.hercules-390.eu/${P}.tar.gz"
+
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="bzip2 custom-cflags +suid"
+
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.09-aliasing.patch
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ ac_cv_lib_bz2_BZ2_bzBuffToBuffDecompress=$(usex bzip2) \
+ econf \
+ $(use_enable bzip2 cckd-bzip2) \
+ $(use_enable bzip2 het-bzip2) \
+ $(use_enable suid setuid-hercifc) \
+ --enable-custom="Gentoo ${PF}.ebuild" \
+ --disable-optimization
+}
+
+src_install() {
+ default
+ insinto /usr/share/hercules
+ doins hercules.cnf
+ dodoc README.* RELEASE.NOTES
+ dohtml -r html
+}