summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-05-25 20:41:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-05-25 20:41:48 +0000
commitcad77b9ba731d7f0137f2c543355629b6f99bed5 (patch)
tree1f19fe0067e44d41ae64e37fa5acd3cc9354fbe9 /app-emulation
parentNew upstream version (diff)
downloadgentoo-2-cad77b9ba731d7f0137f2c543355629b6f99bed5.tar.gz
gentoo-2-cad77b9ba731d7f0137f2c543355629b6f99bed5.tar.bz2
gentoo-2-cad77b9ba731d7f0137f2c543355629b6f99bed5.zip
Fix/workaround for the newer glibc
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/files/qemu-0.7.0-errno.patch11
-rw-r--r--app-emulation/qemu/qemu-0.7.0.ebuild8
3 files changed, 21 insertions, 4 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index d99cc88b93a3..3f512b0e2ceb 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.34 2005/05/18 23:44:49 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.35 2005/05/25 20:41:48 lu_zero Exp $
+
+ 25 May 2005; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.7.0-errno.patch, qemu-0.7.0.ebuild:
+ Fix for the errno issues in helper2.c
18 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
Add a notice about the qemu group, thanks to Leung Ki Chi
diff --git a/app-emulation/qemu/files/qemu-0.7.0-errno.patch b/app-emulation/qemu/files/qemu-0.7.0-errno.patch
new file mode 100644
index 000000000000..291adc1725b5
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.7.0-errno.patch
@@ -0,0 +1,11 @@
+diff -ruN qemu-0.7.0.orig/target-i386/helper2.c qemu-0.7.0/target-i386/helper2.c
+--- qemu-0.7.0.orig/target-i386/helper2.c 2005-04-27 22:52:05.000000000 +0200
++++ qemu-0.7.0/target-i386/helper2.c 2005-05-25 22:07:50.000000000 +0200
+@@ -17,6 +17,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <errno.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/app-emulation/qemu/qemu-0.7.0.ebuild b/app-emulation/qemu/qemu-0.7.0.ebuild
index 385ff3a715c2..dd58e1ea617c 100644
--- a/app-emulation/qemu/qemu-0.7.0.ebuild
+++ b/app-emulation/qemu/qemu-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.7 2005/05/18 23:44:49 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.8 2005/05/25 20:41:48 lu_zero Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -55,13 +55,15 @@ src_unpack() {
cd ${S}/kqemu
epatch ${FILESDIR}/kqemu-sysfs.patch
fi
-
-# if use qvm86; then
+ # if use qvm86; then
# mv ${WORKDIR}/qvm86 ${S}
# cd ${S}
# epatch qvm86/patch.qvm86
# fi
cd ${S}
+ #Fix errno mismatch on glibc-2.3.5
+ epatch ${FILESDIR}/${P}-errno.patch
+
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile