summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2013-05-13 02:40:43 +0000
committerLance Albertson <ramereth@gentoo.org>2013-05-13 02:40:43 +0000
commitd499ab67dcaf892484d3597ba139d3229fa7fa0a (patch)
treeed92dc97ccca787479567c67d3ca997e85f5e82e /app-emulation
parentVersion bump #469164 by Agostino Sarubbo. (diff)
downloadgentoo-2-d499ab67dcaf892484d3597ba139d3229fa7fa0a.tar.gz
gentoo-2-d499ab67dcaf892484d3597ba139d3229fa7fa0a.tar.bz2
gentoo-2-d499ab67dcaf892484d3597ba139d3229fa7fa0a.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 27F4B742)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ChangeLog10
-rw-r--r--app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/app-emulation/ganeti-instance-debootstrap/ChangeLog b/app-emulation/ganeti-instance-debootstrap/ChangeLog
index 02c5f412b96c..77d740119440 100644
--- a/app-emulation/ganeti-instance-debootstrap/ChangeLog
+++ b/app-emulation/ganeti-instance-debootstrap/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-instance-debootstrap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.7 2012/08/12 16:34:59 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ChangeLog,v 1.8 2013/05/13 02:40:43 ramereth Exp $
+
+*ganeti-instance-debootstrap-0.12 (13 May 2013)
+
+ 13 May 2013; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-instance-debootstrap-0.12.ebuild:
+ Version bump
12 Aug 2012; Markus Meier <maekke@gentoo.org>
ganeti-instance-debootstrap-0.11.ebuild:
diff --git a/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild
new file mode 100644
index 000000000000..5fddaf7eac60
--- /dev/null
+++ b/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-instance-debootstrap/ganeti-instance-debootstrap-0.12.ebuild,v 1.1 2013/05/13 02:40:43 ramereth Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Scripts to build Ganeti VMs with debootstrap"
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/ganeti-instance-debootstrap-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-arch/dpkg
+ app-arch/dump
+ app-emulation/ganeti
+ dev-util/debootstrap
+ >=sys-apps/coreutils-6.10-r1
+ sys-apps/util-linux
+ sys-fs/e2fsprogs"
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${P} || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ insinto /etc/ganeti/instance-debootstrap/hooks
+ doins examples/hooks/*
+}