summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2008-01-24 20:55:54 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2008-01-24 20:55:54 +0000
commitea800f5fe0e121a513cec606e8449a8bd9a2673b (patch)
treeb10479b5b3ffbae1ec16932a852b11e39d28247a /app-emulation
parentVersion bump, bug 204719 (diff)
downloadgentoo-2-ea800f5fe0e121a513cec606e8449a8bd9a2673b.tar.gz
gentoo-2-ea800f5fe0e121a513cec606e8449a8bd9a2673b.tar.bz2
gentoo-2-ea800f5fe0e121a513cec606e8449a8bd9a2673b.zip
Version Bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/gxemul/ChangeLog9
-rw-r--r--app-emulation/gxemul/files/digest-gxemul-0.4.6.23
-rw-r--r--app-emulation/gxemul/gxemul-0.4.6.2.ebuild42
3 files changed, 52 insertions, 2 deletions
diff --git a/app-emulation/gxemul/ChangeLog b/app-emulation/gxemul/ChangeLog
index 9316a68f800d..162f0a2c14d1 100644
--- a/app-emulation/gxemul/ChangeLog
+++ b/app-emulation/gxemul/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/gxemul
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.10 2007/07/22 09:22:47 omp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/ChangeLog,v 1.11 2008/01/24 20:55:53 drizzt Exp $
+
+*gxemul-0.4.6.2 (24 Jan 2008)
+
+ 24 Jan 2008; Timothy Redaelli <drizzt@gentoo.org> +gxemul-0.4.6.2.ebuild:
+ Version Bump
22 Jul 2007; David Shakaryan <omp@gentoo.org> gxemul-0.4.5.1.ebuild:
Remove virtual/x11 from dependencies.
diff --git a/app-emulation/gxemul/files/digest-gxemul-0.4.6.2 b/app-emulation/gxemul/files/digest-gxemul-0.4.6.2
new file mode 100644
index 000000000000..88336e35f10f
--- /dev/null
+++ b/app-emulation/gxemul/files/digest-gxemul-0.4.6.2
@@ -0,0 +1,3 @@
+MD5 f26e1f796f50889c6f94e0764cdc36b5 gxemul-0.4.6.2.tar.gz 2186472
+RMD160 f109062c7830b8d308fab9e4dfb4835f38a8adb1 gxemul-0.4.6.2.tar.gz 2186472
+SHA256 21c33f6c9da762459ca3e5050d1334c31b07bd66e30f6ea6732c1b5ca8b41179 gxemul-0.4.6.2.tar.gz 2186472
diff --git a/app-emulation/gxemul/gxemul-0.4.6.2.ebuild b/app-emulation/gxemul/gxemul-0.4.6.2.ebuild
new file mode 100644
index 000000000000..5ce484f4b00a
--- /dev/null
+++ b/app-emulation/gxemul/gxemul-0.4.6.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/gxemul/gxemul-0.4.6.2.ebuild,v 1.1 2008/01/24 20:55:53 drizzt Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A Machine Emulator, Mainly emulates MIPS, but supports other CPU types."
+HOMEPAGE="http://gavare.se/gxemul/"
+SRC_URI="http://gavare.se/gxemul/src/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="X"
+
+RDEPEND="X? ( || ( ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXdmcp
+ )
+ virtual/x11 ) )"
+
+DEPEND="${RDEPEND}
+ X? ( || ( x11-proto/xproto virtual/x11 ) )"
+
+src_compile() {
+ tc-export CC
+ local myconf=""
+
+ use X || myconf="${myconf} --disable-x"
+
+ einfo "Configuring with: ${myconf}"
+ ./configure ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin gxemul || die "gxemul not found in ${S}"
+ doman man/gxemul.1
+ dodoc HISTORY LICENSE README RELEASE TODO
+ dohtml doc/*
+}