summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-13 22:28:28 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-13 22:28:28 +0000
commitf48f264fdea8faaa34ffaa0f281da06955605f36 (patch)
treea77c921ae9eb5427918bcf837f638b50005c3152 /app-emulation
parentVersion bumped. This fixes a crash and gives some more functions. (diff)
downloadgentoo-2-f48f264fdea8faaa34ffaa0f281da06955605f36.tar.gz
gentoo-2-f48f264fdea8faaa34ffaa0f281da06955605f36.tar.bz2
gentoo-2-f48f264fdea8faaa34ffaa0f281da06955605f36.zip
Version bump #112454 by John Myers.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-5.0.1.ebuild60
-rw-r--r--app-emulation/cedega/files/digest-cedega-5.0.11
3 files changed, 67 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 11057ac885d7..1df932581ba5 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.20 2005/11/09 01:14:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.21 2005/11/13 22:28:28 vapier Exp $
+
+*cedega-5.0.1 (13 Nov 2005)
+
+ 13 Nov 2005; Mike Frysinger <vapier@gentoo.org> +cedega-5.0.1.ebuild:
+ Version bump #112454 by John Myers.
*cedega-5.0 (09 Nov 2005)
diff --git a/app-emulation/cedega/cedega-5.0.1.ebuild b/app-emulation/cedega/cedega-5.0.1.ebuild
new file mode 100644
index 000000000000..79548ffc5025
--- /dev/null
+++ b/app-emulation/cedega/cedega-5.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-5.0.1.ebuild,v 1.1 2005/11/13 22:28:28 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups opengl"
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ opengl? ( virtual/opengl )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-5.0.1 b/app-emulation/cedega/files/digest-cedega-5.0.1
new file mode 100644
index 000000000000..7cf4dc1f47b4
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-5.0.1
@@ -0,0 +1 @@
+MD5 0c89fb0e0a63839689df58be224a7df2 cedega-small-5.0.1.tgz 1243577