summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2005-09-28 21:42:54 +0000
committerDaniel Black <dragonheart@gentoo.org>2005-09-28 21:42:54 +0000
commit6132c70d8805b978311d67681f188bf992dacbd6 (patch)
treea0794734c1cb2a7a0dc60761f168c5534d47d07a /app-forensics/air/air-1.2.8.ebuild
parentremoved deprecated uclibtoolize - bug #106399 (diff)
downloadgentoo-2-6132c70d8805b978311d67681f188bf992dacbd6.tar.gz
gentoo-2-6132c70d8805b978311d67681f188bf992dacbd6.tar.bz2
gentoo-2-6132c70d8805b978311d67681f188bf992dacbd6.zip
version bump and old version cleanout
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-forensics/air/air-1.2.8.ebuild')
-rw-r--r--app-forensics/air/air-1.2.8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-forensics/air/air-1.2.8.ebuild b/app-forensics/air/air-1.2.8.ebuild
new file mode 100644
index 000000000000..c10b7ce30464
--- /dev/null
+++ b/app-forensics/air/air-1.2.8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/air/air-1.2.8.ebuild,v 1.1 2005/09/28 21:42:54 dragonheart Exp $
+
+DESCRIPTION="A GUI front-end to dd/dcfldd"
+HOMEPAGE="http://air-imager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/air-imager/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-perl/perl-tk-804.027
+ userland_GNU? ( app-arch/sharutils )
+ sys-apps/sed
+ dev-lang/perl"
+
+RDEPEND="app-arch/mt-st
+ dev-lang/perl
+ userland_GNU? ( sys-apps/coreutils )"
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+
+ PERLTK_VER=$(best_version dev-perl/perl-tk)
+ export PERLTK_VER=${PERLTK_VER:17}
+
+ env INTERACTIVE=no INSTALL_DIR=${D}/usr TEMP_DIR=${T} \
+ FINAL_INSTALL_DIR=/usr \
+ ./install-${P} \
+ || die "failed to install - please attach ${T}/air-install.log to a bug report at http://bugs.gentoo.org"
+
+ dodoc README
+
+ dodoc ${T}/air-install.log
+
+ chown -R root:0 ${D}
+ fowners root:users /usr/share/air/logs
+ fperms ug+rwx /usr/share/air/logs
+ if [ -p ${D}usr/share/air/air-fifo ]; then
+ fperms ug+rw /usr/share/air/air-fifo
+ fowners root:users /usr/share/air/air-fifo
+ fi
+ fperms a+x /usr/bin/air
+}
+
+pkg_postinst() {
+ einfo "This will use programs from the following packages if installed:"
+ einfo "sys-apps/dcfldd"
+ einfo "net-analyzer/netcat"
+ einfo "net-analyzer/cryptcat"
+
+ einfo "The author, steve@unixgurus.com, would appreciate and email of the install file /usr/share/doc/${PF}/air-install.log"
+}