summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 11:46:46 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 11:46:46 +0000
commit87d7f31e99bac88c6b211b94eb743bcabcfd064a (patch)
tree9a80a5effe2cc72dc099d09bee1b0c849def673c /app-forensics/tct
parentStable for ppc. (diff)
downloadgentoo-2-87d7f31e99bac88c6b211b94eb743bcabcfd064a.tar.gz
gentoo-2-87d7f31e99bac88c6b211b94eb743bcabcfd064a.tar.bz2
gentoo-2-87d7f31e99bac88c6b211b94eb743bcabcfd064a.zip
Bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics/tct')
-rw-r--r--app-forensics/tct/ChangeLog7
-rw-r--r--app-forensics/tct/tct-1.19.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/app-forensics/tct/ChangeLog b/app-forensics/tct/ChangeLog
index 5abac383a8fe..449fc73bd06e 100644
--- a/app-forensics/tct/ChangeLog
+++ b/app-forensics/tct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/tct
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.16 2009/04/30 17:37:17 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/ChangeLog,v 1.17 2009/11/08 11:46:46 patrick Exp $
+
+*tct-1.19 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +tct-1.19.ebuild:
+ Bump
30 Apr 2009; Patrick Lauer <patrick@gentoo.org> tct-1.18-r1.ebuild:
Adding ~amd64 keyword
diff --git a/app-forensics/tct/tct-1.19.ebuild b/app-forensics/tct/tct-1.19.ebuild
new file mode 100644
index 000000000000..e4e822db3f62
--- /dev/null
+++ b/app-forensics/tct/tct-1.19.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/tct/tct-1.19.ebuild,v 1.1 2009/11/08 11:46:46 patrick Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="The Coroner's Toolkit - a collection of tools to aide in gathering and analyzing forensic data on a UNIX system"
+HOMEPAGE="http://www.porcupine.org/forensics/tct.html"
+SRC_URI="http://www.porcupine.org/forensics/${P}.tar.gz"
+
+LICENSE="IBM as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.0004
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i "s:^\(CC.*= \).*:\1$(tc-getCC):" Makefile || die "sed CC failed"
+ sed -i "s:\$(OPT) \$(DEBUG):${CFLAGS}:" */*/Makefile \
+ || die "sed CFLAGS failed"
+
+ epatch "${FILESDIR}/tct-1.15-gentoo.diff"
+}
+
+src_install() {
+ # bins/libs
+ into /usr/lib/tct
+ dobin bin/* || die "bin installation failed"
+
+ exeinto /usr/lib/tct
+ doexe reconfig || die "reconfig installation failed"
+
+ insinto /usr/lib/tct/lib
+ doins lib/*.pl || die "lib installation failed"
+
+ exeinto /usr/lib/tct/extras
+ doexe extras/bdf extras/ils2mac extras/realpath extras/entropy/entropy \
+ extras/findkey/findkey || die "extras installation failed"
+
+ # config
+ insinto /etc/tct
+ doins conf/* || die "conf installation failed"
+
+ # docs
+ newdoc extras/README README.extras || die "newdoc failed"
+ dodoc docs/* Beware CHANGES INSTALL OS-NOTES README.FIRST \
+ TODO* additional-resources bibliography help-recovering-file \
+ help-when-broken-into quick-start || die "doc installation failed"
+
+ # these manual pages are provided by other packages
+ rm -f man/man1/{file,md5,icat,ils,lastcomm,timeout}.1
+ rm -f man/man5/magic.5
+ doman man/*/* || die "man installation failed"
+
+ # setup dirs/symlinks
+ keepdir /var/log/tct
+
+ dosym /etc/tct /usr/lib/tct/conf || die "dosym failed"
+
+ keepdir /var/lib/tct
+ dosym /var/lib/tct /usr/lib/tct/data || die "dosym failed"
+
+ # all binaries except the following are meant for internal use
+ local bin
+ dodir /usr/sbin
+ for bin in grave-robber lazarus mactime unrm; do
+ dosym /usr/lib/tct/bin/${bin} /usr/sbin/${bin} \
+ || die "dosym ${bin} failed"
+ done
+}
+
+pkg_postinst() {
+ elog "The authors of The Coroner's Toolkit highly recommend"
+ elog "installing sys-process/lsof for use by the toolkit."
+ elog
+ elog "Please read the README and quickstart files installed"
+ elog "in /usr/share/doc/${PF} before using The Coroner's Toolkit."
+}