summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-10-31 18:25:20 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-10-31 18:25:20 +0000
commit28f0d8cc80123d25244733272d39639bf0d7ee3f (patch)
tree94841e18aae6c75e528dfe67bb2ac4460a24c2ed /app-forensics
parentUpdated package.use and package.unmask handling. (diff)
downloadgentoo-2-28f0d8cc80123d25244733272d39639bf0d7ee3f.tar.gz
gentoo-2-28f0d8cc80123d25244733272d39639bf0d7ee3f.tar.bz2
gentoo-2-28f0d8cc80123d25244733272d39639bf0d7ee3f.zip
Restrict tests that fail with sandbox enabled, wrt bug #279465. Migrate to EAPI 4.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/zzuf/ChangeLog7
-rw-r--r--app-forensics/zzuf/zzuf-0.13-r1.ebuild38
2 files changed, 13 insertions, 32 deletions
diff --git a/app-forensics/zzuf/ChangeLog b/app-forensics/zzuf/ChangeLog
index 3fe08e58e097..06825bfcf139 100644
--- a/app-forensics/zzuf/ChangeLog
+++ b/app-forensics/zzuf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-forensics/zzuf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.11 2012/05/21 18:35:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.12 2012/10/31 18:25:20 kensington Exp $
+
+ 31 Oct 2012; Michael Palimaka <kensington@gentoo.org> zzuf-0.13-r1.ebuild:
+ Restrict tests that fail with sandbox enabled, wrt bug #279465. Migrate to
+ EAPI 4.
21 May 2012; Kacper Kowalik <xarthisius@gentoo.org> zzuf-0.13-r1.ebuild:
Add missing inheritance of eutils.eclass
@@ -47,4 +51,3 @@
19 Apr 2008; Diego Pettenò <flameeyes@gentoo.org> +metadata.xml,
+zzuf-0.10.ebuild:
Initial import of zzuf. Thanks also to Jakub Moc in bug #188646.
-
diff --git a/app-forensics/zzuf/zzuf-0.13-r1.ebuild b/app-forensics/zzuf/zzuf-0.13-r1.ebuild
index 33cfe9892fe3..3dbe7ae4e61d 100644
--- a/app-forensics/zzuf/zzuf-0.13-r1.ebuild
+++ b/app-forensics/zzuf/zzuf-0.13-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.13-r1.ebuild,v 1.3 2012/05/21 18:35:08 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.13-r1.ebuild,v 1.4 2012/10/31 18:25:20 kensington Exp $
-EAPI="2"
+EAPI=4
inherit autotools eutils
@@ -16,8 +16,10 @@ SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE=""
-DEPEND=""
-RDEPEND=""
+# fails with sandbox enabled
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
src_prepare() {
sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
@@ -35,35 +37,11 @@ src_configure() {
# preloading, so there is no reason to build it statically, unless
# you want to use zzuf with a static-linked executable, which I'm
# not even sure would be a good idea.
- econf \
- --disable-dependency-tracking \
- --disable-static \
- || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
-}
-
-# This could be removed in next versions if my patches will be applied
-# by Sam. -- Diego 'Flameeyes'
-src_test() {
- if has sandbox ${FEATURES}; then
- ewarn "zzuf tests don't work correctly when sandbox is enabled,"
- ewarn "skipping tests. If you want to run the testsuite, please"
- ewarn "disable sandbox for this build."
- return
- fi
-
- cd "${S}"/test
- emake check || die "Unable to build tools needed for testsuite"
-
- ./testsuite.sh || die "testsuite failed"
+ econf --disable-static
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
+ default
find "${D}" -name '*.la' -delete
}