summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-08-29 14:49:32 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-08-29 14:49:32 +0000
commit2a89d6c1e9a2acf96ef88fec952a9dcbd45b4000 (patch)
treeff27ab081a150c53c886ab755cba1de70b873794 /app-forensics
parentMarked ~hppa (bug #187147). (diff)
downloadgentoo-2-2a89d6c1e9a2acf96ef88fec952a9dcbd45b4000.tar.gz
gentoo-2-2a89d6c1e9a2acf96ef88fec952a9dcbd45b4000.tar.bz2
gentoo-2-2a89d6c1e9a2acf96ef88fec952a9dcbd45b4000.zip
Version bump, security bug #181977 and dstat collision issue #131268
(Portage version: 2.1.2.12)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog7
-rw-r--r--app-forensics/sleuthkit/files/digest-sleuthkit-2.096
-rw-r--r--app-forensics/sleuthkit/sleuthkit-2.09.ebuild62
3 files changed, 74 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 7e75fbad87ba..914134d12cec 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.26 2007/04/11 22:20:06 falco Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.27 2007/08/29 14:49:32 falco Exp $
+
+*sleuthkit-2.09 (29 Aug 2007)
+
+ 29 Aug 2007; Raphael Marichez <falco@gentoo.org> +sleuthkit-2.09.ebuild:
+ Version bump, security bug #181977 and dstat collision issue #131268
*sleuthkit-2.08 (11 Apr 2007)
diff --git a/app-forensics/sleuthkit/files/digest-sleuthkit-2.09 b/app-forensics/sleuthkit/files/digest-sleuthkit-2.09
new file mode 100644
index 000000000000..ce97173afc38
--- /dev/null
+++ b/app-forensics/sleuthkit/files/digest-sleuthkit-2.09
@@ -0,0 +1,6 @@
+MD5 7a7b50e089c1807956146a50621b7441 sleuthkit-2.09.tar.gz 2027006
+RMD160 0d7247c533f35f0cb7d11ead8d2242533d89fda4 sleuthkit-2.09.tar.gz 2027006
+SHA256 43c62d9c2767a0acee4e9aab895c743c2ecdc758ebfab2d0062ddf353ebf2803 sleuthkit-2.09.tar.gz 2027006
+MD5 6476d326f6d458fd3993e35e42c56a42 sleuthkit-2.09_dbtool.patch.bz2 9049
+RMD160 e88c225929a2286d223e44d4ecf26abf2d6456ff sleuthkit-2.09_dbtool.patch.bz2 9049
+SHA256 7cdf4611634c318731b686059e2114f5b418d45ed5eefdcea90847ce0386d6e3 sleuthkit-2.09_dbtool.patch.bz2 9049
diff --git a/app-forensics/sleuthkit/sleuthkit-2.09.ebuild b/app-forensics/sleuthkit/sleuthkit-2.09.ebuild
new file mode 100644
index 000000000000..30e1b515a2f1
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-2.09.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-2.09.ebuild,v 1.1 2007/08/29 14:49:32 falco Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz
+ dbtool? ( mirror://gentoo/${P}_dbtool.patch.bz2 ) "
+
+LICENSE="GPL-2 IBM"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="dbtool"
+
+RDEPEND="dev-perl/DateManip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ use dbtool && epatch "${WORKDIR}/${P}_dbtool.patch"
+ epatch "${FILESDIR}/${PN}-makefiles_fix.patch"
+ epatch "${FILESDIR}/${PN}-fscheck.c_fix.patch"
+ sed -i '63,69d' src/timeline/config-perl || die "sed config-perl failed"
+ sed -i 's:`cd ../..; pwd`:/usr:' src/sorter/install \
+ || die "sed install failed"
+}
+
+src_compile() {
+ export CC="$(tc-getCC)" OPT="${CFLAGS}"
+ # Targets: this is so it doesn't remake sys-apps/file
+ # -j1: it really doesn't compile well with -j2 or more,
+ # even after having fixed the Makefiles... :(
+ env -u CFLAGS \
+ emake -j1 -e bin no-perl sorter mactime || die "make failed"
+}
+
+src_install() {
+ dobin bin/* || die "dobin failed"
+ if has_version 'sys-apps/dstat' ; then
+ mv ${D}/usr/bin/dstat ${D}/usr/bin/dstat-dsk
+ echo
+ ewarn "You are installing sleuthkit while you have sys-apps/dstat"
+ ewarn "already installed."
+ ewarn "app-forensics/sleuthkit provides /usr/bin/dstat which is a tool"
+ ewarn "that displays details of a data structure, while sys-apps/dstat"
+ ewarn "provides /usr/bin/dstat as a system statistics tool."
+ echo
+ ewarn "The Sleuth Kit dstat binary has been renamed to"
+ ewarn "/usr/bin/dstat-tsk (see bug 131268). This may cause trouble with"
+ ewarn "applications using sleuthkit such as Autopsy. You may prefer"
+ ewarn "to unmerge sys-apps/dstat and re-emerge app-forensics/sleuthkit."
+ echo
+ fi
+ dodoc docs/*.txt
+ docinto api-doc
+ dohtml docs/api-doc/*
+ insinto /usr/share/sorter
+ doins share/sorter/*
+ doman man/man1/*
+}