summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2014-10-19 09:16:23 +0000
committerChristian Ruppert <idl0r@gentoo.org>2014-10-19 09:16:23 +0000
commit2bc91d223a288ceea8033eeac292b18a8cf184c6 (patch)
treee49d0eb97e4c8c31d15b29e330d801c462676200 /app-forensics
parentVersion bump (diff)
downloadgentoo-2-2bc91d223a288ceea8033eeac292b18a8cf184c6.tar.gz
gentoo-2-2bc91d223a288ceea8033eeac292b18a8cf184c6.tar.bz2
gentoo-2-2bc91d223a288ceea8033eeac292b18a8cf184c6.zip
Version bump
(Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/lynis/ChangeLog7
-rw-r--r--app-forensics/lynis/lynis-1.6.3.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-forensics/lynis/ChangeLog b/app-forensics/lynis/ChangeLog
index 8234e449b1b1..462084ec9b6c 100644
--- a/app-forensics/lynis/ChangeLog
+++ b/app-forensics/lynis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/lynis
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/lynis/ChangeLog,v 1.53 2014/09/30 18:55:39 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/lynis/ChangeLog,v 1.54 2014/10/19 09:16:23 idl0r Exp $
+
+*lynis-1.6.3 (19 Oct 2014)
+
+ 19 Oct 2014; Christian Ruppert <idl0r@gentoo.org> +lynis-1.6.3.ebuild:
+ Version bump
*lynis-1.6.2 (30 Sep 2014)
diff --git a/app-forensics/lynis/lynis-1.6.3.ebuild b/app-forensics/lynis/lynis-1.6.3.ebuild
new file mode 100644
index 000000000000..da6764ce7b30
--- /dev/null
+++ b/app-forensics/lynis/lynis-1.6.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/lynis/lynis-1.6.3.ebuild,v 1.1 2014/10/19 09:16:23 idl0r Exp $
+
+EAPI="5"
+
+inherit eutils bash-completion-r1
+
+DESCRIPTION="Security and system auditing tool"
+HOMEPAGE="http://cisofy.com/lynis/"
+SRC_URI="http://cisofy.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-shells/bash"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ # Bug 507438
+ epatch_user
+}
+
+src_install() {
+ doman lynis.8
+ dodoc CHANGELOG FAQ README dev/TODO
+
+ # Remove the old one during the next stabilize progress
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/lynis.cron-new lynis
+
+ dobashcomp extras/bash_completion.d/lynis
+
+ # stricter default perms - bug 507436
+ diropts -m0700
+ insopts -m0600
+
+ insinto /usr/share/${PN}
+ doins -r db/ include/ plugins/
+
+ dosbin lynis
+
+ insinto /etc/${PN}
+ doins default.prf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
+ einfo
+}