summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 00:59:58 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 00:59:58 +0000
commit518b44f635d8c5b9c23c1ffe604f0fa45a236dab (patch)
tree399b4b233316411c5d26dad61388ca7122467cc3 /app-forensics
parentClean out -sharp 1.0 ebuilds (diff)
downloadgentoo-2-518b44f635d8c5b9c23c1ffe604f0fa45a236dab.tar.gz
gentoo-2-518b44f635d8c5b9c23c1ffe604f0fa45a236dab.tar.bz2
gentoo-2-518b44f635d8c5b9c23c1ffe604f0fa45a236dab.zip
Initial import. Fixes #203758. Ebuild by raistlin@s0ftpj.org and aoz.syn@gmail.com.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/afflib/ChangeLog11
-rw-r--r--app-forensics/afflib/afflib-3.3.4.ebuild43
-rw-r--r--app-forensics/afflib/metadata.xml15
3 files changed, 69 insertions, 0 deletions
diff --git a/app-forensics/afflib/ChangeLog b/app-forensics/afflib/ChangeLog
new file mode 100644
index 000000000000..515cd7a3eaa2
--- /dev/null
+++ b/app-forensics/afflib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-forensics/afflib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/ChangeLog,v 1.1 2009/03/01 00:59:58 patrick Exp $
+
+*afflib-3.3.4 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +metadata.xml,
+ +afflib-3.3.4.ebuild:
+ Initial import. Fixes #203758. Ebuild by raistlin@s0ftpj.org and
+ aoz.syn@gmail.com.
+
diff --git a/app-forensics/afflib/afflib-3.3.4.ebuild b/app-forensics/afflib/afflib-3.3.4.ebuild
new file mode 100644
index 000000000000..7c5ae7b75b92
--- /dev/null
+++ b/app-forensics/afflib/afflib-3.3.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/afflib/afflib-3.3.4.ebuild,v 1.1 2009/03/01 00:59:58 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="Library that implements the AFF image standard"
+HOMEPAGE="http://www.afflib.org/"
+SRC_URI="http://www.afflib.org/downloads/${P}.tar.gz"
+
+LICENSE="BSD-4"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="ewf fuse ncurses python qemu readline s3 threads"
+
+DEPEND="
+ ewf? ( app-forensics/libewf )
+ fuse? ( sys-fs/fuse )
+ ncurses? ( sys-libs/ncurses )
+ python? ( dev-lang/python )
+ readline? ( sys-libs/readline )
+ s3? ( net-misc/curl dev-libs/expat )
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf \
+ $(use_enable fuse) \
+ $(use_enable ewf libewf) \
+ $(use_enable python) \
+ $(use_enable qemu) \
+ $(use_enable s3) \
+ $(use_enable threads threading)
+ emake || die "build failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ use s3 || {
+ rm -f "${D}/usr/bin/s3"
+ }
+}
diff --git a/app-forensics/afflib/metadata.xml b/app-forensics/afflib/metadata.xml
new file mode 100644
index 000000000000..54ca968f91d0
--- /dev/null
+++ b/app-forensics/afflib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>forensics</herd>
+<maintainer>
+ <email>forensics@gentoo.org</email>
+</maintainer>
+<use>
+ <flag name="ewf">Enable libewf extra formats</flag>
+ <flag name="fuse">Enable extra fuse thingies</flag>
+ <flag name="qemu">Enable qemu stuff</flag>
+ <flag name="s3">Enable S3</flag>
+
+</use>
+</pkgmetadata>