summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-08 11:54:19 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-08 11:54:19 +0000
commit92d857d8a2ee4e91c4f5d079c4cbba1d9389fbd9 (patch)
tree3ef5f464331851173984faea1ecd5fb5a340c24b /app-forensics
parentBump (diff)
downloadgentoo-2-92d857d8a2ee4e91c4f5d079c4cbba1d9389fbd9.tar.gz
gentoo-2-92d857d8a2ee4e91c4f5d079c4cbba1d9389fbd9.tar.bz2
gentoo-2-92d857d8a2ee4e91c4f5d079c4cbba1d9389fbd9.zip
Bump
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/libewf/ChangeLog7
-rw-r--r--app-forensics/libewf/libewf-20091108.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/app-forensics/libewf/ChangeLog b/app-forensics/libewf/ChangeLog
index 2dd1911f5e21..bc0e32547e2c 100644
--- a/app-forensics/libewf/ChangeLog
+++ b/app-forensics/libewf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/libewf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.5 2009/05/01 18:58:38 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/ChangeLog,v 1.6 2009/11/08 11:54:19 patrick Exp $
+
+*libewf-20091108 (08 Nov 2009)
+
+ 08 Nov 2009; Patrick Lauer <patrick@gentoo.org> +libewf-20091108.ebuild:
+ Bump
01 May 2009; Raúl Porcel <armin76@gentoo.org> libewf-20090209.ebuild:
Add ~arm/~s390 wrt #224121
diff --git a/app-forensics/libewf/libewf-20091108.ebuild b/app-forensics/libewf/libewf-20091108.ebuild
new file mode 100644
index 000000000000..5cf5d19f8de7
--- /dev/null
+++ b/app-forensics/libewf/libewf-20091108.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/libewf/libewf-20091108.ebuild,v 1.1 2009/11/08 11:54:19 patrick Exp $
+
+inherit eutils autotools
+
+MY_P=${P/libewf/libewf-beta}
+
+DESCRIPTION="Implementation of the EWF (SMART and EnCase) image format"
+HOMEPAGE="http://libewf.sourceforge.net"
+SRC_URI="mirror://sourceforge/libewf/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+# upstream bug #2597171, pyewf has implicit declarations
+#IUSE="debug python rawio unicode"
+IUSE="debug rawio unicode"
+
+DEPEND="
+ sys-libs/e2fsprogs-libs
+ sys-libs/zlib
+ dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable unicode wide-character-type) \
+ $(use_enable rawio raw-access) \
+ $(use_enable debug verbose-output) \
+ $(use_enable debug debug-output)
+ emake
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README documents/*.txt
+ doman manuals/*.1 manuals/*.3
+}