summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-26 20:50:28 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-26 20:50:28 +0000
commitd18f67e67a09788dcbf8b3611ecb514db5e310dc (patch)
tree3a995d0da64b114d7ff9f8ea20435fc30ab6ff03 /app-forensics
parentBump (diff)
downloadgentoo-2-d18f67e67a09788dcbf8b3611ecb514db5e310dc.tar.gz
gentoo-2-d18f67e67a09788dcbf8b3611ecb514db5e310dc.tar.bz2
gentoo-2-d18f67e67a09788dcbf8b3611ecb514db5e310dc.zip
Bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/zzuf/ChangeLog9
-rw-r--r--app-forensics/zzuf/zzuf-0.13.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/app-forensics/zzuf/ChangeLog b/app-forensics/zzuf/ChangeLog
index c0d2fe3627c6..5d6e1e8f90b7 100644
--- a/app-forensics/zzuf/ChangeLog
+++ b/app-forensics/zzuf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/zzuf
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.5 2009/12/28 16:29:48 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/ChangeLog,v 1.6 2010/02/26 20:50:28 patrick Exp $
+
+*zzuf-0.13 (26 Feb 2010)
+
+ 26 Feb 2010; Patrick Lauer <patrick@gentoo.org> +zzuf-0.13.ebuild:
+ Bump
28 Dec 2009; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Relinquish this to maintainer-needed.
diff --git a/app-forensics/zzuf/zzuf-0.13.ebuild b/app-forensics/zzuf/zzuf-0.13.ebuild
new file mode 100644
index 000000000000..7ce0185f1c73
--- /dev/null
+++ b/app-forensics/zzuf/zzuf-0.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/zzuf/zzuf-0.13.ebuild,v 1.1 2010/02/26 20:50:28 patrick Exp $
+
+inherit autotools
+
+DESCRIPTION="Transparent application input fuzzer"
+HOMEPAGE="http://libcaca.zoy.org/wiki/zzuf/"
+SRC_URI="http://caca.zoy.org/files/${PN}/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
+ || die "unable to fix the configure.ac"
+ sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
+ || die "unable to fix unconditional test building"
+
+ eautoreconf
+}
+
+src_compile() {
+ # Don't build the static library, as the library is only used for
+ # preloading, so there is no reason to build it statically, unless
+ # you want to use zzuf with a static-linked executable, which I'm
+ # not even sure would be a good idea.
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+# This could be removed in next versions if my patches will be applied
+# by Sam. -- Diego 'Flameeyes'
+src_test() {
+ if hasq sandbox ${FEATURES}; then
+ ewarn "zzuf tests don't work correctly when sandbox is enabled,"
+ ewarn "skipping tests. If you want to run the testsuite, please"
+ ewarn "disable sandbox for this build."
+ return
+ fi
+
+ cd "${S}"/test
+ emake check || die "Unable to build tools needed for testsuite"
+
+ ./testsuite.sh || die "testsuite failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ find "${D}" -name '*.la' -delete
+}