summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-07-12 13:10:08 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-07-12 13:10:08 +0000
commiteeae102a483de9b18a809b4bff1dfa9f2ffaea27 (patch)
treeb1718f6f1b0258e93f97f5b53036763f689a3713 /app-i18n/anthy
parentStable on sparc (diff)
downloadgentoo-2-eeae102a483de9b18a809b4bff1dfa9f2ffaea27.tar.gz
gentoo-2-eeae102a483de9b18a809b4bff1dfa9f2ffaea27.tar.bz2
gentoo-2-eeae102a483de9b18a809b4bff1dfa9f2ffaea27.zip
use emake for install
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-i18n/anthy')
-rw-r--r--app-i18n/anthy/ChangeLog6
-rw-r--r--app-i18n/anthy/anthy-7100b-r1.ebuild16
-rw-r--r--app-i18n/anthy/anthy-7500b.ebuild18
3 files changed, 23 insertions, 17 deletions
diff --git a/app-i18n/anthy/ChangeLog b/app-i18n/anthy/ChangeLog
index 9c6140e6a9f8..c6ce562ce15f 100644
--- a/app-i18n/anthy/ChangeLog
+++ b/app-i18n/anthy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/anthy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.77 2006/07/12 12:53:50 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/ChangeLog,v 1.78 2006/07/12 13:10:08 hattya Exp $
+
+ 12 Jul 2006; Akinori Hattori <hattya@gentoo.org> -anthy-6700b.ebuild,
+ anthy-7100b-r1.ebuild, anthy-7500b.ebuild:
+ use emake for install
*anthy-7900 (12 Jul 2006)
diff --git a/app-i18n/anthy/anthy-7100b-r1.ebuild b/app-i18n/anthy/anthy-7100b-r1.ebuild
index 3e721092623c..0a263f48dcf4 100644
--- a/app-i18n/anthy/anthy-7100b-r1.ebuild
+++ b/app-i18n/anthy/anthy-7100b-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-7100b-r1.ebuild,v 1.9 2006/05/27 17:44:34 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-7100b-r1.ebuild,v 1.10 2006/07/12 13:10:08 hattya Exp $
inherit elisp-common eutils
@@ -14,8 +14,8 @@ LICENSE="GPL-2"
KEYWORDS="alpha amd64 ia64 ppc ~ppc-macos ppc64 sparc x86"
SLOT="0"
-DEPEND="emacs? ( virtual/emacs )
- !app-i18n/anthy-ss"
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
src_compile() {
@@ -33,19 +33,19 @@ src_compile() {
unset TMPDIR
econf ${myconf} || die
- emake || die
+ emake -j1 || die
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
- use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
-
- rm doc/Makefile*
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ rm doc/Makefile*
dodoc doc/*
}
diff --git a/app-i18n/anthy/anthy-7500b.ebuild b/app-i18n/anthy/anthy-7500b.ebuild
index c1488f4e4f44..2c771467c2ed 100644
--- a/app-i18n/anthy/anthy-7500b.ebuild
+++ b/app-i18n/anthy/anthy-7500b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-7500b.ebuild,v 1.2 2006/04/24 11:04:24 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy/anthy-7500b.ebuild,v 1.3 2006/07/12 13:10:08 hattya Exp $
inherit elisp-common eutils autotools libtool
@@ -14,10 +14,11 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
SLOT="0"
-DEPEND="emacs? ( virtual/emacs )
- !app-i18n/anthy-ss"
+DEPEND="!app-i18n/anthy-ss
+ emacs? ( virtual/emacs )"
src_unpack() {
+
unpack ${A}
cd "${S}"
@@ -25,6 +26,7 @@ src_unpack() {
eautomake
elibtoolize
+
}
src_compile() {
@@ -42,19 +44,19 @@ src_compile() {
fi
econf ${myconf} || die
- emake || die
+ emake -j1 || die
}
src_install() {
- make DESTDIR=${D} install || die
-
- use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+ emake DESTDIR="${D}" install || die
- rm doc/Makefile*
+ use emacs && elisp-site-file-install "${FILESDIR}"/50anthy-gentoo.el
dodoc AUTHORS DIARY NEWS README ChangeLog
+
+ rm doc/Makefile*
dodoc doc/*
}