summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2014-01-06 04:40:43 +0000
committerNaohiro Aota <naota@gentoo.org>2014-01-06 04:40:43 +0000
commit616d8bf1bdb466ee1192d847d32ea8be67dd035c (patch)
tree0629e2a3bc181b77c68e73dce2aa31b6e0351f66 /app-i18n/ibus-qt
parentAdd missing dependency: x11-libs/libnotify #480168 ;Quote ${T} (diff)
downloadgentoo-2-616d8bf1bdb466ee1192d847d32ea8be67dd035c.tar.gz
gentoo-2-616d8bf1bdb466ee1192d847d32ea8be67dd035c.tar.bz2
gentoo-2-616d8bf1bdb466ee1192d847d32ea8be67dd035c.zip
version bump #485794
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F8551514)
Diffstat (limited to 'app-i18n/ibus-qt')
-rw-r--r--app-i18n/ibus-qt/ChangeLog9
-rw-r--r--app-i18n/ibus-qt/ibus-qt-1.3.2.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/app-i18n/ibus-qt/ChangeLog b/app-i18n/ibus-qt/ChangeLog
index 5c41d2c436b5..390ef2113a07 100644
--- a/app-i18n/ibus-qt/ChangeLog
+++ b/app-i18n/ibus-qt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/ibus-qt
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.20 2013/11/11 08:14:10 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ChangeLog,v 1.21 2014/01/06 04:40:43 naota Exp $
+
+*ibus-qt-1.3.2 (06 Jan 2014)
+
+ 06 Jan 2014; Naohiro Aota <naota@gentoo.org> +ibus-qt-1.3.2.ebuild:
+ version bump #485794
11 Nov 2013; Justin Lecher <jlec@gentoo.org> ibus-qt-1.3.1.ebuild,
metadata.xml:
diff --git a/app-i18n/ibus-qt/ibus-qt-1.3.2.ebuild b/app-i18n/ibus-qt/ibus-qt-1.3.2.ebuild
new file mode 100644
index 000000000000..8a7fdd8e8eba
--- /dev/null
+++ b/app-i18n/ibus-qt/ibus-qt-1.3.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus-qt/ibus-qt-1.3.2.ebuild,v 1.1 2014/01/06 04:40:43 naota Exp $
+
+EAPI="5"
+inherit cmake-utils eutils multilib
+
+MY_P="${P}-Source"
+DESCRIPTION="Qt IBus library and Qt input method plugin"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=app-i18n/ibus-1.3.7
+ >=sys-apps/dbus-1.2
+ x11-libs/libX11
+ >=dev-qt/qtcore-4.5:4
+ >=dev-qt/qtdbus-4.5:4"
+DEPEND="${RDEPEND}
+ >=dev-libs/icu-4:=
+ dev-util/cmake
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS="AUTHORS README TODO"
+
+mycmakeargs="-DLIBDIR=$(get_libdir) -DDOCDIR=${EPREFIX}/usr/share/doc/${PF} all"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.0.20091217-doc.patch"
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ cd "${CMAKE_BUILD_DIR}"
+ emake docs || die
+ fi
+}
+
+src_install() {
+ if use doc ; then
+ HTML_DOCS="${CMAKE_BUILD_DIR}/docs/html/*"
+ fi
+
+ cmake-utils_src_install
+}