summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 09:38:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-06-02 09:38:54 +0000
commitbb7b747fadf6441eaebb3d141d859491a53ab1bc (patch)
tree0fec30d7013cf157b43f1bbd0fda1f4f3dbd17e4 /app-i18n/libtabe
parentCleanup. Remove the getmail-3 conditional code. (diff)
downloadgentoo-2-bb7b747fadf6441eaebb3d141d859491a53ab1bc.tar.gz
gentoo-2-bb7b747fadf6441eaebb3d141d859491a53ab1bc.tar.bz2
gentoo-2-bb7b747fadf6441eaebb3d141d859491a53ab1bc.zip
Bump debian patch (make it semi-automatic to bump, too) so that it does not fail with --as-needed; use sequential calls to make to avoid failing with parallel make.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/libtabe')
-rw-r--r--app-i18n/libtabe/ChangeLog12
-rw-r--r--app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild58
2 files changed, 68 insertions, 2 deletions
diff --git a/app-i18n/libtabe/ChangeLog b/app-i18n/libtabe/ChangeLog
index 087757497a9a..6a7f93e93fa8 100644
--- a/app-i18n/libtabe/ChangeLog
+++ b/app-i18n/libtabe/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/libtabe
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/ChangeLog,v 1.13 2008/05/01 14:35:10 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/ChangeLog,v 1.14 2009/06/02 09:38:54 flameeyes Exp $
+
+*libtabe-0.2.6.1.2 (02 Jun 2009)
+
+ 02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +libtabe-0.2.6.1.2.ebuild:
+ Bump debian patch (make it semi-automatic to bump, too) so that it does
+ not fail with --as-needed; use sequential calls to make to avoid failing
+ with parallel make.
01 May 2008; Markus Meier <maekke@gentoo.org>
-files/libtabe-0.2.5-db3.patch, -libtabe-0.2.5.ebuild:
diff --git a/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild b/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild
new file mode 100644
index 000000000000..687adc2170f6
--- /dev/null
+++ b/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/libtabe/libtabe-0.2.6.1.2.ebuild,v 1.1 2009/06/02 09:38:54 flameeyes Exp $
+
+inherit eutils libtool autotools multilib versionator
+
+DEBIAN_PV=$(replace_version_separator 3 '-')
+DEBIAN_PATCH=${PN}_${DEBIAN_PV}.diff
+ORIG_PV=${DEBIAN_PV%-*}
+ORIG_P=${PN}-${ORIG_PV}
+
+DESCRIPTION="Libtabe provides bimsphone support for xcin-2.5+"
+HOMEPAGE="http://packages.qa.debian.org/libt/libtabe.html"
+SRC_URI="mirror://debian/pool/main/${PN:0:4}/${PN}/${PN}_${ORIG_PV}.orig.tar.gz
+ mirror://debian/pool/main/${PN:0:4}/libtabe/${DEBIAN_PATCH}.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND=">=sys-libs/db-4.5
+ x11-libs/libX11"
+
+S=${WORKDIR}/${ORIG_P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${DEBIAN_PATCH}
+ epatch "${FILESDIR}"/${ORIG_P}-fabs.patch
+
+ ln -s script/configure.in . || die
+ eautoreconf
+}
+
+src_compile() {
+ myconf="--with-db-inc=/usr/include
+ --with-db-lib=/usr/$(get_libdir)
+ --with-db-bin=/usr/bin
+ --with-db-name=db
+ --enable-shared
+ --disable-static
+ $(use_enable debug)"
+
+ econf ${myconf}
+
+ # We execute this serially because the Makefiles don't handle
+ # proper cross-directory references.
+ for dir in src util tsi-src; do
+ emake -C ${dir} || die "make failed"
+ done
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc doc/* || die
+}