summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-09 17:01:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-03-09 17:01:24 +0000
commitab79d42e7a962eca340662733268288c37492b98 (patch)
treed40fc5df22628b81b93e357eac1c69627c52763f /app-i18n/scim-qtimm
parentdigests, wth ? (diff)
downloadgentoo-2-ab79d42e7a962eca340662733268288c37492b98.tar.gz
gentoo-2-ab79d42e7a962eca340662733268288c37492b98.tar.bz2
gentoo-2-ab79d42e7a962eca340662733268288c37492b98.zip
Ebuild cleanup as per bug #121258. Allow parallel build, remove arts and add debug useflags.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'app-i18n/scim-qtimm')
-rw-r--r--app-i18n/scim-qtimm/ChangeLog9
-rw-r--r--app-i18n/scim-qtimm/files/scim-qtimm-0.9.4-qtimm-check.patch19
-rw-r--r--app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild37
3 files changed, 46 insertions, 19 deletions
diff --git a/app-i18n/scim-qtimm/ChangeLog b/app-i18n/scim-qtimm/ChangeLog
index 6de8119faf89..3d2e7ed2bad1 100644
--- a/app-i18n/scim-qtimm/ChangeLog
+++ b/app-i18n/scim-qtimm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-qtimm
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-qtimm/ChangeLog,v 1.29 2005/09/03 21:05:24 hansmi Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-qtimm/ChangeLog,v 1.30 2006/03/09 17:01:24 flameeyes Exp $
+
+ 09 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/scim-qtimm-0.9.4-qtimm-check.patch, scim-qtimm-0.9.4.ebuild:
+ Ebuild cleanup as per bug #121258. Allow parallel build, remove arts and add
+ debug useflags.
03 Sep 2005; Michael Hanselmann <hansmi@gentoo.org>
scim-qtimm-0.9.3.ebuild:
diff --git a/app-i18n/scim-qtimm/files/scim-qtimm-0.9.4-qtimm-check.patch b/app-i18n/scim-qtimm/files/scim-qtimm-0.9.4-qtimm-check.patch
new file mode 100644
index 000000000000..dcfaa3b8d937
--- /dev/null
+++ b/app-i18n/scim-qtimm/files/scim-qtimm-0.9.4-qtimm-check.patch
@@ -0,0 +1,19 @@
+Index: work/scim-qtimm-0.9.4/configure.in.in
+===================================================================
+--- work.orig/scim-qtimm-0.9.4/configure.in.in
++++ work/scim-qtimm-0.9.4/configure.in.in
+@@ -131,12 +131,12 @@ INPUTMETHODSDIR=$QTDIR_LOCAL/plugins/inp
+ AC_SUBST(INPUTMETHODSDIR)
+
+ if test "$kde_qtver" = "3"; then
+-if test ! -e $qt_incdir/qinputcontext.h -o ! -e $qt_incdir/qinputcontextplugin.h; then
++KDE_CHECK_HEADERS([qinputcontext.h qinputcontextplugin.h], , [
+ AC_MSG_ERROR([
+ The Qt library was not compiled with the qt-immodule patch
+ applied please download it from
+ http://immodule-qt.freedesktop.org/Software/ImmoduleQtDownload and recompile Qt.])
+-fi
++])
+ fi
+
+ AC_MSG_RESULT([
diff --git a/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild b/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild
index 0f5e680b9b9c..5efc49cca579 100644
--- a/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild
+++ b/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild,v 1.1 2005/08/17 10:27:30 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-qtimm/scim-qtimm-0.9.4.ebuild,v 1.2 2006/03/09 17:01:24 flameeyes Exp $
-inherit kde-functions
+inherit kde-functions eutils
DESCRIPTION="Qt immodules input method framework plugin for SCIM"
HOMEPAGE="http://scim.freedesktop.org/"
@@ -12,32 +12,35 @@ SRC_URI="mirror://sourceforge/scim/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="nls arts"
+IUSE="nls debug"
-DEPEND="|| ( >=app-i18n/scim-1.4.2 >=app-i18n/scim-cvs-1.4.2 )
- nls? ( sys-devel/gettext )
- arts? ( kde-base/arts )
+RDEPEND="|| ( >=app-i18n/scim-1.4.2 >=app-i18n/scim-cvs-1.4.2 )
+ nls? ( virtual/libintl )
$(qt_min_version 3.3.4)"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
pkg_setup() {
if [ ! -e /usr/qt/3/plugins/inputmethods/libqimsw-none.so ] ; then
die "You need to rebuild >=x11-libs/qt-3.3.4 with immqt-bc(recommended) or immqt USE flag enabled."
fi
}
-src_compile() {
+src_unpack() {
+ unpack ${A}
+ cd ${S}
- # bug #84369
- if which kde-config >/dev/null 2>&1 ; then
- export KDEDIR=$(kde-config --prefix)
- export kde_kcfgdir=/usr/share/config.kcfg
- export kde_servicesdir=/usr/share/services
- fi
+ epatch "${FILESDIR}/${P}-qtimm-check.patch"
- econf --enable-mt \
+ make -f admin/Makefile.common || die "reautotooling failed"
+}
+
+src_compile() {
+ econf \
$(use_enable nls) \
- $(use_with arts) || die
- emake -j1 || die "make failed."
+ $(use_enable debug scim-debug) || die
+ emake || die "make failed."
}
src_install() {