summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-12-28 16:19:24 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-12-28 16:19:24 +0000
commit8637f1c143112d0c9e28073bcaed1f9ea91a7f3f (patch)
tree8641537b25fc1b65e95d5030066c6b1707f08a69 /app-i18n/scim-wijesekera
parentRemoved app-i18n/scim-wijesekera from p.mask, bug #250680. (diff)
downloadgentoo-2-8637f1c143112d0c9e28073bcaed1f9ea91a7f3f.tar.gz
gentoo-2-8637f1c143112d0c9e28073bcaed1f9ea91a7f3f.tar.bz2
gentoo-2-8637f1c143112d0c9e28073bcaed1f9ea91a7f3f.zip
Fixed gcc-4.3 issue, bug #250680.
(Portage version: 2.1.6.3/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-i18n/scim-wijesekera')
-rw-r--r--app-i18n/scim-wijesekera/ChangeLog9
-rw-r--r--app-i18n/scim-wijesekera/files/scim-wijesekera-0.3.3-gcc43.patch22
-rw-r--r--app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild31
3 files changed, 61 insertions, 1 deletions
diff --git a/app-i18n/scim-wijesekera/ChangeLog b/app-i18n/scim-wijesekera/ChangeLog
index 65ba55e720a0..bbbb7bfef6fa 100644
--- a/app-i18n/scim-wijesekera/ChangeLog
+++ b/app-i18n/scim-wijesekera/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/scim-wijesekera
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/ChangeLog,v 1.2 2008/10/04 19:07:02 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/ChangeLog,v 1.3 2008/12/28 16:19:24 matsuu Exp $
+
+*scim-wijesekera-0.3.3-r1 (28 Dec 2008)
+
+ 28 Dec 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/scim-wijesekera-0.3.3-gcc43.patch,
+ +scim-wijesekera-0.3.3-r1.ebuild:
+ Fixed gcc-4.3 issue, bug #250680.
04 Oct 2008; Thomas Anderson <gentoofan23@gentoo.org>
scim-wijesekera-0.3.3.ebuild:
diff --git a/app-i18n/scim-wijesekera/files/scim-wijesekera-0.3.3-gcc43.patch b/app-i18n/scim-wijesekera/files/scim-wijesekera-0.3.3-gcc43.patch
new file mode 100644
index 000000000000..1fa083fd7c8d
--- /dev/null
+++ b/app-i18n/scim-wijesekera/files/scim-wijesekera-0.3.3-gcc43.patch
@@ -0,0 +1,22 @@
+diff -Naur scim-wijesekera-0.3.3.orig/src/scim_wijesekera_imengine.cpp scim-wijesekera-0.3.3/src/scim_wijesekera_imengine.cpp
+--- scim-wijesekera-0.3.3.orig/src/scim_wijesekera_imengine.cpp 2008-04-26 17:45:15.000000000 +0900
++++ scim-wijesekera-0.3.3/src/scim_wijesekera_imengine.cpp 2008-12-29 01:07:23.000000000 +0900
+@@ -33,6 +33,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <cstring>
+ #include <unistd.h>
+ #include <sys/types.h>
+ #include <sys/wait.h>
+diff -Naur scim-wijesekera-0.3.3.orig/src/scim_wijesekera_imengine_setup.cpp scim-wijesekera-0.3.3/src/scim_wijesekera_imengine_setup.cpp
+--- scim-wijesekera-0.3.3.orig/src/scim_wijesekera_imengine_setup.cpp 2008-04-26 17:45:15.000000000 +0900
++++ scim-wijesekera-0.3.3/src/scim_wijesekera_imengine_setup.cpp 2008-12-29 01:07:03.000000000 +0900
+@@ -30,6 +30,7 @@
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
++#include <cstring>
+
+ #include <scim.h>
+ #include <gtk/scimkeyselection.h>
diff --git a/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
new file mode 100644
index 000000000000..8cbb653d97c9
--- /dev/null
+++ b/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-wijesekera/scim-wijesekera-0.3.3-r1.ebuild,v 1.1 2008/12/28 16:19:24 matsuu Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Wijesekara keyboard for Sinhala input using scim"
+HOMEPAGE="http://sinhala.sourceforge.net/"
+SRC_URI="http://sinhala.sourceforge.net/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=app-i18n/scim-0.99.8"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}