summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-29 16:10:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-29 16:10:06 +0000
commit84340c9dfd539df38182f943105c50f2c46567df (patch)
treec191bb59a7835bb5da0ca538d7659c0de2e718bd /app-i18n/xcin
parentmake sure that all installed files are in ${S}, reported by flameeyes in bug ... (diff)
downloadgentoo-2-84340c9dfd539df38182f943105c50f2c46567df.tar.gz
gentoo-2-84340c9dfd539df38182f943105c50f2c46567df.tar.bz2
gentoo-2-84340c9dfd539df38182f943105c50f2c46567df.zip
Fix building with GLIBC 2.10+ wrt #298015.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n/xcin')
-rw-r--r--app-i18n/xcin/ChangeLog8
-rw-r--r--app-i18n/xcin/files/xcin-2.5.3_pre3-glibc-2.10.patch110
-rw-r--r--app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild7
3 files changed, 120 insertions, 5 deletions
diff --git a/app-i18n/xcin/ChangeLog b/app-i18n/xcin/ChangeLog
index 704a66d3d8b8..c511f67ceefe 100644
--- a/app-i18n/xcin/ChangeLog
+++ b/app-i18n/xcin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-i18n/xcin
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/ChangeLog,v 1.19 2008/05/04 17:49:08 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/ChangeLog,v 1.20 2009/12/29 16:10:05 ssuominen Exp $
+
+ 29 Dec 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xcin-2.5.3_pre3-r2.ebuild, +files/xcin-2.5.3_pre3-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #298015.
04 May 2008; nixnut <nixnut@gentoo.org> xcin-2.5.3_pre3-r2.ebuild:
Stable on ppc wrt bug 148096
diff --git a/app-i18n/xcin/files/xcin-2.5.3_pre3-glibc-2.10.patch b/app-i18n/xcin/files/xcin-2.5.3_pre3-glibc-2.10.patch
new file mode 100644
index 000000000000..3d472f95b0f4
--- /dev/null
+++ b/app-i18n/xcin/files/xcin-2.5.3_pre3-glibc-2.10.patch
@@ -0,0 +1,110 @@
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/doc/En/internal/module.En xcin-2.5.2.99.pre2+cvs20030224/doc/En/internal/module.En
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/doc/En/internal/module.En 2000-12-13 18:55:41.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/doc/En/internal/module.En 2009-12-29 18:09:20.000000000 +0200
+@@ -481,13 +481,13 @@
+ char *lc_ctype; /* LC_CTYPE locale category name */
+ char *lc_messages; /* LC_MESSAGES locale category name */
+ char *encoding; /* encoding name */
+- } locale_t;
++ } xcin_locale_t;
+
+ typedef struct {
+ char *rcfile; /* rcfile name. */
+ char *default_dir; /* Default module directory. */
+ char *user_dir; /* User data directory. */
+- locale_t locale; /* Locale name. */
++ xcin_locale_t locale; /* Locale name. */
+ } xcin_rc_t;
+
+ The return value of this function is True when excuting successfully,
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/doc/internal/module xcin-2.5.2.99.pre2+cvs20030224/doc/internal/module
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/doc/internal/module 2002-10-29 13:53:42.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/doc/internal/module 2009-12-29 18:09:24.000000000 +0200
+@@ -423,13 +423,13 @@
+ char *lc_ctype; /* LC_CTYPE locale category name */
+ char *lc_messages; /* LC_MESSAGES locale category name */
+ char *encoding; /* encoding name */
+- } locale_t;
++ } xcin_locale_t;
+
+ typedef struct {
+ char *rcfile; /* rcfile name. */
+ char *default_dir; /* Default module directory. */
+ char *user_dir; /* User data directory. */
+- locale_t locale; /* Locale name. */
++ xcin_locale_t locale; /* Locale name. */
+ } xcin_rc_t;
+
+ 本函式若成功傳回 True, 失敗傳回 False。
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/src/include/xcintool.h xcin-2.5.2.99.pre2+cvs20030224/src/include/xcintool.h
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/src/include/xcintool.h 2002-10-29 13:53:42.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/src/include/xcintool.h 2009-12-29 18:09:01.000000000 +0200
+@@ -202,12 +202,12 @@
+ char *lc_messages;
+ char *encoding;
+ int encid, locid;
+-} locale_t;
++} xcin_locale_t;
+
+ typedef struct {
+ int argc; /* Command line arguement list */
+ char **argv;
+- locale_t locale; /* Locale name. */
++ xcin_locale_t locale; /* Locale name. */
+ char *usrhome; /* User home directory. */
+ char *default_dir; /* Default module directory. */
+ char *user_dir; /* User data directory. */
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/src/util/cin2tab/cin2tab.c xcin-2.5.2.99.pre2+cvs20030224/src/util/cin2tab/cin2tab.c
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/src/util/cin2tab/cin2tab.c 2009-12-29 18:07:44.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/src/util/cin2tab/cin2tab.c 2009-12-29 18:09:12.000000000 +0200
+@@ -233,7 +233,7 @@
+ }
+
+ static void
+-cin2tab_setlocale(locale_t *locale)
++cin2tab_setlocale(xcin_locale_t *locale)
+ {
+ char loc_return[128], enc_return[128];
+ int ret;
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/src/xcin_main.c xcin-2.5.2.99.pre2+cvs20030224/src/xcin_main.c
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/src/xcin_main.c 2003-01-20 19:50:05.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/src/xcin_main.c 2009-12-29 18:09:06.000000000 +0200
+@@ -56,7 +56,7 @@
+ static void
+ xcin_setlocale(void)
+ {
+- locale_t *locale = &(xcin_core.xcin_rc.locale);
++ xcin_locale_t *locale = &(xcin_core.xcin_rc.locale);
+ char loc_return[128], enc_return[128];
+
+ set_perr("xcin");
+@@ -332,7 +332,7 @@
+ char *cmd[2], value[256], *s, loc_buf[64], *loc_name=NULL;
+ char *fmt = N_("%s:\n\tlocale section \"%s\": %s: value not specified.\n");
+ xcin_rc_t *xrc = &(xcin_core.xcin_rc);
+- locale_t *locale = &(xcin_core.xcin_rc.locale);
++ xcin_locale_t *locale = &(xcin_core.xcin_rc.locale);
+ /*
+ * Determine the true locale setting name.
+ */
+@@ -409,7 +409,7 @@
+ char *cmd[2], value[256], *s, *s1, objname[100], objenc[100];
+ char *fmt = N_("%s:\n\tIM section \"%s\": %s: %s.\n");
+ xcin_rc_t *xrc = &(xcin_core.xcin_rc);
+- locale_t *locale = &(xcin_core.xcin_rc.locale);
++ xcin_locale_t *locale = &(xcin_core.xcin_rc.locale);
+ int setkey;
+ /*
+ * Go to each CINPUT sub-node and read important keywords.
+diff -ur xcin-2.5.2.99.pre2+cvs20030224.orig/src/xim.c xcin-2.5.2.99.pre2+cvs20030224/src/xim.c
+--- xcin-2.5.2.99.pre2+cvs20030224.orig/src/xim.c 2009-12-29 18:07:44.000000000 +0200
++++ xcin-2.5.2.99.pre2+cvs20030224/src/xim.c 2009-12-29 18:09:06.000000000 +0200
+@@ -1032,7 +1032,7 @@
+ XIMTriggerKeys on_keys;
+ XIMEncodings encodings;
+ Window mainwin;
+- locale_t *locale;
++ xcin_locale_t *locale;
+ char* imlocale = NULL;
+ int i;
+
diff --git a/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild b/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
index 03881dcac126..c466aabb09bb 100644
--- a/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
+++ b/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild,v 1.3 2008/05/04 17:49:08 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/xcin-2.5.3_pre3-r2.ebuild,v 1.4 2009/12/29 16:10:05 ssuominen Exp $
inherit multilib eutils autotools libtool
@@ -13,7 +13,7 @@ SRC_URI="mirror://debian/pool/main/x/${PN}/${MY_P}.orig.tar.gz
LICENSE="XCIN GPL-2"
SLOT="0"
-KEYWORDS="ppc x86"
+KEYWORDS="~amd64 ppc x86"
IUSE="debug nls unicode"
RDEPEND=">=sys-libs/db-4.5
@@ -31,6 +31,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${WORKDIR}"/${MY_P}-1.4.diff
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
rm -f configure
cd script
elibtoolize