summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-11 23:07:47 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-11 23:07:47 +0000
commit005aee668e2ca7767aefc097c52ad58a8fbd7679 (patch)
tree610fe50cc97da6302815da7d01db5d018fe07886 /app-i18n
parentAllow building with DB 4.8.30 (diff)
downloadgentoo-2-005aee668e2ca7767aefc097c52ad58a8fbd7679.tar.gz
gentoo-2-005aee668e2ca7767aefc097c52ad58a8fbd7679.tar.bz2
gentoo-2-005aee668e2ca7767aefc097c52ad58a8fbd7679.zip
Fixed python dependency, bug #311211.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/ibus/ChangeLog9
-rw-r--r--app-i18n/ibus/ibus-1.2.1-r1.ebuild106
-rw-r--r--app-i18n/ibus/ibus-1.3.3-r1.ebuild (renamed from app-i18n/ibus/ibus-1.3.2.ebuild)6
3 files changed, 119 insertions, 2 deletions
diff --git a/app-i18n/ibus/ChangeLog b/app-i18n/ibus/ChangeLog
index 7061dae11f3b..1937a7a726a2 100644
--- a/app-i18n/ibus/ChangeLog
+++ b/app-i18n/ibus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-i18n/ibus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.59 2010/05/07 16:14:57 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ChangeLog,v 1.60 2010/05/11 23:07:47 matsuu Exp $
+
+*ibus-1.3.3-r1 (11 May 2010)
+*ibus-1.2.1-r1 (11 May 2010)
+
+ 11 May 2010; MATSUU Takuto <matsuu@gentoo.org> +ibus-1.2.1-r1.ebuild,
+ -ibus-1.3.2.ebuild, +ibus-1.3.3-r1.ebuild:
+ Fixed python dependency, bug #311211.
*ibus-1.3.3 (07 May 2010)
diff --git a/app-i18n/ibus/ibus-1.2.1-r1.ebuild b/app-i18n/ibus/ibus-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..922626447d2e
--- /dev/null
+++ b/app-i18n/ibus/ibus-1.2.1-r1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.2.1-r1.ebuild,v 1.1 2010/05/11 23:07:47 matsuu Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.5"
+inherit eutils gnome2-utils multilib python
+
+DESCRIPTION="Intelligent Input Bus for Linux / Unix OS"
+HOMEPAGE="http://code.google.com/p/ibus/"
+SRC_URI="http://ibus.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2
+ >=gnome-base/gconf-2.12
+ >=gnome-base/librsvg-2
+ sys-apps/dbus
+ app-text/iso-codes
+ x11-libs/libX11
+ >=dev-python/pygobject-2.14
+ dev-python/notify-python
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )
+ nls? ( >=sys-devel/gettext-0.16.1 )"
+RDEPEND="${RDEPEND}
+ dev-python/pygtk
+ >=dev-python/dbus-python-0.83
+ dev-python/pyxdg"
+
+RESTRICT="test"
+
+update_gtk_immodules() {
+ if [ -x /usr/bin/gtk-query-immodules-2.0 ] ; then
+ GTK2_CONFDIR="/etc/gtk-2.0"
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="${GTK2_CONFDIR}/${CHOST}"
+ mkdir -p "${ROOT}${GTK2_CONFDIR}"
+ gtk-query-immodules-2.0 > "${ROOT}${GTK2_CONFDIR}/gtk.immodules"
+ fi
+}
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ mv py-compile py-compile.orig || die
+ ln -s "$(type -P true)" py-compile || die
+ echo "ibus/_config.py" >> po/POTFILES.skip || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable nls) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # bug 289547
+ keepdir /usr/share/ibus/{engine,icons} || die
+
+ dodoc AUTHORS ChangeLog NEWS README || die
+}
+
+pkg_postinst() {
+
+ elog "To use ibus, you should:"
+ elog "1. Get input engines from sunrise overlay."
+ elog " Run \"emerge -s ibus-\" in your favorite terminal"
+ elog " for a list of packages we already have."
+ elog
+ elog "2. Setup ibus:"
+ elog
+ elog " $ ibus-setup"
+ elog
+ elog "3. Set the following in your user startup scripts"
+ elog " such as .xinitrc, .xsession or .xprofile:"
+ elog
+ elog " export XMODIFIERS=\"@im=ibus\""
+ elog " export GTK_IM_MODULE=\"ibus\""
+ elog " export QT_IM_MODULE=\"xim\""
+ elog " ibus-daemon -d -x"
+
+ update_gtk_immodules
+
+ python_mod_optimize /usr/share/${PN}
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ update_gtk_immodules
+
+ python_mod_cleanup /usr/share/${PN}
+ gnome2_icon_cache_update
+}
diff --git a/app-i18n/ibus/ibus-1.3.2.ebuild b/app-i18n/ibus/ibus-1.3.3-r1.ebuild
index 88e1cdc02477..b3debf984b45 100644
--- a/app-i18n/ibus/ibus-1.3.2.ebuild
+++ b/app-i18n/ibus/ibus-1.3.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.3.2.ebuild,v 1.1 2010/04/23 17:45:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/ibus/ibus-1.3.3-r1.ebuild,v 1.1 2010/05/11 23:07:47 matsuu Exp $
EAPI="2"
PYTHON_DEPEND="python? 2:2.5"
@@ -52,6 +52,10 @@ update_gtk_immodules() {
fi
}
+pkg_setup() {
+ python_set_active_version 2
+}
+
src_prepare() {
mv py-compile py-compile.orig || die
ln -s "$(type -P true)" py-compile || die