summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-03-28 16:34:04 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-03-28 16:34:04 +0000
commit16b9db31bbefa25724bc0e3bc2da3dc97296788b (patch)
tree083d0a3a2a8ea3ca3ed0f5e043ab6bb7f98734e3 /app-i18n
parentIgnore luks crypt devices while not fully up. Small rule cleanup. (diff)
downloadgentoo-2-16b9db31bbefa25724bc0e3bc2da3dc97296788b.tar.gz
gentoo-2-16b9db31bbefa25724bc0e3bc2da3dc97296788b.tar.bz2
gentoo-2-16b9db31bbefa25724bc0e3bc2da3dc97296788b.zip
Version bumped.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-anthy/ChangeLog7
-rw-r--r--app-i18n/scim-anthy/files/digest-scim-anthy-1.3.03
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.3.0.ebuild58
3 files changed, 67 insertions, 1 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index 20bd2d91e887..93955842a78b 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-i18n/scim-anthy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.41 2007/03/24 22:23:17 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.42 2007/03/28 16:34:03 matsuu Exp $
+
+*scim-anthy-1.3.0 (28 Mar 2007)
+
+ 28 Mar 2007; MATSUU Takuto <matsuu@gentoo.org> +scim-anthy-1.3.0.ebuild:
+ Version bumped.
24 Mar 2007; Matti Bickel <mabi@gentoo.org> scim-anthy-1.2.2.ebuild:
~ppc readded (bug #167429)
diff --git a/app-i18n/scim-anthy/files/digest-scim-anthy-1.3.0 b/app-i18n/scim-anthy/files/digest-scim-anthy-1.3.0
new file mode 100644
index 000000000000..e7d720f229b3
--- /dev/null
+++ b/app-i18n/scim-anthy/files/digest-scim-anthy-1.3.0
@@ -0,0 +1,3 @@
+MD5 2f7d8421aaf505b6d4afd907dfc6f57f scim-anthy-1.3.0.tar.gz 706279
+RMD160 25c2d5f60d0079705c3156be777404799cc7791a scim-anthy-1.3.0.tar.gz 706279
+SHA256 fcc1d1db129fb932554cf43479c363a9fc76aebd3039ac926e7461870c481545 scim-anthy-1.3.0.tar.gz 706279
diff --git a/app-i18n/scim-anthy/scim-anthy-1.3.0.ebuild b/app-i18n/scim-anthy/scim-anthy-1.3.0.ebuild
new file mode 100644
index 000000000000..2d2badb889ac
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.3.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.3.0.ebuild,v 1.1 2007/03/28 16:34:03 matsuu Exp $
+
+inherit libtool
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/24668/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk kde nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )
+ || ( >=app-i18n/anthy-7500 >=app-i18n/anthy-ss-7500 )
+ nls? ( virtual/libintl )
+ gtk? ( >=x11-libs/gtk+-2.8 )"
+RDEPEND="${DEPEND}
+ app-dicts/kasumi"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+PDEPEND="kde? ( app-i18n/skim-scim-anthy )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS THANKS README
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}