summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-09-10 08:31:38 +0000
committerIan Delaney <idella4@gentoo.org>2013-09-10 08:31:38 +0000
commit27f0d4ca4916112af5e9329e663e2fc4bdc36907 (patch)
tree7cb72f3d3814ae67d945e4bf31a530344b4a7edf /app-i18n
parentDeclare EGIT_REPO_URI to make smart-live-rebuild a bit happier. (diff)
downloadgentoo-2-27f0d4ca4916112af5e9329e663e2fc4bdc36907.tar.gz
gentoo-2-27f0d4ca4916112af5e9329e663e2fc4bdc36907.tar.bz2
gentoo-2-27f0d4ca4916112af5e9329e663e2fc4bdc36907.zip
revbump -> EAPI 5
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/zinnia/ChangeLog8
-rw-r--r--app-i18n/zinnia/zinnia-0.05.ebuild19
-rw-r--r--app-i18n/zinnia/zinnia-0.06-r2.ebuild78
3 files changed, 85 insertions, 20 deletions
diff --git a/app-i18n/zinnia/ChangeLog b/app-i18n/zinnia/ChangeLog
index 620f6c6458c4..3708c9444c04 100644
--- a/app-i18n/zinnia/ChangeLog
+++ b/app-i18n/zinnia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/zinnia
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zinnia/ChangeLog,v 1.7 2013/09/01 10:08:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zinnia/ChangeLog,v 1.8 2013/09/10 08:31:38 idella4 Exp $
+
+*zinnia-0.06-r2 (10 Sep 2013)
+
+ 10 Sep 2013; Ian Delaney <idella4@gentoo.org> +zinnia-0.06-r2.ebuild,
+ -zinnia-0.05.ebuild:
+ revbump -> EAPI 5
01 Sep 2013; Agostino Sarubbo <ago@gentoo.org> zinnia-0.06-r1.ebuild:
Stable for x86, wrt bug #480822
diff --git a/app-i18n/zinnia/zinnia-0.05.ebuild b/app-i18n/zinnia/zinnia-0.05.ebuild
deleted file mode 100644
index 3c34bfb83a15..000000000000
--- a/app-i18n/zinnia/zinnia-0.05.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/zinnia/zinnia-0.05.ebuild,v 1.1 2010/05/04 02:38:01 matsuu Exp $
-
-DESCRIPTION="Online hand recognition system with machine learning"
-HOMEPAGE="http://zinnia.sourceforge.net/"
-SRC_URI="mirror://sourceforge/zinnia/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-src_install() {
- emake DESTDIR="${D}" install || die
-
- dodoc AUTHORS ChangeLog NEWS README || die
- dohtml doc/*.html doc/*.css || die
-}
diff --git a/app-i18n/zinnia/zinnia-0.06-r2.ebuild b/app-i18n/zinnia/zinnia-0.06-r2.ebuild
new file mode 100644
index 000000000000..e3379b5e41a5
--- /dev/null
+++ b/app-i18n/zinnia/zinnia-0.06-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/zinnia/zinnia-0.06-r2.ebuild,v 1.1 2013/09/10 08:31:38 idella4 Exp $
+
+EAPI=5
+
+inherit perl-module eutils flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="Online hand recognition system with machine learning"
+HOMEPAGE="http://zinnia.sourceforge.net/"
+SRC_URI="mirror://sourceforge/zinnia/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Package warrants ISUE doc
+IUSE="perl"
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ricedown.patch"
+ epatch "${FILESDIR}/${P}-perl.patch"
+ eautoreconf
+
+ if use perl ; then
+ (
+ cd "${S}/perl"
+ perl-module_src_prepare
+ )
+ fi
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ base_src_compile
+
+ if use perl ; then
+ (
+ cd "${S}/perl"
+
+ # We need to run this here as otherwise it won't pick up the
+ # just-built -lzinnia and cause the extension to have
+ # undefined symbols.
+ perl-module_src_configure
+
+ append-cppflags "-I${S}"
+ append-ldflags "-L${S}/.libs"
+
+ emake \
+ LDDLFLAGS="-shared" \
+ OTHERLDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCXX)" LD="$(tc-getCXX)" \
+ OPTIMIZE="${CPPFLAGS} ${CXXFLAGS}" \
+ )
+ fi
+}
+
+# no tests present
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete
+
+ if use perl ; then
+ (
+ cd "${S}/perl"
+ perl-module_src_install
+ )
+ fi
+
+ # Curiously ChangeLog & NEWS are left uncompressed
+ dodoc ${DOCS[@]}
+ dohtml doc/*.html doc/*.css
+}