summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-05-07 15:29:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-05-07 15:29:03 +0000
commitba9eff2eb5f58832f79b8c253778abb3149bdd36 (patch)
treec7be73be9685290f1b1d170e9666273efdeed709 /app-i18n
parentChainsaw is taking over maintaining nvidia-drivers (diff)
downloadgentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.tar.gz
gentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.tar.bz2
gentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.zip
Fixed build failure with gcc-4.3, the patch is from debian bug #455270.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-skk/ChangeLog10
-rw-r--r--app-i18n/scim-skk/files/scim-skk-0.5.2-gcc43.patch11
-rw-r--r--app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild54
3 files changed, 73 insertions, 2 deletions
diff --git a/app-i18n/scim-skk/ChangeLog b/app-i18n/scim-skk/ChangeLog
index 65645b6912cf..af664e004ea0 100644
--- a/app-i18n/scim-skk/ChangeLog
+++ b/app-i18n/scim-skk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-i18n/scim-skk
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-skk/ChangeLog,v 1.18 2007/01/05 16:31:32 flameeyes Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-skk/ChangeLog,v 1.19 2008/05/07 15:29:02 matsuu Exp $
+
+*scim-skk-0.5.2-r1 (07 May 2008)
+
+ 07 May 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/scim-skk-0.5.2-gcc43.patch, +scim-skk-0.5.2-r1.ebuild:
+ Fixed build failure with gcc-4.3, the patch is from debian bug #455270.
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> scim-skk-0.5.2.ebuild:
Convert to use elog.
diff --git a/app-i18n/scim-skk/files/scim-skk-0.5.2-gcc43.patch b/app-i18n/scim-skk/files/scim-skk-0.5.2-gcc43.patch
new file mode 100644
index 000000000000..8223eb3502ce
--- /dev/null
+++ b/app-i18n/scim-skk/files/scim-skk-0.5.2-gcc43.patch
@@ -0,0 +1,11 @@
+--- a/src/scim_skk_imengine_setup.cpp
++++ b/src/scim_skk_imengine_setup.cpp
+@@ -39,6 +39,8 @@
+ #include "scim_skk_intl.h"
+ #include "scim_skk_setup_dictionaries.h"
+
++#include <cstring>
++
+ using namespace scim;
+
+ namespace scim_skk {
diff --git a/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild b/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..924479402271
--- /dev/null
+++ b/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild,v 1.1 2008/05/07 15:29:02 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Japanese input method SKK IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMSKK"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/18121/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )"
+RDEPEND="${DEPEND}
+ || ( app-i18n/skk-jisyo virtual/skkserv )
+ nls? ( virtual/libintl )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-static || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}