summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2008-12-08 10:33:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2008-12-08 10:33:10 +0000
commit172f1e19536e6cc785e78401c07b92f017ec87dd (patch)
tree7b7d1502dee6a2037d1d2ef29dffdc489dfd76ac /app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild
parentfixed MAKEOPTS setting (#250132) (diff)
downloadgentoo-2-172f1e19536e6cc785e78401c07b92f017ec87dd.tar.gz
gentoo-2-172f1e19536e6cc785e78401c07b92f017ec87dd.tar.bz2
gentoo-2-172f1e19536e6cc785e78401c07b92f017ec87dd.zip
Use system lrmi library to fix building with GLIBC 2.8, incorporated with GCC 3.x and linux-headers patchset. Untested version. Closes bug #240018.
(Portage version: 2.1.6_rc3/cvs/Linux 2.6.27.7 i686)
Diffstat (limited to 'app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild')
-rw-r--r--app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild b/app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..342efb7a8f05
--- /dev/null
+++ b/app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/lphdisk/lphdisk-0.9.1-r2.ebuild,v 1.1 2008/12/08 10:33:10 ssuominen Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility for preparing a hibernation partition for APM Suspend-To-Disk"
+HOMEPAGE="http://www.procyon.com/~pda/lphdisk/"
+SRC_URI="http://www.procyon.com/~pda/lphdisk/${P}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-libs/lrmi"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+}
+
+pkg_postinst() {
+ ewarn "This package is now using external lrmi library instead of shipped"
+ ewarn "copy it came with. This package is untested, use at your own risk."
+}