summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 02:38:16 +0000
commit0ba2da8c1d8edaed3fd1b059f3dc80b334d89314 (patch)
treeb4720eadae9333815ae7989d9d8c4b55da9b4f8f /app-laptop/tpctl/tpctl-4.2.ebuild
parentAdded ~mips. Fixed CXXFLAGS so that non-x86 builds work. QA: added IUSE. (Man... (diff)
downloadgentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.tar.gz
gentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.tar.bz2
gentoo-2-0ba2da8c1d8edaed3fd1b059f3dc80b334d89314.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-laptop/tpctl/tpctl-4.2.ebuild')
-rw-r--r--app-laptop/tpctl/tpctl-4.2.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/app-laptop/tpctl/tpctl-4.2.ebuild b/app-laptop/tpctl/tpctl-4.2.ebuild
index c58d599a1460..c2aa7b155d75 100644
--- a/app-laptop/tpctl/tpctl-4.2.ebuild
+++ b/app-laptop/tpctl/tpctl-4.2.ebuild
@@ -1,50 +1,51 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.2.ebuild,v 1.2 2004/06/24 22:00:48 agriffis Exp $
-
-IUSE="ncurses tpctlir perl"
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpctl/tpctl-4.2.ebuild,v 1.3 2004/06/28 02:37:53 vapier Exp $
#transform P to match tarball versioning
MYPV=${PV/_beta/beta}
MYP="${PN}_${MYPV}"
DESCRIPTION="Thinkpad system control user space programs"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="-* x86"
-SLOT="0"
+SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE="ncurses tpctlir perl"
-DEPEND="$DEPEND >=app-laptop/thinkpad-4.1 ncurses? ( sys-libs/ncurses )"
-RDEPEND="$RDEPEND app-laptop/thinkpad ncurses? ( sys-libs/ncurses ) perl? ( dev-lang/perl )"
+DEPEND=">=app-laptop/thinkpad-4.1
+ ncurses? ( sys-libs/ncurses )"
+RDEPEND="${DEPEND}
+ perl? ( dev-lang/perl )"
src_compile() {
emake -C lib || die "lib make failed"
emake -C tpctl || die "tpctl make failed"
- if use ncurses > /dev/null; then
+ if use ncurses ; then
emake -C ntpctl || die "ntpctl make failed"
fi
# Only for thinkpad models 760 and 765
# build with:
# $ USE=tpctlir emerge tpctl
- if use tpctlir > /dev/null; then
+ if use tpctlir ; then
emake -C tpctlir || die "tpctlir make failed"
fi
}
src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING \
- VGA-MODES
+ dodoc AUTHORS ChangeLog README SUPPORTED-MODELS TROUBLESHOOTING VGA-MODES
dolib lib/libsmapidev.so.2.0
dobin tpctl/tpctl
[ -e ntpctl/ntpctl ] && dobin ntpctl/ntpctl
- if use tpctlir > /dev/null && [ -e tpctlir/tpctlir ]; then
+ if use tpctlir && [ -e tpctlir/tpctlir ]; then
mv tpctlir/README README.tpctlir
dodoc README.tpctlir
dobin tpctlir/tpctlir
fi
- if use perl > /dev/null; then
+ if use perl ; then
mv apmiser/README README.apmiser
dodoc README.apmiser
dosbin apmiser/apmiser