summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2007-04-20 13:18:01 +0000
committerTony Vroon <chainsaw@gentoo.org>2007-04-20 13:18:01 +0000
commit06f37fad1e4e0efaf899b85f218b6c5186c7d6c0 (patch)
treed52dacd0a98d87f3b15bd664d9ca5ce9a77759f1 /app-laptop
parentmedia-sound/easytag:wavpack - Add support for wavpack (diff)
downloadgentoo-2-06f37fad1e4e0efaf899b85f218b6c5186c7d6c0.tar.gz
gentoo-2-06f37fad1e4e0efaf899b85f218b6c5186c7d6c0.tar.bz2
gentoo-2-06f37fad1e4e0efaf899b85f218b6c5186c7d6c0.zip
Version bump, closes bug #170106.
(Portage version: 2.1.2.4)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tp_smapi/ChangeLog9
-rw-r--r--app-laptop/tp_smapi/files/digest-tp_smapi-0.313
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.30.ebuild4
-rw-r--r--app-laptop/tp_smapi/tp_smapi-0.31.ebuild55
4 files changed, 67 insertions, 4 deletions
diff --git a/app-laptop/tp_smapi/ChangeLog b/app-laptop/tp_smapi/ChangeLog
index 4cf5aaa97631..ef803f0f9a4e 100644
--- a/app-laptop/tp_smapi/ChangeLog
+++ b/app-laptop/tp_smapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tp_smapi
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.18 2007/04/07 13:26:46 genstef Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/ChangeLog,v 1.19 2007/04/20 13:18:01 chainsaw Exp $
+
+*tp_smapi-0.31 (20 Apr 2007)
+
+ 20 Apr 2007; Tony Vroon <chainsaw@gentoo.org> +tp_smapi-0.31.ebuild:
+ Version bump, closes bug #170106.
29 Dec 2006; Stefan Schweizer <genstef@gentoo.org> tp_smapi-0.30.ebuild:
Fix for wrong kernel source in bug 159039 for jkt and uberlord
diff --git a/app-laptop/tp_smapi/files/digest-tp_smapi-0.31 b/app-laptop/tp_smapi/files/digest-tp_smapi-0.31
new file mode 100644
index 000000000000..65372177f7eb
--- /dev/null
+++ b/app-laptop/tp_smapi/files/digest-tp_smapi-0.31
@@ -0,0 +1,3 @@
+MD5 c999d10250974a188f45bbe50d2434d3 tp_smapi-0.31.tgz 35692
+RMD160 cdcd032cbb2c315b9336694c8c196b0e563a36af tp_smapi-0.31.tgz 35692
+SHA256 aa575491ec07c774eaa0258d6490d3ff5e4780272692e7b8bea043469e4087db tp_smapi-0.31.tgz 35692
diff --git a/app-laptop/tp_smapi/tp_smapi-0.30.ebuild b/app-laptop/tp_smapi/tp_smapi-0.30.ebuild
index bbef64390006..9c5f01087474 100644
--- a/app-laptop/tp_smapi/tp_smapi-0.30.ebuild
+++ b/app-laptop/tp_smapi/tp_smapi-0.30.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.30.ebuild,v 1.2 2006/12/29 19:16:49 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.30.ebuild,v 1.3 2007/04/20 13:18:01 chainsaw Exp $
inherit linux-mod
diff --git a/app-laptop/tp_smapi/tp_smapi-0.31.ebuild b/app-laptop/tp_smapi/tp_smapi-0.31.ebuild
new file mode 100644
index 000000000000..5cf1d28de811
--- /dev/null
+++ b/app-laptop/tp_smapi/tp_smapi-0.31.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tp_smapi/tp_smapi-0.31.ebuild,v 1.1 2007/04/20 13:18:01 chainsaw Exp $
+
+inherit linux-mod
+
+DESCRIPTION="IBM ThinkPad SMAPI BIOS driver"
+HOMEPAGE="http://tpctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tpctl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="hdaps"
+
+RESTRICT="userpriv"
+
+# We need dmideode if the kernel does not support DMI_DEV_TYPE_OEM_STRING
+# in dmi.h
+DEPEND="sys-apps/dmidecode"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is lt 2 6 15; then
+ eerror
+ eerror "${P} requires Linux kernel 2.6.15 or above."
+ eerror
+ die "Unsupported kernel version"
+ fi
+
+ MODULE_NAMES="thinkpad_ec(extra:) tp_smapi(extra:)"
+ BUILD_PARAMS="KSRC=${KV_DIR} KBUILD=${KV_DIR}"
+ BUILD_TARGETS="default"
+
+ if use hdaps; then
+ MODULE_NAMES="${MODULE_NAMES} hdaps(extra:)"
+ BUILD_PARAMS="${BUILD_PARAMS} HDAPS=1"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Ug, sudo in a Makefile
+ sed -i 's,sudo ,,' Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc CHANGES README
+}