summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2010-02-28 16:33:11 +0000
committerCédric Krier <cedk@gentoo.org>2010-02-28 16:33:11 +0000
commit174fa770bdaf51a18f2f3468284254d64256cad2 (patch)
treebdd3bffebb172ea0925148c7ee6e8fceaf6971e4 /app-laptop
parentFix init scripts to work with tabs for bug #301619 (diff)
downloadgentoo-2-174fa770bdaf51a18f2f3468284254d64256cad2.tar.gz
gentoo-2-174fa770bdaf51a18f2f3468284254d64256cad2.tar.bz2
gentoo-2-174fa770bdaf51a18f2f3468284254d64256cad2.zip
Version bump
(Portage version: 2.1.7.16/cvs/Linux i686)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/pommed/ChangeLog8
-rw-r--r--app-laptop/pommed/files/pommed-1.31.patch75
-rw-r--r--app-laptop/pommed/pommed-1.31.ebuild111
3 files changed, 193 insertions, 1 deletions
diff --git a/app-laptop/pommed/ChangeLog b/app-laptop/pommed/ChangeLog
index 5854d99f1d8c..bb7b381ccd86 100644
--- a/app-laptop/pommed/ChangeLog
+++ b/app-laptop/pommed/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/pommed
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/ChangeLog,v 1.49 2010/01/07 16:07:28 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/ChangeLog,v 1.50 2010/02/28 16:33:11 cedk Exp $
+
+*pommed-1.31 (28 Feb 2010)
+
+ 28 Feb 2010; Cédric Krier <cedk@gentoo.org> +pommed-1.31.ebuild,
+ +files/pommed-1.31.patch:
+ Version bump
07 Jan 2010; Joseph Jezak <josejx@gentoo.org> pommed-1.30.ebuild:
Fix for x86/amd64 kernel check not needed on ppc.
diff --git a/app-laptop/pommed/files/pommed-1.31.patch b/app-laptop/pommed/files/pommed-1.31.patch
new file mode 100644
index 000000000000..484d7bc2db57
--- /dev/null
+++ b/app-laptop/pommed/files/pommed-1.31.patch
@@ -0,0 +1,75 @@
+diff -ru pommed-1.31~/gpomme/Makefile pommed-1.31/gpomme/Makefile
+--- pommed-1.31~/gpomme/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/gpomme/Makefile 2010-02-28 17:25:31.000000000 +0100
+@@ -17,8 +17,8 @@
+
+ INOTIFY_CFLAGS = $(shell test -e /usr/include/sys/inotify.h || echo -DNO_SYS_INOTIFY_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
+-LDFLAGS = -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(DBUSGLIB_CFLAGS) $(GTK_CFLAGS) $(CONFUSE_CFLAGS) $(GLADE_CFLAGS) $(INOTIFY_CFLAGS)
++LDFLAGS += -lpthread -lX11 $(DBUS_LIBS) $(DBUSGLIB_LIBS) $(GTK_LIBS) $(CONFUSE_LIBS) $(GLADE_LIBS)
+
+ SOURCES = gpomme.c theme.c conffile.c \
+ ../client-common/dbus-client.c \
+@@ -33,6 +33,7 @@
+ mo: $(MOFILES)
+
+ gpomme: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ gpomme.o: gpomme.c gpomme.h theme.h ../client-common/dbus-client.h ../client-common/video-client.h
+
+diff -ru pommed-1.31~/pommed/Makefile pommed-1.31/pommed/Makefile
+--- pommed-1.31~/pommed/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/pommed/Makefile 2010-02-28 17:26:20.000000000 +0100
+@@ -18,9 +18,9 @@
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(ALSA_CFLAGS) $(AUDIOFILE_CFLAGS) $(CONFUSE_CFLAGS) $(INOTIFY_CFLAGS) $(TIMERFD_CFLAGS)
+
+-LDFLAGS = -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
++LDFLAGS += -pthread -lrt $(DBUS_LIBS) $(ALSA_LIBS) $(AUDIOFILE_LIBS) $(CONFUSE_LIBS)
+
+ ifneq (, $(findstring ppc, $(ARCH)))
+ OFLIB ?=
+@@ -52,6 +52,7 @@
+
+ CFLAGS += $(LIBPCI_CFLAGS)
+ LDFLAGS += $(LIBPCI_LIBS)
++ LIBS = $(LIBPCI_LIBS)
+ else
+ LIBS = /usr/lib/libpci.a
+ LDFLAGS += -lz
+@@ -69,6 +70,7 @@
+
+
+ pommed: $(OBJS) $(LIBS)
++ ${CC} -o $@ ${OBJS} ${LIBS} ${LDFLAGS}
+
+ pommed.o: pommed.c pommed.h evloop.h kbd_backlight.h lcd_backlight.h cd_eject.h evdev.h conffile.h audio.h dbus.h beep.h
+
+diff -ru pommed-1.31~/wmpomme/Makefile pommed-1.31/wmpomme/Makefile
+--- pommed-1.31~/wmpomme/Makefile 2010-02-28 17:24:31.000000000 +0100
++++ pommed-1.31/wmpomme/Makefile 2010-02-28 17:26:42.000000000 +0100
+@@ -5,8 +5,8 @@
+
+ TIMERFD_CFLAGS = $(shell test -e /usr/include/sys/timerfd.h || echo -DNO_SYS_TIMERFD_H)
+
+-CFLAGS = -g -O2 -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
+-LDFLAGS = -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
++CFLAGS += -g -Wall $(DBUS_CFLAGS) $(TIMERFD_CFLAGS)
++LDFLAGS += -lrt -lXpm -lXext -lX11 $(DBUS_LIBS)
+
+ SOURCES = wmgeneral.c wmpomme.c \
+ ../client-common/dbus-client.c \
+@@ -15,6 +15,7 @@
+ OBJS = $(SOURCES:%.c=%.o)
+
+ wmpomme: $(OBJS)
++ ${CC} -o $@ ${OBJS} ${LDFLAGS}
+
+ wmpomme.o: wmpomme.c wmgeneral.h wmpomme-master.xpm ../client-common/dbus-client.h
+
diff --git a/app-laptop/pommed/pommed-1.31.ebuild b/app-laptop/pommed/pommed-1.31.ebuild
new file mode 100644
index 000000000000..bc9ba1c6f863
--- /dev/null
+++ b/app-laptop/pommed/pommed-1.31.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/pommed/pommed-1.31.ebuild,v 1.1 2010/02/28 16:33:11 cedk Exp $
+
+inherit eutils toolchain-funcs linux-info
+
+DESCRIPTION="Manage special features such as screen and keyboard backlight on Apple MacBook Pro/PowerBook"
+HOMEPAGE="http://technologeek.org/projects/pommed/index.html"
+ALIOTH_NUMBER="3202"
+SRC_URI="http://alioth.debian.org/frs/download.php/${ALIOTH_NUMBER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk X"
+
+COMMON_DEPEND="media-libs/alsa-lib
+ x86? ( sys-apps/pciutils )
+ amd64? ( sys-apps/pciutils )
+ dev-libs/confuse
+ >=sys-apps/dbus-1.1
+ dev-libs/dbus-glib
+ sys-libs/zlib
+ media-libs/audiofile
+ gtk? ( >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2 )
+ X? ( x11-libs/libX11
+ x11-libs/libXpm )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ media-sound/alsa-utils
+ virtual/eject"
+
+pkg_setup() {
+ if ! use ppc; then
+ linux-info_pkg_setup
+
+ CONFIG_CHECK="DMIID"
+ check_extra_config
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+ cd "${S}"/pommed
+ emake CC="$(tc-getCC)" OFLIB=1 || die "emake pommed failed"
+
+ if use gtk; then
+ cd "${S}"/gpomme
+ local POFILES=""
+ for LANG in ${LINGUAS}; do
+ if [ -f po/${LANG}.po ]; then
+ POFILES="${POFILES} po/${LANG}.po"
+ fi
+ done
+ emake CC="$(tc-getCC)" POFILES="${POFILES}" || die "emake gpomme failed"
+ fi
+ if use X; then
+ cd "${S}"/wmpomme
+ emake CC="$(tc-getCC)" || die "emake wmpomme failed"
+ fi
+}
+
+src_install() {
+ insinto /etc
+ if use x86 || use amd64; then
+ newins pommed.conf.mactel pommed.conf
+ elif use ppc; then
+ newins pommed.conf.pmac pommed.conf
+ fi
+
+ insinto /etc/dbus-1/system.d
+ newins dbus-policy.conf pommed.conf
+
+ insinto /usr/share/pommed
+ doins pommed/data/*.wav
+
+ dobin pommed/pommed
+
+ newinitd "${FILESDIR}"/pommed.rc pommed
+
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use gtk ; then
+ dobin gpomme/gpomme
+ for LANG in ${LINGUAS}; do
+ if [ -f gpomme/po/${LANG}.mo ]; then
+ einfo "Installing lang ${LANG}"
+ insinto /usr/share/locale/${LANG}/LC_MESSAGES/
+ doins gpomme/po/${LANG}.mo
+ fi
+ done
+
+ insinto /usr/share/applications
+ doins gpomme/gpomme.desktop
+ doins gpomme/gpomme-c.desktop
+ insinto /usr/share/gpomme/
+ doins -r gpomme/themes
+ doins gpomme/gpomme.glade
+ fi
+
+ if use X ; then
+ dobin wmpomme/wmpomme
+ fi
+}