summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-07-17 20:02:35 +0000
committerDaniel Drake <dsd@gentoo.org>2006-07-17 20:02:35 +0000
commit23ea9e7e003a78109403767f0f4cc0367d598394 (patch)
tree1000f7b7c4ad16842cbeae07194a2f62ce377689 /app-laptop
parentStable on ppc64; bug #133524 (diff)
downloadgentoo-2-23ea9e7e003a78109403767f0f4cc0367d598394.tar.gz
gentoo-2-23ea9e7e003a78109403767f0f4cc0367d598394.tar.bz2
gentoo-2-23ea9e7e003a78109403767f0f4cc0367d598394.zip
Fix compilation on Linux 2.6.17, thanks to Henryk Plotz in bug #137646
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkpad/ChangeLog7
-rw-r--r--app-laptop/thinkpad/files/thinkpad-5.9-module-param.patch18
-rw-r--r--app-laptop/thinkpad/thinkpad-5.9-r1.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/app-laptop/thinkpad/ChangeLog b/app-laptop/thinkpad/ChangeLog
index 6c2679fd921b..28775b40eeca 100644
--- a/app-laptop/thinkpad/ChangeLog
+++ b/app-laptop/thinkpad/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/thinkpad
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.15 2006/05/09 21:41:01 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/ChangeLog,v 1.16 2006/07/17 20:02:35 dsd Exp $
+
+ 17 Jul 2006; Daniel Drake <dsd@gentoo.org>
+ +files/thinkpad-5.9-module-param.patch, -thinkpad-5.7.ebuild,
+ -thinkpad-5.8.ebuild, thinkpad-5.9-r1.ebuild:
+ Fix compilation on Linux 2.6.17, thanks to Henryk Plotz in bug #137646
09 May 2006; John N. Laliberte <allanonjl@gentoo.org>
thinkpad-5.9-r1.ebuild:
diff --git a/app-laptop/thinkpad/files/thinkpad-5.9-module-param.patch b/app-laptop/thinkpad/files/thinkpad-5.9-module-param.patch
new file mode 100644
index 000000000000..e573b59f4cce
--- /dev/null
+++ b/app-laptop/thinkpad/files/thinkpad-5.9-module-param.patch
@@ -0,0 +1,18 @@
+diff -purN thinkpad-5.9-orig/2.6/drivers/thinkpad.c thinkpad-5.9/2.6/drivers/thinkpad.c
+--- thinkpad-5.9-orig/2.6/drivers/thinkpad.c 2006-07-15 12:27:38.000000000 +0200
++++ thinkpad-5.9/2.6/drivers/thinkpad.c 2006-07-15 12:42:55.000000000 +0200
+@@ -91,11 +91,11 @@ static int enable_smapi = 1;
+ static int enable_superio = 1;
+ static int enable_rtcmosram = 1;
+ #ifdef MODULE
+-MODULE_PARM( enable_smapi, "i" );
++module_param( enable_smapi, int, S_IRUGO );
+ MODULE_PARM_DESC( enable_smapi, "Enable/disable (1/0) use of the smapi module" );
+-MODULE_PARM( enable_superio, "i" );
++module_param( enable_superio, int, S_IRUGO );
+ MODULE_PARM_DESC( enable_superio, "Enable/disable (1/0) use of the superio module" );
+-MODULE_PARM( enable_rtcmosram, "i" );
++module_param( enable_rtcmosram, int, S_IRUGO );
+ MODULE_PARM_DESC( enable_rtcmosram, "Enable/disable (1/0) use of the rtcmosram module" );
+ MODULE_AUTHOR( "Thomas Hood" );
+ MODULE_DESCRIPTION( "Metadriver for IBM ThinkPad hardware drivers" );
diff --git a/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
index a98b66087d28..f5c11af609e4 100644
--- a/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
+++ b/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild,v 1.2 2006/05/09 21:41:01 allanonjl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkpad/thinkpad-5.9-r1.ebuild,v 1.3 2006/07/17 20:02:35 dsd Exp $
inherit eutils linux-mod
@@ -48,6 +48,8 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-5.9-remove-thinkpadapm-argument.patch
epatch "${FILESDIR}"/${PN}-5.9-remove-inter_module.patch
+
+ kernel_is ge 2 6 0 && epatch "${FILESDIR}"/${P}-module-param.patch
}
src_install() {