summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-01-17 16:10:03 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-01-17 16:10:03 +0000
commit5dee517865273e68e9a21ce68a67881020fcbadd (patch)
tree4edaf974970b3c10631152db984e08789549ffe9 /app-laptop
parentadded prefix support (bug #498212) (diff)
downloadgentoo-2-5dee517865273e68e9a21ce68a67881020fcbadd.tar.gz
gentoo-2-5dee517865273e68e9a21ce68a67881020fcbadd.tar.bz2
gentoo-2-5dee517865273e68e9a21ce68a67881020fcbadd.zip
version bump (bug #498330)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/tpacpi-bat/ChangeLog9
-rw-r--r--app-laptop/tpacpi-bat/tpacpi-bat-2.1.ebuild34
2 files changed, 41 insertions, 2 deletions
diff --git a/app-laptop/tpacpi-bat/ChangeLog b/app-laptop/tpacpi-bat/ChangeLog
index 3160fbbb3be3..3fa8fb48759a 100644
--- a/app-laptop/tpacpi-bat/ChangeLog
+++ b/app-laptop/tpacpi-bat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-laptop/tpacpi-bat
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/ChangeLog,v 1.7 2013/12/06 14:49:15 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/ChangeLog,v 1.8 2014/01/17 16:10:03 ottxor Exp $
+
+*tpacpi-bat-2.1 (17 Jan 2014)
+
+ 17 Jan 2014; Christoph Junghans <ottxor@gentoo.org> +tpacpi-bat-2.1.ebuild:
+ version bump (bug #498330)
*tpacpi-bat-1.1-r1 (06 Dec 2013)
diff --git a/app-laptop/tpacpi-bat/tpacpi-bat-2.1.ebuild b/app-laptop/tpacpi-bat/tpacpi-bat-2.1.ebuild
new file mode 100644
index 000000000000..196899ca7bb5
--- /dev/null
+++ b/app-laptop/tpacpi-bat/tpacpi-bat-2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/tpacpi-bat/tpacpi-bat-2.1.ebuild,v 1.1 2014/01/17 16:10:03 ottxor Exp $
+
+EAPI=5
+
+inherit eutils systemd
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/teleshoes/tpacpi-bat.git http://github.com/teleshoes/tpacpi-bat.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/teleshoes/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+DESCRIPTION="Control battery thresholds of recent ThinkPads, which are not supported by tp_smapi"
+HOMEPAGE="https://github.com/teleshoes/tpacpi-bat"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="sys-power/acpi_call
+ dev-lang/perl"
+
+src_install() {
+ dodoc README battery_asl
+ dobin tpacpi-bat
+ newinitd "${FILESDIR}"/${PN}.initd.1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd.0 ${PN}
+ systemd_newunit tpacpi.service ${PN}.service
+}