summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-07-24 11:14:21 +0000
committerMichael Weber <xmw@gentoo.org>2014-07-24 11:14:21 +0000
commitea2c4e5f9d4b4a7a6b1bb1c06ae1e34ef3054439 (patch)
tree99de7bb8928925a6a28ed0378d2d172fb84ac371 /app-laptop
parentRemove description for USE="udisks" which is a global USE flag now. (diff)
downloadgentoo-2-ea2c4e5f9d4b4a7a6b1bb1c06ae1e34ef3054439.tar.gz
gentoo-2-ea2c4e5f9d4b4a7a6b1bb1c06ae1e34ef3054439.tar.bz2
gentoo-2-ea2c4e5f9d4b4a7a6b1bb1c06ae1e34ef3054439.zip
Revbump to fix typo in init script
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/thinkfan/ChangeLog8
-rw-r--r--app-laptop/thinkfan/files/thinkfan-0.9.2-openrc.patch11
-rw-r--r--app-laptop/thinkfan/thinkfan-0.9.2-r1.ebuild49
3 files changed, 67 insertions, 1 deletions
diff --git a/app-laptop/thinkfan/ChangeLog b/app-laptop/thinkfan/ChangeLog
index 301c3fc8a564..5dd3e9c1b2e3 100644
--- a/app-laptop/thinkfan/ChangeLog
+++ b/app-laptop/thinkfan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-laptop/thinkfan
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.18 2014/07/21 15:10:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/ChangeLog,v 1.19 2014/07/24 11:14:21 xmw Exp $
+
+*thinkfan-0.9.2-r1 (24 Jul 2014)
+
+ 24 Jul 2014; Michael Weber <xmw@gentoo.org>
+ +files/thinkfan-0.9.2-openrc.patch, +thinkfan-0.9.2-r1.ebuild:
+ Revbump to fix typo in init script
*thinkfan-0.9.2 (21 Jul 2014)
diff --git a/app-laptop/thinkfan/files/thinkfan-0.9.2-openrc.patch b/app-laptop/thinkfan/files/thinkfan-0.9.2-openrc.patch
new file mode 100644
index 000000000000..34e665321f12
--- /dev/null
+++ b/app-laptop/thinkfan/files/thinkfan-0.9.2-openrc.patch
@@ -0,0 +1,11 @@
+--- thinkfan-0.9.2/rcscripts/thinkfan.gentoo
++++ thinkfan-0.9.2/rcscripts/thinkfan.gentoo
+@@ -11,7 +11,7 @@
+
+ start() {
+ ebegin "Starting thinkfan"
+- start-stop-daemon --start --exec /usr/sbin/thinkfan -- -q -s5 -c /etc/thinkfan.com
++ start-stop-daemon --start --exec /usr/sbin/thinkfan -- -q -s5 -c /etc/thinkfan.conf
+ eend $?
+ }
+
diff --git a/app-laptop/thinkfan/thinkfan-0.9.2-r1.ebuild b/app-laptop/thinkfan/thinkfan-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..e94ea9795397
--- /dev/null
+++ b/app-laptop/thinkfan/thinkfan-0.9.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/thinkfan/thinkfan-0.9.2-r1.ebuild,v 1.1 2014/07/24 11:14:21 xmw Exp $
+
+EAPI=5
+
+inherit cmake-utils readme.gentoo systemd
+
+DESCRIPTION="simple fan control program for thinkpads"
+HOMEPAGE="http://thinkfan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atasmart"
+
+DEPEND="atasmart? ( dev-libs/libatasmart )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-openrc.patch
+
+ sed -e "s:share/doc/${PN}:share/doc/${P}:" \
+ -i CMakeLists.txt
+}
+
+src_configure() {
+ mycmakeargs+=(
+ "-DCMAKE_BUILD_TYPE:STRING=Debug"
+ "$(cmake-utils_use_use atasmart ATASMART)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ newinitd rcscripts/${PN}.gentoo ${PN}
+ systemd_dounit rcscripts/${PN}.service
+
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please read the documentation and copy an
+appropriate file to /etc/thinkfan.conf."