summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-02 18:26:25 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-02 18:26:25 +0000
commitb685ca6215ab58e7444ff27f3a3f48a43ce87717 (patch)
tree7abbadda57c58abeb98a079eba841122d89fd01e /app-misc/alexandria
parentalpha/ia64/s390/sh/sparc stable wrt #308521 (diff)
downloadgentoo-2-b685ca6215ab58e7444ff27f3a3f48a43ce87717.tar.gz
gentoo-2-b685ca6215ab58e7444ff27f3a3f48a43ce87717.tar.bz2
gentoo-2-b685ca6215ab58e7444ff27f3a3f48a43ce87717.zip
Fix QA notice about missing documentation, bug 330819.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/alexandria')
-rw-r--r--app-misc/alexandria/ChangeLog8
-rw-r--r--app-misc/alexandria/alexandria-0.6.6-r2.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/app-misc/alexandria/ChangeLog b/app-misc/alexandria/ChangeLog
index c1234be6e711..19359b53daeb 100644
--- a/app-misc/alexandria/ChangeLog
+++ b/app-misc/alexandria/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/alexandria
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.43 2010/07/30 19:52:09 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/ChangeLog,v 1.44 2010/08/02 18:26:25 graaff Exp $
+
+*alexandria-0.6.6-r2 (02 Aug 2010)
+
+ 02 Aug 2010; Hans de Graaff <graaff@gentoo.org>
+ +alexandria-0.6.6-r2.ebuild:
+ Fix QA notice about missing documentation, bug 330819.
30 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
-alexandria-0.6.5.ebuild:
diff --git a/app-misc/alexandria/alexandria-0.6.6-r2.ebuild b/app-misc/alexandria/alexandria-0.6.6-r2.ebuild
new file mode 100644
index 000000000000..50c9a57a1832
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.6-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.6-r2.ebuild,v 1.1 2010/08/02 18:26:25 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+inherit gnome2 ruby-ng
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="mirror://rubyforge/${PN}/${PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="evo"
+
+DOCS="ChangeLog README TODO doc/BUGS doc/cuecat_support.rdoc doc/FAQ doc/HACKING doc/NEWS"
+
+ruby_add_rdepend "
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.16.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/imagesize-0.1.1
+ dev-ruby/hpricot
+ evo? ( >=dev-ruby/revolution-0.5 )"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+DEPEND="${DEPEND} app-text/scrollkeeper"
+
+RUBY_PATCHES=(
+ "${FILESDIR}/${P}-Rakefile.patch"
+)
+
+each_ruby_compile() {
+ ${RUBY} -S rake || die
+}
+
+each_ruby_install() {
+ export DESTDIR="${D}" PREFIX=/usr
+ rake install_package_staging || die
+}
+
+all_ruby_install() {
+ [ -n "${DOCS}" ] && dodoc ${DOCS} || die "Failed to install documentation"
+}
+
+pkg_postinst() {
+ unset PREFIX
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ "${ROOT}/usr/bin/gconftool-2" --shutdown
+
+ echo
+ elog "To enable some book providers you will need to emerge"
+ elog "additional packages:"
+ echo
+ elog " For the Deastore book provider:"
+ elog " dev-ruby/htmlentities"
+ echo
+ elog " For Z39.50 support and the Library of Congress and"
+ elog " British Library book proviers:"
+ elog " dev-ruby/ruby-zoom"
+}