summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-15 18:41:43 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-15 18:41:43 +0000
commit9cedcf06a66bed3053592d7338297ac88ac025e3 (patch)
tree08c2d4768a5ad10e1afae9aa1a0559bf3398a202 /app-misc/detox/detox-1.2.0-r1.ebuild
parentmove media-tv to virtual/linuxtv-dvb-headers, bug #403929 (diff)
downloadgentoo-2-9cedcf06a66bed3053592d7338297ac88ac025e3.tar.gz
gentoo-2-9cedcf06a66bed3053592d7338297ac88ac025e3.tar.bz2
gentoo-2-9cedcf06a66bed3053592d7338297ac88ac025e3.zip
Moved to EAPI=4, add ~linux keywords tested by me
(Portage version: 2.2.0_alpha86/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/detox/detox-1.2.0-r1.ebuild')
-rw-r--r--app-misc/detox/detox-1.2.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/detox/detox-1.2.0-r1.ebuild b/app-misc/detox/detox-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..5afd0de1a617
--- /dev/null
+++ b/app-misc/detox/detox-1.2.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.2.0-r1.ebuild,v 1.1 2012/02/15 18:41:43 jlec Exp $
+
+EAPI=4
+
+inherit eutils
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Safely remove spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel.patch \
+ "${FILESDIR}"/${P}-LDFLAGS.patch
+ sed \
+ -e '/detoxrc.sample/d' \
+ -i Makefile.in || die
+}
+
+src_configure() {
+ econf --with-popt="${EPREFIX}/usr"
+}