summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-04-20 16:49:51 +0000
committerSamuli Suominen <drac@gentoo.org>2008-04-20 16:49:51 +0000
commit518371278af38c5df5d9fec695f18d0e6067c34e (patch)
treee91869b238d3cafe8edc26dabfb7935355bbec88 /app-misc/emelfm2
parentStable on ppc wrt bug 218407 (diff)
downloadgentoo-2-518371278af38c5df5d9fec695f18d0e6067c34e.tar.gz
gentoo-2-518371278af38c5df5d9fec695f18d0e6067c34e.tar.bz2
gentoo-2-518371278af38c5df5d9fec695f18d0e6067c34e.zip
Version bump and ~amd64 keyword wrt #217039, thanks to Tobias Jakobi.
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'app-misc/emelfm2')
-rw-r--r--app-misc/emelfm2/ChangeLog9
-rw-r--r--app-misc/emelfm2/emelfm2-0.4.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/app-misc/emelfm2/ChangeLog b/app-misc/emelfm2/ChangeLog
index 02c7e8f1ee82..abd81608e81c 100644
--- a/app-misc/emelfm2/ChangeLog
+++ b/app-misc/emelfm2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/emelfm2
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/ChangeLog,v 1.18 2007/09/07 19:12:16 josejx Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/ChangeLog,v 1.19 2008/04/20 16:49:51 drac Exp $
+
+*emelfm2-0.4 (20 Apr 2008)
+
+ 20 Apr 2008; Samuli Suominen <drac@gentoo.org> +emelfm2-0.4.ebuild:
+ Version bump and ~amd64 keyword wrt #217039, thanks to Tobias Jakobi.
07 Sep 2007; Joseph Jezak <josejx@gentoo.org> emelfm2-0.3.5.ebuild:
Marked ~ppc for bug #186562.
diff --git a/app-misc/emelfm2/emelfm2-0.4.ebuild b/app-misc/emelfm2/emelfm2-0.4.ebuild
new file mode 100644
index 000000000000..edebf3e25a21
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/emelfm2/emelfm2-0.4.ebuild,v 1.1 2008/04/20 16:49:51 drac Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A file manager that implements the popular two-pane design"
+HOMEPAGE="http://emelfm2.net"
+SRC_URI="http://${PN}.net/rel/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl unicode fam"
+
+RESTRICT="test"
+
+DEPEND=">=x11-libs/gtk+-2.12
+ fam? ( virtual/fam )
+ acl? ( sys-apps/acl )"
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e "s:${PN}/${PN}_48.png:${PN}:" \
+ docs/desktop_environment/${PN}.desktop || die "sed failed."
+ sed -i -e "s:(PREFIX)/lib:(PREFIX)/$(get_libdir):" \
+ Makefile || die "sed failed."
+}
+
+src_compile() {
+ # These options need >=x11-libs/gtk-2.12 which we depend upon
+ local myconf="USE_LATEST=1 WITH_TRANSPARENCY=1"
+
+ if use acl; then
+ myconf="${myconf} WITH_ACL=1"
+ fi
+
+ if use unicode; then
+ myconf="${myconf} FILES_UTF8ONLY=1"
+ fi
+
+ if use fam; then
+ if has_version "app-admin/gamin"; then
+ myconf="${myconf} USE_GAMIN=1"
+ else
+ myconf="${myconf} USE_FAM=1"
+ fi
+ else
+ myconf="${myconf} USE_FAM=0"
+ fi
+
+ tc-export CC
+ emake ICON_DIR="/usr/share/pixmaps/${PN}" ${myconf} || die "emake failed."
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install || die "emake install failed."
+ newicon icons/${PN}_48.png ${PN}.png
+ prepalldocs
+}