summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-27 08:02:25 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-27 08:02:25 +0000
commit5979e1afdfbdf5314d05e863a4ff26a4db1d4722 (patch)
tree0d1bdc2a1e8f63d446e2f66ad878c9ee286012e6 /app-misc/gnote
parentMask USE=applet for gtk3-based gnote, it pulls in masked gnome-panel-3. (diff)
downloadgentoo-2-5979e1afdfbdf5314d05e863a4ff26a4db1d4722.tar.gz
gentoo-2-5979e1afdfbdf5314d05e863a4ff26a4db1d4722.tar.bz2
gentoo-2-5979e1afdfbdf5314d05e863a4ff26a4db1d4722.zip
Add gtk3-based gnote-0.8.1 from the gnome overlay.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/gnote')
-rw-r--r--app-misc/gnote/ChangeLog7
-rw-r--r--app-misc/gnote/gnote-0.8.1.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/app-misc/gnote/ChangeLog b/app-misc/gnote/ChangeLog
index 65633fae98e7..066c70d0ee5a 100644
--- a/app-misc/gnote/ChangeLog
+++ b/app-misc/gnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gnote
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.12 2011/10/27 05:58:50 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/ChangeLog,v 1.13 2011/10/27 08:02:25 tetromino Exp $
+
+*gnote-0.8.1 (27 Oct 2011)
+
+ 27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> +gnote-0.8.1.ebuild:
+ Add gtk3-based gnote-0.8.1 from the gnome overlay.
27 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org> gnote-0.7.3.ebuild,
gnote-0.7.4.ebuild:
diff --git a/app-misc/gnote/gnote-0.8.1.ebuild b/app-misc/gnote/gnote-0.8.1.ebuild
new file mode 100644
index 000000000000..1fa3e2d29da1
--- /dev/null
+++ b/app-misc/gnote/gnote-0.8.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnote/gnote-0.8.1.ebuild,v 1.1 2011/10/27 08:02:25 tetromino Exp $
+
+EAPI="4"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Desktop note-taking application"
+HOMEPAGE="http://live.gnome.org/Gnote"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="applet debug"
+
+RDEPEND=">=x11-libs/gtk+-3.0:3
+ >=dev-cpp/glibmm-2.28:2
+ >=dev-cpp/gtkmm-3.0:3.0
+ >=dev-libs/libxml2-2:2
+ dev-libs/libxslt
+ >=dev-libs/libpcre-7.8:3[cxx]
+ >=dev-libs/boost-1.34
+ >=sys-apps/util-linux-2.16
+ applet? ( >=gnome-base/gnome-panel-3 )"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0
+ app-text/gnome-doc-utils
+ app-text/docbook-xml-dtd:4.1.2"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-schemas-compile
+ $(use_enable applet)
+ $(use_enable debug)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Do not set idiotic defines in a released tarball, bug #311979
+ sed 's/-DG.*_DISABLE_DEPRECATED//g' -i libtomboy/Makefile.* ||
+ die "sed failed"
+}