summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
commitc676ea5558bf9bd02aa9397693de6f3829798b05 (patch)
treec10129ee9a02b59eb7e2862a1cdf2552e5922c3e /app-misc/gtypist/gtypist-2.6.2.ebuild
parentadded X to DEPEND (diff)
downloadgentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.gz
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.bz2
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.zip
Version bumps
Diffstat (limited to 'app-misc/gtypist/gtypist-2.6.2.ebuild')
-rw-r--r--app-misc/gtypist/gtypist-2.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-misc/gtypist/gtypist-2.6.2.ebuild b/app-misc/gtypist/gtypist-2.6.2.ebuild
new file mode 100644
index 000000000000..f9a7bf72e900
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.6.2.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
+SRC_URI="mirror://gnu/gtypist/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
+IUSE="nls"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=sys-libs/ncurses-5.2"
+
+src_compile() {
+ local myconf
+
+ # gtypist uses a built in gettext
+ use nls && myconf="--enable-nls" || \
+ myconf="--disable-nls"
+
+ # gtypist also produces some Emacs/XEmacs editing modes if
+ # emacs/xemacs is present. if emacs/xemacs is not present then
+ # these emacs modes are not compiled or installed.
+
+ econf ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO THANKS
+}