summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-12-01 17:59:12 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-12-01 17:59:12 +0000
commit0ff3b4425a6e17a0ce3695d6d2b29ec2d49fb813 (patch)
tree5e8fb69c12d72c9abec3a189bc126b3d8c61b506 /app-misc/gtypist
parentVersion bump. Start of speaker screen support, camera based background suppor... (diff)
downloadgentoo-2-0ff3b4425a6e17a0ce3695d6d2b29ec2d49fb813.tar.gz
gentoo-2-0ff3b4425a6e17a0ce3695d6d2b29ec2d49fb813.tar.bz2
gentoo-2-0ff3b4425a6e17a0ce3695d6d2b29ec2d49fb813.zip
very, very minor upstream version bump including UTF-8 fixes, bug 392555
(Portage version: 2.1.10.36/cvs/Linux i686)
Diffstat (limited to 'app-misc/gtypist')
-rw-r--r--app-misc/gtypist/ChangeLog7
-rw-r--r--app-misc/gtypist/gtypist-2.9.1.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/app-misc/gtypist/ChangeLog b/app-misc/gtypist/ChangeLog
index 5b6a7b72eee3..9108d922dade 100644
--- a/app-misc/gtypist/ChangeLog
+++ b/app-misc/gtypist/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gtypist
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.30 2011/09/30 15:48:11 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/ChangeLog,v 1.31 2011/12/01 17:59:12 darkside Exp $
+
+*gtypist-2.9.1 (01 Dec 2011)
+
+ 01 Dec 2011; Jeremy Olexa <darkside@gentoo.org> +gtypist-2.9.1.ebuild:
+ very, very minor upstream version bump including UTF-8 fixes, bug 392555
30 Sep 2011; Jeremy Olexa <darkside@gentoo.org> -gtypist-2.8.5.ebuild,
gtypist-2.8.5-r1.ebuild:
diff --git a/app-misc/gtypist/gtypist-2.9.1.ebuild b/app-misc/gtypist/gtypist-2.9.1.ebuild
new file mode 100644
index 000000000000..31a43c903c4e
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.9.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gtypist/gtypist-2.9.1.ebuild,v 1.1 2011/12/01 17:59:12 darkside Exp $
+
+EAPI=4
+
+inherit eutils elisp-common
+
+DESCRIPTION="Universal typing tutor"
+HOMEPAGE="http://www.gnu.org/software/gtypist/"
+SRC_URI="mirror://gnu/gtypist/${P}.tar.xz
+ http://colemak.com/pub/learn/colemak.typ"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE="nls emacs xemacs"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ emacs? ( virtual/emacs )
+ xemacs? ( !emacs? ( app-editors/xemacs app-xemacs/fsf-compat ) )"
+
+RDEPEND="${DEPEND}"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${P}.tar.xz
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.8.3-xemacs-compat.patch
+}
+
+src_configure() {
+ local lispdir=""
+ if use emacs; then
+ lispdir="${SITELISP}/${PN}"
+ einfo "Configuring to build with GNU Emacs support"
+ elif use xemacs; then
+ lispdir="${EPREFIX}/usr/lib/xemacs/site-packages/lisp/${PN}"
+ einfo "Configuring to build with XEmacs support"
+ fi
+
+ econf $(use_enable nls) \
+ EMACS=$(usev emacs || usev xemacs || echo no) \
+ --with-lispdir="${lispdir}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ insinto /usr/share/gtypist
+ doins "${DISTDIR}"/colemak.typ
+
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}