summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 20:10:58 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-26 20:10:58 +0000
commitb0a1cbca3c94fbabba5729c18f91929aca4ac3ec (patch)
tree4259ece72b691b71adbb2fd7ccdf67e61a23c9ca /app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-b0a1cbca3c94fbabba5729c18f91929aca4ac3ec.tar.gz
gentoo-2-b0a1cbca3c94fbabba5729c18f91929aca4ac3ec.tar.bz2
gentoo-2-b0a1cbca3c94fbabba5729c18f91929aca4ac3ec.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 15841-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild')
-rw-r--r--app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild23
1 files changed, 14 insertions, 9 deletions
diff --git a/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild b/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild
index 3009f672c3f8..d9b64ae47ed4 100644
--- a/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild
+++ b/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild
@@ -1,23 +1,28 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild,v 1.3 2008/08/12 08:12:19 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/hachoir-subfile/hachoir-subfile-0.5.3.ebuild,v 1.4 2010/03/26 20:10:58 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils
-DESCRIPTION="a tool based on hachoir-parser to find subfiles in any binary stream"
-HOMEPAGE="http://hachoir.org/wiki/hachoir-subfile"
-SRC_URI="http://cheeseshop.python.org/packages/source/h/${PN}/${P}.tar.gz"
+DESCRIPTION="Find subfile in any binary stream"
+HOMEPAGE="http://bitbucket.org/haypo/hachoir/wiki/hachoir-subfile http://pypi.python.org/pypi/hachoir-subfile"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=""
RDEPEND=">=dev-python/hachoir-core-1.1
>=dev-python/hachoir-parser-1.1
- >=dev-python/hachoir-regex-1.0.2"
+ >=dev-python/hachoir-regex-1.0.1"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
-PYTHON_MODNAME="hachoir_subfile"
+DISTUTILS_GLOBAL_OPTIONS=("--setuptools")
+PYTHON_MODNAME="${PN/-/_}"