summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-20 12:15:10 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-20 12:15:10 +0000
commit753cc39949aeaeea68536dee5696722d7010b057 (patch)
treee543db1b642c3963ef9df52507a64addf5d961f1 /app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild
parentStable on ppc64 (diff)
downloadgentoo-2-753cc39949aeaeea68536dee5696722d7010b057.tar.gz
gentoo-2-753cc39949aeaeea68536dee5696722d7010b057.tar.bz2
gentoo-2-753cc39949aeaeea68536dee5696722d7010b057.zip
vb
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild')
-rw-r--r--app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild b/app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild
new file mode 100644
index 000000000000..ad9a22800167
--- /dev/null
+++ b/app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jbidwatcher/jbidwatcher-0.9.7.1.ebuild,v 1.1 2005/07/20 12:15:10 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Ebay Bidder Tools for Sniping"
+HOMEPAGE="http://jbidwatcher.sf.net/"
+SRC_URI="mirror://sourceforge/jbidwatcher/${P/_/}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 amd64 ppc"
+IUSE="jikes"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Fix bad build.xml
+ sed -i -e 's:${user.home}/.jbidwatcher:.:' \
+ -e 's:jikes:modern:' \
+ -e 's:<fileset dir="${src.dir}" includes="jbidwatcher.properties">:<fileset dir="${src.dir}" includes="jbidwatcher.properties" />:' \
+ -e '/taskdef/d' build.xml
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation failed"
+}
+
+src_install() {
+ java-pkg_newjar *.jar ${PN}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo 'java -jar $(java-config -p jbidwatcher) "$@"' >> ${PN}
+
+ dobin ${PN}
+}