summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-04-09 04:35:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-04-09 04:35:05 +0000
commit3f4721e03fe88c6b42738063cd001cffda0e6370 (patch)
tree5d2c5becf2f900d4a6728b7dbc221a21eede982a /app-misc/nut
parentBump for #465182 (diff)
downloadgentoo-2-3f4721e03fe88c6b42738063cd001cffda0e6370.tar.gz
gentoo-2-3f4721e03fe88c6b42738063cd001cffda0e6370.tar.bz2
gentoo-2-3f4721e03fe88c6b42738063cd001cffda0e6370.zip
Version bump, fix fltk linking, respect CXX, and remove old.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-misc/nut')
-rw-r--r--app-misc/nut/ChangeLog8
-rw-r--r--app-misc/nut/files/nut-18.7-fltk-linking.patch20
-rw-r--r--app-misc/nut/nut-18.7.ebuild (renamed from app-misc/nut/nut-18.6.ebuild)8
3 files changed, 33 insertions, 3 deletions
diff --git a/app-misc/nut/ChangeLog b/app-misc/nut/ChangeLog
index 42af4f892f45..c844f1c01d79 100644
--- a/app-misc/nut/ChangeLog
+++ b/app-misc/nut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/nut
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.58 2013/04/07 02:47:35 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/ChangeLog,v 1.59 2013/04/09 04:35:05 radhermit Exp $
+
+*nut-18.7 (09 Apr 2013)
+
+ 09 Apr 2013; Tim Harder <radhermit@gentoo.org> -nut-18.6.ebuild,
+ +nut-18.7.ebuild, +files/nut-18.7-fltk-linking.patch:
+ Version bump, fix fltk linking, respect CXX, and remove old.
*nut-18.6 (07 Apr 2013)
diff --git a/app-misc/nut/files/nut-18.7-fltk-linking.patch b/app-misc/nut/files/nut-18.7-fltk-linking.patch
new file mode 100644
index 000000000000..bd35c4276d71
--- /dev/null
+++ b/app-misc/nut/files/nut-18.7-fltk-linking.patch
@@ -0,0 +1,20 @@
+--- nut-18.7/fltk/Makefile
++++ nut-18.7/fltk/Makefile
+@@ -5,7 +5,7 @@
+ NUTDIR := \".nutdb\"
+ FOODDIR := \"$(libdir)\"
+ EXECUTABLE := Nut
+-LIBS := `fltk-config --libs`
++LIBS := `fltk-config --ldflags`
+
+ OS := $(shell uname -s)
+ ifeq ($(OS),HP-UX)
+@@ -31,7 +31,7 @@
+ OBJS := ../anameal.o ../db.o ../food.o ../meal.o ../options.o ../prtmenu.o ../ranking.o ../recmeal.o ../trendy.o ../util.o $(patsubst %.cc,%.o,$(SOURCE))
+
+ nut: $(OBJS)
+- $(CXX) $(OPT) $(LDFLAGS) `fltk-config --ldflags` -o $(EXECUTABLE) $(OBJS) $(LIBS)
++ $(CXX) $(OPT) $(LDFLAGS) -o $(EXECUTABLE) $(OBJS) $(LIBS)
+
+ deps:
+ makedepend -Y.. ../anameal.c ../db.c ../food.c ../meal.c ../options.c ../prtmenu.c ../recmeal.c ../util.c *.cc >/dev/null 2>&1
diff --git a/app-misc/nut/nut-18.6.ebuild b/app-misc/nut/nut-18.7.ebuild
index 1c7e1b305a82..cbacb1173b5e 100644
--- a/app-misc/nut/nut-18.6.ebuild
+++ b/app-misc/nut/nut-18.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-18.6.ebuild,v 1.1 2013/04/07 02:47:34 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/nut/nut-18.7.ebuild,v 1.1 2013/04/09 04:35:05 radhermit Exp $
EAPI=5
inherit eutils toolchain-funcs
@@ -13,8 +13,12 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~x86"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fltk-linking.patch
+}
+
src_compile() {
- emake CC="$(tc-getCC)" OPT="${CFLAGS}" FOODDIR=\\\"/usr/share/nut\\\"
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" OPT="${CFLAGS}" FOODDIR=\\\"/usr/share/nut\\\"
}
src_install() {