summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-01-02 18:28:32 +0000
committerMike Frysinger <vapier@gentoo.org>2013-01-02 18:28:32 +0000
commitc71c7f103811ca3836fc18e913b797f731da5018 (patch)
treeffb370b6e0e2087fe0a9346717b198adafa52d18 /app-misc/pax-utils/pax-utils-0.6.ebuild
parentBump to 1.9.3, thanks to slepnoga (diff)
downloadgentoo-2-c71c7f103811ca3836fc18e913b797f731da5018.tar.gz
gentoo-2-c71c7f103811ca3836fc18e913b797f731da5018.tar.bz2
gentoo-2-c71c7f103811ca3836fc18e913b797f731da5018.zip
Version bump.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'app-misc/pax-utils/pax-utils-0.6.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-0.6.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-0.6.ebuild b/app-misc/pax-utils/pax-utils-0.6.ebuild
new file mode 100644
index 000000000000..4be416b4c46e
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.6.ebuild,v 1.1 2013/01/02 18:28:32 vapier Exp $
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="caps python"
+#RESTRICT="mirror"
+
+RDEPEND="caps? ( sys-libs/libcap )
+ python? ( dev-python/pyelftools )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_PYTHON=$(usex python) \
+ "$@" || die
+}
+
+src_compile() {
+ _emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ _emake DESTDIR="${D}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+ prepalldocs
+}