summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-02-14 18:16:30 +0000
committerMike Frysinger <vapier@gentoo.org>2010-02-14 18:16:30 +0000
commite8191c5b9deea16843ad4098e51979fe36668867 (patch)
tree6ab4db2d9f1e804c5e4655aba3791c0bd5cbd165 /app-misc/pax-utils
parentold (diff)
downloadgentoo-2-e8191c5b9deea16843ad4098e51979fe36668867.tar.gz
gentoo-2-e8191c5b9deea16843ad4098e51979fe36668867.tar.bz2
gentoo-2-e8191c5b9deea16843ad4098e51979fe36668867.zip
Fix garbage in symbol matching output.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/pax-utils')
-rw-r--r--app-misc/pax-utils/ChangeLog7
-rw-r--r--app-misc/pax-utils/pax-utils-0.2.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/app-misc/pax-utils/ChangeLog b/app-misc/pax-utils/ChangeLog
index 4bb55d18c0e4..22d18f2c4a6f 100644
--- a/app-misc/pax-utils/ChangeLog
+++ b/app-misc/pax-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/pax-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.113 2010/01/15 12:39:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/ChangeLog,v 1.114 2010/02/14 18:16:30 vapier Exp $
+
+*pax-utils-0.2.1 (14 Feb 2010)
+
+ 14 Feb 2010; Mike Frysinger <vapier@gentoo.org> +pax-utils-0.2.1.ebuild:
+ Fix garbage in symbol matching output.
*pax-utils-0.2 (15 Jan 2010)
diff --git a/app-misc/pax-utils/pax-utils-0.2.1.ebuild b/app-misc/pax-utils/pax-utils-0.2.1.ebuild
new file mode 100644
index 000000000000..7a1df0523c2b
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/pax-utils/pax-utils-0.2.1.ebuild,v 1.1 2010/02/14 18:16:30 vapier Exp $
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="http://hardened.gentoo.org/pax-utils.xml"
+SRC_URI="mirror://gentoo/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/pax-utils-${PV}.tar.bz2"
+#SRC_URI="http://wh0rd.org/pax-utils-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="caps"
+#RESTRICT="mirror"
+
+DEPEND="caps? ( sys-libs/libcap )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" USE_CAP=$(use caps && echo yes) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc BUGS README TODO
+}