summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-10-04 16:59:18 +0000
committerSven Wegener <swegener@gentoo.org>2008-10-04 16:59:18 +0000
commit0b5471d3a5320e82a3d19cd274e15a883f3b6b59 (patch)
treed5f3444e3097e3aecd209fa153273dc8df364b3a /app-misc/rl/rl-0.2.7.ebuild
parentAdd the latest pre release (still hard masked) of dev-util/darcs-2.1.0. (diff)
downloadgentoo-2-0b5471d3a5320e82a3d19cd274e15a883f3b6b59.tar.gz
gentoo-2-0b5471d3a5320e82a3d19cd274e15a883f3b6b59.tar.bz2
gentoo-2-0b5471d3a5320e82a3d19cd274e15a883f3b6b59.zip
Version bump.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'app-misc/rl/rl-0.2.7.ebuild')
-rw-r--r--app-misc/rl/rl-0.2.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/rl/rl-0.2.7.ebuild b/app-misc/rl/rl-0.2.7.ebuild
new file mode 100644
index 000000000000..9e12b0a7bb2d
--- /dev/null
+++ b/app-misc/rl/rl-0.2.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/rl/rl-0.2.7.ebuild,v 1.1 2008/10/04 16:59:18 swegener Exp $
+
+DESCRIPTION="Randomize lines from text files or stdin"
+HOMEPAGE="http://ch.tudelft.nl/~arthur/rl/"
+SRC_URI="http://ch.tudelft.nl/~arthur/rl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~mips ~ppc ~s390 ~sparc ~x86"
+IUSE="debug"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}