summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-07-04 12:07:44 +0000
committerJohannes Huber <johu@gentoo.org>2012-07-04 12:07:44 +0000
commit0b836455ce2cb5be6f3d7d98116316a5f2ac3859 (patch)
tree49cffb6bce80375110b5e215bddf345518239bfe /app-misc/strigi
parentdev-cpp/gccxml: Fix doc installation location (diff)
downloadgentoo-2-0b836455ce2cb5be6f3d7d98116316a5f2ac3859.tar.gz
gentoo-2-0b836455ce2cb5be6f3d7d98116316a5f2ac3859.tar.bz2
gentoo-2-0b836455ce2cb5be6f3d7d98116316a5f2ac3859.zip
Add mandriva patch to build with ffmpeg-0.11 spotted by Hanno Boeck <hanno@gentoo.org> wrt bug #417877.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/strigi')
-rw-r--r--app-misc/strigi/ChangeLog8
-rw-r--r--app-misc/strigi/files/strigi-0.7.7-ffmpeg-0.11.patch155
-rw-r--r--app-misc/strigi/strigi-0.7.7-r1.ebuild7
3 files changed, 166 insertions, 4 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index 67ec35045ccb..6daad0d824b3 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/strigi
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.90 2012/06/14 07:12:40 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.91 2012/07/04 12:07:44 johu Exp $
+
+ 04 Jul 2012; Johannes Huber <johu@gentoo.org>
+ +files/strigi-0.7.7-ffmpeg-0.11.patch, strigi-0.7.7-r1.ebuild:
+ Add mandriva patch to build with ffmpeg-0.11 spotted by Hanno Boeck
+ <hanno@gentoo.org> wrt bug #417877.
14 Jun 2012; Ben de Groot <yngwin@gentoo.org> strigi-0.7.7.ebuild:
Destabling to ~ia64 because last available stable qt will be masked pending
@@ -466,4 +471,3 @@
strigi-0.5.1.ebuild, strigi-9999.ebuild:
Added metadata.xml and Changelog. Thanks to Franz Fellner for the initial
ebuild.
-
diff --git a/app-misc/strigi/files/strigi-0.7.7-ffmpeg-0.11.patch b/app-misc/strigi/files/strigi-0.7.7-ffmpeg-0.11.patch
new file mode 100644
index 000000000000..465eda4c71c5
--- /dev/null
+++ b/app-misc/strigi/files/strigi-0.7.7-ffmpeg-0.11.patch
@@ -0,0 +1,155 @@
+Source: Mandriva patch
+Upstream: No bug report on bugs.kde.org
+Reason: libstreamanalyzer uses deprecated symbols from ffmpeg removed in 0.11
+--- strigi-0.7.7/libstreamanalyzer/plugins/endplugins/ffmpegendanalyzer.cpp.bero 2012-06-08 16:49:40.846877030 +0200
++++ strigi-0.7.7/libstreamanalyzer/plugins/endplugins/ffmpegendanalyzer.cpp 2012-06-08 17:27:40.416888115 +0200
+@@ -305,13 +305,6 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ uint8_t pDataBuffer[32768];//65536];
+ long lSize = 32768;
+
+- ByteIOContext ByteIOCtx;
+- if(init_put_byte(&ByteIOCtx, pDataBuffer, lSize, 0, in, read_data, NULL, seek_data) < 0)
+- return -1;
+-
+- //pAVInputFormat->flags |= AVFMT_NOFILE;
+- ByteIOCtx.is_streamed = 0;
+-
+ AVProbeData pd;
+ const char *buf;
+ pd.filename ="";
+@@ -324,14 +317,27 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ if(fmt == NULL)
+ return 1;
+
+- AVFormatContext *fc = NULL;
+- if(av_open_input_stream(&fc, &ByteIOCtx, "", fmt, NULL) < 0)
++ AVFormatContext *fc = avformat_alloc_context();
++ if(!fc)
++ return -1;
++
++ AVIOContext *pb = avio_alloc_context(pDataBuffer, lSize, 0, in, read_data, NULL, seek_data);
++ if(!fc->pb) {
++ av_free(fc);
+ return -1;
++ }
++
++ fc->pb = pb;
++
++ if(avformat_open_input(&fc, "", fmt, NULL) < 0) {
++ av_free(fc);
++ return -1;
++ }
+
+- av_find_stream_info(fc);
++ avformat_find_stream_info(fc, NULL);
+
+ // Dump information about file onto standard error
+- dump_format(fc, 0, ar.path().c_str(), false);
++ av_dump_format(fc, 0, ar.path().c_str(), false);
+
+ if(fc->bit_rate)
+ ar.addValue(factory->bitrateProperty, fc->bit_rate);
+@@ -372,10 +378,10 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ ar.addTriplet(streamuri, durationPropertyName,outs.str());
+ }
+
+- //FIXME we must stop using the deprecated fuction av_metadata_get and use
++ //FIXME we must stop using the deprecated fuction av_dict_get and use
+ // av_dict_get once we are able to detect the version of FFMpeg being used
+ // using version macros. same goes for all occurences of this function.
+- AVMetadataTag *entry = av_metadata_get(stream.metadata, "language", NULL, 0);
++ AVDictionaryEntry *entry = av_dict_get(stream.metadata, "language", NULL, 0);
+ if (entry != NULL) {
+ const char *languageValue = entry->value;
+ if (size_t len = strlen(languageValue)) {
+@@ -430,7 +436,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ outs << codec.sample_rate;
+ ar.addTriplet(streamuri, sampleratePropertyName, outs.str());
+ }
+- if (codec.sample_fmt != SAMPLE_FMT_NONE) {}//FIXME sample format
++ if (codec.sample_fmt != AV_SAMPLE_FMT_NONE) {}//FIXME sample format
+
+ } else { // video stream
+
+@@ -469,7 +475,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+
+ // Tags
+
+- AVMetadataTag *entry = av_metadata_get(fc->metadata, "title", NULL, 0);
++ AVDictionaryEntry *entry = av_dict_get(fc->metadata, "title", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *titleValue = entry->value;
+@@ -478,7 +484,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "author", NULL, 0);
++ entry = av_dict_get(fc->metadata, "author", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *authorValue = entry->value;
+@@ -490,7 +496,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "copyright", NULL, 0);
++ entry = av_dict_get(fc->metadata, "copyright", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *copyrightValue = entry->value;
+@@ -499,7 +505,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "comment", NULL, 0);
++ entry = av_dict_get(fc->metadata, "comment", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *commentValue = entry->value;
+@@ -508,7 +514,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "album", NULL, 0);
++ entry = av_dict_get(fc->metadata, "album", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *albumValue = entry->value;
+@@ -520,7 +526,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "genre", NULL, 0);
++ entry = av_dict_get(fc->metadata, "genre", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *genreValue = entry->value;
+@@ -529,7 +535,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "track", NULL, 0);
++ entry = av_dict_get(fc->metadata, "track", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *trackValue = entry->value;
+@@ -538,7 +544,7 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- entry = av_metadata_get(fc->metadata, "year", NULL, 0);
++ entry = av_dict_get(fc->metadata, "year", NULL, 0);
+ if (entry != NULL)
+ {
+ const char *yearValue = entry->value;
+@@ -547,7 +553,8 @@ FFMPEGEndAnalyzer::analyze(AnalysisResul
+ }
+ }
+
+- av_close_input_stream(fc);
++ avformat_close_input(&fc);
++ av_free(pb);
+ //url_fclose(&ByteIOCtx);
+
+ return 0;
diff --git a/app-misc/strigi/strigi-0.7.7-r1.ebuild b/app-misc/strigi/strigi-0.7.7-r1.ebuild
index 06af1bf536b5..b84fb2c8b0cc 100644
--- a/app-misc/strigi/strigi-0.7.7-r1.ebuild
+++ b/app-misc/strigi/strigi-0.7.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.7-r1.ebuild,v 1.2 2012/05/17 16:42:29 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.7.7-r1.ebuild,v 1.3 2012/07/04 12:07:44 johu Exp $
EAPI=4
@@ -48,7 +48,10 @@ DEPEND="${COMMONDEPEND}
test? ( dev-util/cppunit )"
RDEPEND=${COMMONDEPEND}
-PATCHES=( "${FILESDIR}/${P}-gcc47.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-gcc47.patch"
+ "${FILESDIR}/${P}-ffmpeg-0.11.patch"
+)
src_configure() {
# Enabled: POLLING (only reliable way to check for files changed.)